<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US">
<head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>

<script type="rocketlazyloadscript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WP68QHT');</script>

<script type="rocketlazyloadscript" src="https://us.connextra.com/dcs/tagController/tag/362820167f7c/homepage" async defer></script>
<meta name="verifyownership" content="8b17572d9adc3b6cbc654dc1d5d043e5" />
<meta name="verifyownership" content="16a1e10dad87b5c0fc759f5de4f6f60e" />
<script type="rocketlazyloadscript" data-minify="1" async src="https://cavaliersnation.com/wp-content/cache/min/1/ht/p/184031-43290852983293.js?ver=1661215680"></script>

<script type="rocketlazyloadscript">
        var _comscore = _comscore || [];
        _comscore.push({ c1: "2", c2: "6035223" });
        (function() {
            var s = document.createElement("script"), el =
                document.getElementsByTagName("script")[0]; s.async = true;
            s.src = (document.location.protocol == "https:" ? "https://sb" :
                    "http://b") +
                ".scorecardresearch.com/beacon.js";
            el.parentNode.insertBefore(s, el);
        })();
    </script>
<noscript>
        <img data-hero src="https://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" />
    </noscript>

<script type="rocketlazyloadscript" data-minify="1" async custom-element="amp-ad" src="https://cavaliersnation.com/wp-content/cache/min/1/v0/amp-ad-0.1.js?ver=1661215680"></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type="text/javascript" async="async" src="https://cavaliersnation.com/wp-content/cache/min/1/outbrain.js?ver=1661215681"></script>
<meta name="google-site-verification" content="KStSRn6409ttzCYidg-n9MD7blSVvoj25HKqQg3hg5Y" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<meta property="og:image" content="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_8535056_168386351_lowres-e1661215473993-615x400.jpg" />
<title>Who won? Grading the Kyrie Irving trade from the Cavs to the Celtics 5 years later - Cavaliers Nation</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Open%20Sans%20Condensed%3A300%2C700%7COpen%20Sans%3A400%2C700%7COswald%3A300%2C400%2C700&#038;subset=latin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese&#038;display=swap" /><style id="" media="print" onload="this.media='all'">@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 400;
  font-stretch: normal;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/opensans/v34/memSYaGs126MiZpBA-UvWbX2vVnXBbObj2OVZyOOSr4dVJWUgsjZ0C4n.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 700;
  font-stretch: normal;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/opensans/v34/memSYaGs126MiZpBA-UvWbX2vVnXBbObj2OVZyOOSr4dVJWUgsg-1y4n.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans Condensed';
  font-style: normal;
  font-weight: 300;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/opensanscondensed/v23/z7NFdQDnbTkabZAIOl9il_O6KJj73e7Ff1GhPuI.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans Condensed';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/opensanscondensed/v23/z7NFdQDnbTkabZAIOl9il_O6KJj73e7Ff0GmPuI.ttf) format('truetype');
}
@font-face {
  font-family: 'Oswald';
  font-style: normal;
  font-weight: 300;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/oswald/v49/TK3_WkUHHAIjg75cFRf3bXL8LICs169vgUE.ttf) format('truetype');
}
@font-face {
  font-family: 'Oswald';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/oswald/v49/TK3_WkUHHAIjg75cFRf3bXL8LICs1_FvgUE.ttf) format('truetype');
}
@font-face {
  font-family: 'Oswald';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/oswald/v49/TK3_WkUHHAIjg75cFRf3bXL8LICs1xZogUE.ttf) format('truetype');
}
</style><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%20Condensed%3A300%2C700%7COpen%20Sans%3A400%2C700%7COswald%3A300%2C400%2C700&#038;subset=latin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese&#038;display=swap" /></noscript>
<!--[if IE]>

<link rel="stylesheet" type="text/css" href="https://cavaliersnation.com/wp-content/themes/gameday/css/iecss.css" />

<![endif]-->
<link rel="shortcut icon" href="https://cavaliersnation.com/wp-content/uploads/2017/10/cavaliersnationlogo-1.jpg" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://cavaliersnation.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://cavaliersnation.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://cavaliersnation.com/feed/atom/" />
<link rel="pingback" href="https://cavaliersnation.com/xmlrpc.php" />
<script type="rocketlazyloadscript">
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-56943371-1', 'auto');
  ga('send', 'pageview');

</script>
<script type="rocketlazyloadscript">!function(){"use strict";for(var t=window.location.search.substring(1).split("&"),e=0;e<t.length;e++){var i="adt_ei",a=t[e];if(0===a.indexOf(i)){var r=a.split(i+"=")[1];localStorage.setItem(i,r),t.splice(e,1),history.replaceState(null,"","?"+t.join("&"));break}}}();
</script><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<style data-no-optimize="1" data-cfasync="false">
	.adthrive-ad {
		margin-top: 10px;
		margin-bottom: 10px;
		text-align: center;
		overflow-x: visible;
		clear: both;
		line-height: 0;
	}
	.adthrive-footer {
z-index:10000001 !important;
}

.adthrive-sidebar.adthrive-stuck {
margin-top: 54px !important;
}

#AdThrive_Sidebar_9_desktop {
margin-left: 12px !important;
}

body.archive #AdThrive_Sidebar_9_desktop:not(.adthrive-stuck) {
position:absolute;
left:0px;
top:1163px;
}

body.home .adthrive-content {
padding: 20px 0 0 0;
}

/* Fix for left aligned ads, 10/11/19 */
.adthrive-ad > div[id^='google_ads_iframe'] {margin: 0 auto !important;}
.adthrive-ad iframe {max-width: none !important;}

.adthrive-device-phone .adthrive-player-position.adthrive-collapse-mobile, .adthrive-device-tablet .adthrive-player-position.adthrive-collapse-mobile {
top: 80px;
}

.adthrive-collapse-player {
    width: 100%;
    border-top: 0px;
    border-bottom: 0px;
    padding: 5px !important;
}</style>
<script data-no-optimize="1" data-cfasync="false">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</script>
<script data-no-optimize="1" data-cfasync="false">
(function(w, d) {
	w.adthrive = w.adthrive || {};
	w.adthrive.cmd = w.adthrive.cmd || [];
	w.adthrive.plugin = 'adthrive-ads-2.2.2';
	w.adthrive.host = 'ads.adthrive.com';
	w.adthrive.integration = 'plugin';

	var commitParam = (w.adthriveCLS && w.adthriveCLS.bucket !== 'prod' && w.adthriveCLS.branch) ? '&commit=' + w.adthriveCLS.branch : '';

	var s = d.createElement('script');
	s.async = true;
	s.referrerpolicy='no-referrer-when-downgrade';
	s.src = 'https://' + w.adthrive.host + '/sites/5b48a37c9be6984315eaf2ce/ads.min.js?referrer=' + w.encodeURIComponent(w.location.href) + commitParam + '&cb=' + (Math.floor(Math.random() * 100) + 1) + '';
	var n = d.getElementsByTagName('script')[0];
	n.parentNode.insertBefore(s, n);
})(window, document);
</script>

<meta name="description" content="One of the most important trades in Cleveland Cavaliers franchise history took place on Aug. 30, 2017 when the team shipped star guard Kyrie Irving to the Boston Celtics." />
<link rel="canonical" href="https://cavaliersnation.com/2022/08/22/who-won-grading-the-kyrie-irving-trade-from-the-cavs-to-the-celtics-5-years-later/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Who won? Grading the Kyrie Irving trade from the Cavs to the Celtics 5 years later" />
<meta property="og:description" content="One of the most important trades in Cleveland Cavaliers franchise history took place on Aug. 30, 2017 when the team shipped star guard Kyrie Irving to the Boston Celtics." />
<meta property="og:url" content="https://cavaliersnation.com/2022/08/22/who-won-grading-the-kyrie-irving-trade-from-the-cavs-to-the-celtics-5-years-later/" />
<meta property="og:site_name" content="Cavaliers Nation" />
<meta property="article:publisher" content="https://www.facebook.com/CavaliersNation/" />
<meta property="article:published_time" content="2022-08-23T00:45:07+00:00" />
<meta property="article:modified_time" content="2022-08-23T00:47:26+00:00" />
<meta property="og:image" content="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_8535056_168386351_lowres-e1661215473993.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="811" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="author" content="Peter Dewey" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@WeAreCavsNation" />
<meta name="twitter:site" content="@WeAreCavsNation" />
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Cavaliers Nation &raquo; Feed" href="https://cavaliersnation.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Cavaliers Nation &raquo; Comments Feed" href="https://cavaliersnation.com/comments/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://cavaliersnation.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link data-minify="1" rel='stylesheet' id='easy_author_image-css' href='https://cavaliersnation.com/wp-content/cache/min/1/wp-content/plugins/easy-author-image/css/easy-author-image.css?ver=1661215680' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='wp-pagenavi-css' href='https://cavaliersnation.com/wp-content/cache/min/1/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=1661215680' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='mvp-style-css' href='https://cavaliersnation.com/wp-content/cache/min/1/wp-content/themes/gameday/style.css?ver=1661215680' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='reset-css' href='https://cavaliersnation.com/wp-content/cache/min/1/wp-content/themes/gameday/css/reset.css?ver=1661215680' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='media-queries-css' href='https://cavaliersnation.com/wp-content/cache/min/1/wp-content/themes/gameday/css/media-queries.css?ver=1661215680' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='flexcss-css' href='https://cavaliersnation.com/wp-content/cache/min/1/wp-content/themes/gameday/css/flexslider.css?ver=1661215680' type='text/css' media='all' />
<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player:focus-within{outline: 2px solid currentColor;outline-offset: 5px;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:100%;width:100%;left:0;top:0;position:absolute;background:url(https://cavaliersnation.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat center;background-color: transparent !important;cursor:pointer;border:none;}
</style>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/sticky-menu-or-anything-on-scroll/assets/js/jq-sticky-anything.min.js?ver=2.1.1' id='stickyAnythingLib-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/wp-retina-2x/app/picturefill.min.js?ver=1660238187' id='wr2x-picturefill-js-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/lozad.min.js?ver=6.0.1' id='lozad-js' defer></script>
<link rel="https://api.w.org/" href="https://cavaliersnation.com/wp-json/" /><link rel="alternate" type="application/json" href="https://cavaliersnation.com/wp-json/wp/v2/posts/56810" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://cavaliersnation.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cavaliersnation.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0.1" />
<link rel='shortlink' href='https://cavaliersnation.com/?p=56810' />
<link rel="alternate" type="application/json+oembed" href="https://cavaliersnation.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcavaliersnation.com%2F2022%2F08%2F22%2Fwho-won-grading-the-kyrie-irving-trade-from-the-cavs-to-the-celtics-5-years-later%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://cavaliersnation.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcavaliersnation.com%2F2022%2F08%2F22%2Fwho-won-grading-the-kyrie-irving-trade-from-the-cavs-to-the-celtics-5-years-later%2F&#038;format=xml" />
<link rel="dns-prefetch" href="https://ads.adthrive.com/"><link rel="preconnect" href="https://ads.adthrive.com/"><link rel="preconnect" href="https://ads.adthrive.com/" crossorigin>
<style type='text/css'>



		#nav-main-wrapper { background: #1a1a1a url(https://cavaliersnation.com/wp-content/themes/gameday/images/nav-bg.png) repeat-x bottom; }



		span.headlines-header, #content-social { background: #1a1a1a }



		#nav-mobi select { background: #1a1a1a url(https://cavaliersnation.com/wp-content/themes/gameday/images/triangle-dark.png) no-repeat right; }



		.category-heading { background: #1a1a1a url(https://cavaliersnation.com/wp-content/themes/gameday/images/striped-bg.png); }



		ul.score-nav li.active, ul.score-nav li.active:hover, .blog-cat li, .blog-cat-title, .flex-control-paging li a.flex-active { background: #260580; }



		.prev-post, .next-post { color: #260580; }



		a, a:visited { color: #8f1b1b; }



		h3#reply-title, h2.comments, #related-posts h3, h4.widget-header, h4.widget-header-fb { background: #8f1b1b url(https://cavaliersnation.com/wp-content/themes/gameday/images/striped-bg.png); }



		#wallpaper { background: url() no-repeat 50% 0; }



		</style><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style> <meta name="onesignal" content="wordpress-plugin" />
<script type="rocketlazyloadscript">

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://cavaliersnation.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'b691d3c3-97cc-4969-a5c2-2d07e83c1aba';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://cavaliersnation.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.28671d66-3da8-4a50-bcc4-1b29e015670b";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #141414; }
</style>
<link rel="amphtml" href="https://cavaliersnation.com/2022/08/22/who-won-grading-the-kyrie-irving-trade-from-the-cavs-to-the-celtics-5-years-later/amp/"><link rel="icon" href="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" sizes="32x32" />
<link rel="icon" href="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" />
<meta name="msapplication-TileImage" content="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" />
<script data-no-optimize='1' data-cfasync='false' id='cls-disable-ads-144ef04'>var cls_disable_ads=function(t){"use strict";var e=function(t){var e=window.location.href;return t.some((function(t){return new RegExp(t,"i").test(e)}))},i=function(){function t(t){this.adthrive=t,this.all=!1,this.content=!1,this.recipe=!1,this.video=!1,this.locations=new Set,this.reasons=new Set,(this.urlHasEmail(window.location.href)||this.urlHasEmail(window.document.referrer))&&(this.all=!0,this.reasons.add("all_email"));try{this.checkCommandQueue(),null!==document.querySelector(".tag-novideo")&&(this.video=!0,this.locations.add("Video"),this.reasons.add("video_tag"))}catch(t){}}return t.prototype.checkCommandQueue=function(){var t=this;this.adthrive&&this.adthrive.cmd&&this.adthrive.cmd.forEach((function(e){var i=e.toString(),a=t.extractAPICall(i,"disableAds");a&&t.disableAllAds(t.extractPatterns(a));var n=t.extractAPICall(i,"disableContentAds");n&&t.disableContentAds(t.extractPatterns(n));var s=t.extractAPICall(i,"disablePlaylistPlayers");s&&t.disablePlaylistPlayers(t.extractPatterns(s))}))},t.prototype.extractPatterns=function(t){var e=t.match(/\'(.*?)\'/g);if(null!==e)return e.map((function(t){return t.replace(/'/g,"")}))},t.prototype.extractAPICall=function(t,e){var i=new RegExp(e+"\\((.*?)\\)","g"),a=t.match(i);return null!==a&&a[0]},t.prototype.disableAllAds=function(t){t&&!e(t)||(this.all=!0,this.reasons.add("all_page"))},t.prototype.disableContentAds=function(t){t&&!e(t)||(this.content=!0,this.recipe=!0,this.locations.add("Content"),this.locations.add("Recipe"),this.reasons.add("content_plugin"))},t.prototype.disablePlaylistPlayers=function(t){t&&!e(t)||(this.video=!0,this.locations.add("Video"),this.reasons.add("video_page"))},t.prototype.urlHasEmail=function(t){if(!t)return!1;return null!==/([A-Z0-9._%+-]+(@|%(25)*40)[A-Z0-9.-]+\.[A-Z]{2,})/i.exec(t)},t}(),a=window.adthriveCLS;return a&&(a.disableAds=new i(window.adthrive)),t.ClsDisableAds=i,Object.defineProperty(t,"__esModule",{value:!0}),t}({});
</script><script data-no-optimize='1' data-cfasync='false' id='cls-header-insertion-144ef04'>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</script><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript>
<style type="text/css">

@media only screen and (max-width : 480px) {
.fb_iframe_widget span {
    width: 100% !important;
}
#post-area p {
	
        font-size: 16px !important;

	}
 }
#top-spacer {display: none;}
#wrapper {top: 50px !important;}
#post-area p {
	display: block;
        font-size: 15px;
	margin-bottom: 15px;
	}
.amp-ad-wrapper {text-align: center;}
</style>
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-56810 single-format-standard custom-background">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WP68QHT"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="site">
<div id="wrapper">
<div id="nav-main-wrapper">
<div id="nav-main">
<div id="nav-main-left">
<div id="nav-logo">
<a href="https://cavaliersnation.com"><img width="222" height="95" data-hero src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20222%2095'%3E%3C/svg%3E" alt="Cavaliers Nation" data-lazy-src="https://cavaliersnation.com/wp-content/uploads/2019/05/cnwebsite12.png" /><noscript><img width="222" height="95" data-hero src="https://cavaliersnation.com/wp-content/uploads/2019/05/cnwebsite12.png" alt="Cavaliers Nation" /></noscript></a>
</div>
<ul class="nav-main">
<div class="menu-home-container"><ul id="menu-home" class="menu"><li id="menu-item-75" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75"><a href="https://cavaliersnation.com/">Home</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-41"><a title="Categories">Categories</a>
<ul class="sub-menu">
<li id="menu-item-81" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a href="https://cavaliersnation.com/category/game-reports/">Game Reports</a></li>
<li id="menu-item-82" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-82"><a href="https://cavaliersnation.com/category/editorials/">Editorials</a></li>
<li id="menu-item-84" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84"><a href="https://cavaliersnation.com/category/team-news/">Team News</a></li>
<li id="menu-item-85" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a href="https://cavaliersnation.com/category/rumors/">Rumors</a></li>
<li id="menu-item-83" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83"><a href="https://cavaliersnation.com/category/media/">Media</a></li>
<li id="menu-item-86" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-86"><a href="https://cavaliersnation.com/category/videos/">Videos</a></li>
</ul>
</li>
<li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://cavaliersnation.com/schedule/">Schedule</a></li>
<li id="menu-item-48" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48"><a href="https://cavaliersnation.com/contributors/">Contributors</a></li>
<li id="menu-item-40" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a href="https://cavaliersnation.com/about/">About</a></li>
<li id="menu-item-9117" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9117"><a href="https://cavaliersnation.com/career/">Career</a></li>
</ul></div>
</ul>
<div id="nav-mobi">
<div class="menu-home-container"><select><option value="#">Menu</option><option value="https://cavaliersnation.com/">Home</option>
<option value="">Categories	<option value="https://cavaliersnation.com/category/game-reports/">-Game Reports</option>
<option value="https://cavaliersnation.com/category/editorials/">-Editorials</option>
<option value="https://cavaliersnation.com/category/team-news/">-Team News</option>
<option value="https://cavaliersnation.com/category/rumors/">-Rumors</option>
<option value="https://cavaliersnation.com/category/media/">-Media</option>
<option value="https://cavaliersnation.com/category/videos/">-Videos</option>
</option>
<option value="https://cavaliersnation.com/schedule/">Schedule</option>
<option value="https://cavaliersnation.com/contributors/">Contributors</option>
<option value="https://cavaliersnation.com/about/">About</option>
<option value="https://cavaliersnation.com/career/">Career</option>
</select></div>
</div>
</div>
<div id="nav-search">
<form method="get" id="searchform" action="https://cavaliersnation.com/">
<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
<input type="hidden" id="search-button" />
</form>
</div>
</div>
</div>
<div id="main-wrapper">
<div id="top-spacer"></div>
<div id="content-outer">
<div id="main-top">
<div id="ticker">
<span class="ticker-heading">Don't Miss</span>
<ul class="ticker-list">
<li><a href="https://cavaliersnation.com/2022/08/22/who-won-grading-the-kyrie-irving-trade-from-the-cavs-to-the-celtics-5-years-later/">Who won? Grading the Kyrie Irving trade from the Cavs to the Celtics 5 years later</a></li>
<li><a href="https://cavaliersnation.com/2022/08/20/report-collin-sexton-has-been-described-as-fast-and-explosive-by-those-who-have-seen-him-this-offseason/">Report: Collin Sexton described as &#8216;fast&#8217; and &#8216;explosive&#8217; by those who have seen him this offseason</a></li>
<li><a href="https://cavaliersnation.com/2022/08/20/report-cavs-have-had-conversations-with-mavericks-about-sign-and-trade-for-collin-sexton/">Report: Cavs have had conversations with Mavericks about sign-and-trade for Collin Sexton</a></li>

<li><a href="https://cavaliersnation.com/2022/08/19/video-development-team-has-been-working-with-evan-mobley-using-kevin-durant-as-study-sample/">Video: Development team has been working with Evan Mobley, using Kevin Durant as study sample</a></li>
<li><a href="https://cavaliersnation.com/2022/08/18/former-cavs-big-man-expresses-disappointment-with-browns-statement-on-deshaun-watson/">Former Cavs big man expresses disappointment with Browns statement on Deshaun Watson</a></li>
<li><a href="https://cavaliersnation.com/2022/08/17/report-cavs-have-discussed-cedi-osman-in-several-trade-scenarios-this-offseason/">Report: Cavs have discussed Cedi Osman in &#8216;several trade scenarios&#8217; this offseason</a></li>
<li><a href="https://cavaliersnation.com/2022/08/17/video-cedi-osman-puts-on-show-for-turkish-national-team-with-22-point-performance/">Video: Cedi Osman puts on show for Turkish national team with 22-point performance</a></li>
<li><a href="https://cavaliersnation.com/2022/08/16/cavs-insider-says-team-will-have-decent-amount-of-nationally-televised-games/">Cavs insider says team will have &#8216;decent&#8217; amount of nationally televised games this season</a></li>
<li><a href="https://cavaliersnation.com/2022/08/16/report-cavs-to-begin-regular-season-vs-raptors-host-lakers-in-december/">Report: Cavs to begin regular season vs. Raptors, host Lakers in December</a></li>
<li><a href="https://cavaliersnation.com/2022/08/15/brandon-jennings-validates-darius-garlands-offseason-work-with-7-word-declaration/">Brandon Jennings validates Darius Garland&#8217;s offseason work with 7-word declaration</a></li>
</ul>
</div>
<div id="content-social">
<ul>
<li><a href="https://www.facebook.com/cavaliersnation" alt="Facebook" class="fb-but" target="_blank"></a></li>
<li><a href="https://www.twitter.com/wearecavsnation" alt="Twitter" class="twitter-but" target="_blank"></a></li>
<li><a href="https://www.instagram.com/cavaliersnationdotcom" alt="Instagram" class="instagram-but" target="_blank"></a></li>
<li><a href="https://cavaliersnation.com/feed/rss/" alt="RSS Feed" class="rss-but"></a></li>
</ul>
</div>
</div>
<div id="content-inner">
<div id="main">
<div class="breadcrumb">
<div id="crumbs"><a href="https://cavaliersnation.com">Home</a> / <a href="https://cavaliersnation.com/category/editorials/">Editorials</a> / <span class="current">Who won? Grading the Kyrie Irving trade from the Cavs to the Celtics 5 years later</span></div>
</div>
<h1 class="headline">Who won? Grading the Kyrie Irving trade from the Cavs to the Celtics 5 years later</h1>
<div id="post-info-wrapper">
<ul class="post-info">
<li><div class="post-author">By <a href="https://cavaliersnation.com/author/peter-dewey/" title="Posts by Peter Dewey" rel="author">Peter Dewey</a></div></li>
<li>
<ul class="post-social">
<li>
<div class="fb-like" data-send="false" data-layout="button_count" data-width="90" data-show-faces="false"></div>
</li>
<li>
<a href="https://twitter.com/share" class="twitter-share-button" data-lang="en" data-count="horizontal">Tweet</a>
</li>
<li>
<g:plusone size="medium" annotation="bubble" width="120"></g:plusone>
</li>
<li>
 <a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fcavaliersnation.com%2F2022%2F08%2F22%2Fwho-won-grading-the-kyrie-irving-trade-from-the-cavs-to-the-celtics-5-years-later%2F&media=https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_8535056_168386351_lowres-e1661215473993.jpg&description=Who won? Grading the Kyrie Irving trade from the Cavs to the Celtics 5 years later" class="pin-it-button" count-layout="horizontal">Pin It</a>
</li>
</ul>
</li>
<li><div class="post-update">Updated: August 22, 2022</div></li>
</ul>
</div>
<div id="post-area" class="post-56810 post type-post status-publish format-standard has-post-thumbnail category-editorials tag-ante-zizic tag-boston-celtics tag-cleveland-cavaliers tag-collin-sexton tag-featured tag-isaiah-thomas tag-jae-crowder tag-kyrie-irving tag-news-ticker">
<div class="post-image">
<img width="1200" height="811" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20811'%3E%3C/svg%3E" class="attachment-post-thumb size-post-thumb wp-post-image" alt="Kyrie Irving and Isaiah Thomas" data-hero="" data-lazy-srcset="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_8535056_168386351_lowres-e1661215473993.jpg 1200w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_8535056_168386351_lowres-e1661215473993-300x203.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_8535056_168386351_lowres-e1661215473993-1024x692.jpg 1024w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_8535056_168386351_lowres-e1661215473993-768x519.jpg 768w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-lazy-src="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_8535056_168386351_lowres-e1661215473993.jpg" /><noscript><img width="1200" height="811" src="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_8535056_168386351_lowres-e1661215473993.jpg" class="attachment-post-thumb size-post-thumb wp-post-image" alt="Kyrie Irving and Isaiah Thomas" data-hero="" srcset="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_8535056_168386351_lowres-e1661215473993.jpg 1200w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_8535056_168386351_lowres-e1661215473993-300x203.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_8535056_168386351_lowres-e1661215473993-1024x692.jpg 1024w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_8535056_168386351_lowres-e1661215473993-768x519.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /></noscript>
</div>
<div id="content-area">
<p>One of the most important trades in <a title="Cleveland Cavaliers" href="https://cavaliersnation.com/tag/cleveland-cavaliers/">Cleveland Cavaliers</a> franchise history took place on Aug. 30, 2017 when the team shipped star guard <a title="Kyrie Irving" href="https://cavaliersnation.com/tag/kyrie-irving/">Kyrie Irving</a> to the Boston Celtics.</p>
<p>Irving, who had helped Cleveland win an NBA title in the 2015-16 season, wanted out from Cleveland after spending multiple seasons in <a title="LeBron James" href="https://cavaliersnation.com/tag/lebron-james/">LeBron James</a>’ shadow. The Cavs had lost in the NBA Finals in the 2016-17 season, and yet they were essentially forced into moving their second best player prior to the start of the 2017-18 campaign.</p>
<p>So, what did Cleveland get in return? Well, the Cavs received a few pieces from Boston, including guard <a title="Isaiah Thomas" href="https://cavaliersnation.com/tag/isaiah-thomas/">Isaiah Thomas</a>, who was an All-Star in the 2016-17 season and averaged 28.9 points per game.</p>
<p>Along with Thomas, the Cavs received forward Jae Crowder, big man <a title="Ante Zizic" href="https://cavaliersnation.com/tag/ante-zizic/">Ante Zizic</a> and a first-round pick in the 2018 NBA Draft.</p>
<div class="lozad" data-twitter-src="https://twitter.com/theScore/status/1561753749294645248"></div>
<p>The pick that Boston traded was actually the Brooklyn Nets’ first-round pick that season from a previous deal between those two franchises. It ended up becoming the No. 8 pick in the 2018 NBA Draft, where the Cavs took guard <a title="Collin Sexton" href="https://cavaliersnation.com/tag/collin-sexton/">Collin Sexton</a>. Fast forward to the 2022 offseason, and Sexton is a restricted free agent. He has yet to agree to a long-term deal with the Cavs.</p>
<p>Neither team has gone on to win an NBA title since the Irving deal was made, but both the Cavs and Celtics have made an NBA Finals in the seasons following the deal.</p>
<p>Cleveland has gone through a major rebuild following the departure of James for the Los Angeles Lakers, and yet, it finds itself back in a position to be a playoff team in the 2022-23 campaign.</p>
<p>As for the Celtics, well, they have learned that life after Irving is better than it was with him, making the NBA Finals in the 2021-22 season before losing to the Golden State Warriors.</p>
<p>Does that make either team a clear winner?</p>
<p>Let’s grade the Cavs’ Irving swap now that everything has played out for several seasons:</p>
<h2>Grading the Cavs haul</h2>
<p><img class="size-full wp-image-48686" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%202560%201707'%3E%3C/svg%3E" alt="Isaiah Thomas Cavs" width="2560" height="1707" data-lazy-srcset="https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_10579601_168386351_lowres-scaled.jpg 2560w, https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_10579601_168386351_lowres-300x200.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_10579601_168386351_lowres-1024x683.jpg 1024w, https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_10579601_168386351_lowres-1536x1024.jpg 1536w, https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_10579601_168386351_lowres-2048x1365.jpg 2048w, https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_10579601_168386351_lowres-300x200@2x.jpg 600w" data-lazy-sizes="(max-width: 2560px) 100vw, 2560px" data-lazy-src="https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_10579601_168386351_lowres-scaled.jpg" /><noscript><img class="size-full wp-image-48686" src="https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_10579601_168386351_lowres-scaled.jpg" alt="Isaiah Thomas Cavs" width="2560" height="1707" srcset="https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_10579601_168386351_lowres-scaled.jpg 2560w, https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_10579601_168386351_lowres-300x200.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_10579601_168386351_lowres-1024x683.jpg 1024w, https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_10579601_168386351_lowres-1536x1024.jpg 1536w, https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_10579601_168386351_lowres-2048x1365.jpg 2048w, https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_10579601_168386351_lowres-300x200@2x.jpg 600w" sizes="(max-width: 2560px) 100vw, 2560px" /></noscript></p>
<p><strong>Cavs received:</strong> <a title="Isaiah Thomas" href="https://cavaliersnation.com/tag/isaiah-thomas/">Isaiah Thomas</a>, Jae Crowder, <a title="Ante Zizic" href="https://cavaliersnation.com/tag/ante-zizic/">Ante Zizic</a>, 2018 first-round pick (became <a title="Collin Sexton" href="https://cavaliersnation.com/tag/collin-sexton/">Collin Sexton</a>)</p>
<p>There’s no doubt that the Cavs gave up the best player in this trade, but they still went on to make the NBA Finals in the 2017-18 season (thanks to James).</p>
<p>At the time, Thomas seemed like a comparable player to receive for Irving, as he was coming off his best season of his career. However, a hip injury derailed Thomas’ time with the Cavs, and the rest of his NBA career.</p>
<p>Thomas played in just 15 games for Cleveland, averaging 14.7 points per game and was eventually dealt to the Los Angeles Lakers as part of a package that sent <a title="Jordan Clarkson" href="https://cavaliersnation.com/tag/jordan-clarkson/">Jordan Clarkson</a> and <a title="Larry Nance Jr" href="https://cavaliersnation.com/tag/larry-nance-jr/">Larry Nance Jr</a>. to Cleveland.</p>
<p>Both of those players went on to have major roles in Cleveland’s playoff run that season, but neither player is still on the Cavs. Nance lasted longer with Cleveland than Clarkson, but he was dealt last offseason to help the Cavs bring in forward <a title="Lauri Markkanen" href="https://cavaliersnation.com/tag/lauri-markkanen/">Lauri Markkanen</a>.</p>
<p>Crowder’s stay in Cleveland was short as well, as the team traded him to the Utah Jazz at the trade deadline in the 2017-18 season. <a title="Rodney Hood" href="https://cavaliersnation.com/tag/rodney-hood/">Rodney Hood</a> and <a title="George Hill" href="https://cavaliersnation.com/tag/george-hill/">George Hill</a> were the two players that Cleveland received in the deal that sent Crowder to the Jazz.</p>
<p>Crowder has since gone on to play a major role on two teams that made the NBA Finals recently (the Miami Heat and Phoenix Suns).</p>
<p>As for Zizic, he played sparingly for the Cavs for three seasons, appearing in 113 games. He finished his Cavs career averaging 6.0 points, 3.9 rebounds and 0.4 blocks per game.</p>
<p>Essentially, all three players that Boston gave up in the deal didn’t make a major impact for Cleveland. While some of the pieces that they were traded for did, none of those players remain with the team.</p>
<p>To give up Irving, who was a four-time All-Star when Cleveland made the deal, this certainly seems like an underwhelming return before you get to Sexton.</p>
<p>Sexton is by far the best piece the Cavs received, as they did about as well as you could ask with the No. 8 pick in the 2018 NBA Draft. Cleveland’s ultimate grade on this deal will be determined on what Sexton’s future looks like.</p>
<p>If he returns to Cleveland on a long-term deal and thrives, the Cavs will have gotten the best of this deal, since Irving moved on from Boston so quickly.</p>
<p>However, if the Cavs lose him this offseason or next offseason (he could take the qualifying offer to return for the 2022-23 season on a one-year deal), without getting anything in return, it would crush their final grade on this trade.</p>
<p>When healthy, Sexton has proven that he can be a top threat on offense, as he had a fantastic 2020-21 season for the Cavs. He averaged 24.3 points, 3.1 rebounds, 4.4 assists and 1.0 steal per game while shooting 47.5 percent from the field and 37.1 percent from beyond the arc that season.</p>
<p>However, a torn meniscus derailed his 2021-22 campaign, and it has changed his outlook with the franchise. Cleveland nearly made the playoffs without Sexton last season, and <a title="Darius Garland" href="https://cavaliersnation.com/tag/darius-garland/">Darius Garland</a> emerged as an All-Star in Cleveland’s backcourt.</p>
<p>There’s no doubt that Sexton is still a productive NBA player, but the question is whether or not he will be that player in Cleveland.</p>
<p>For now, the Cavs escape without a failing grade, but given the lack of long-term assets they received for a player of Irving’s caliber, they don’t pass with flying colors either.</p>
<p><strong>Grade: C-</strong></p>
<h2>Grading the Celtics haul</h2>
<p><img class="alignnone size-full wp-image-37476" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201800%201071'%3E%3C/svg%3E" alt="Kyrie Irving Boston Celtics" width="1800" height="1071" data-lazy-srcset="https://cavaliersnation.com/wp-content/uploads/2019/05/USATSI_12639119-e1557338026615.jpg 1800w, https://cavaliersnation.com/wp-content/uploads/2019/05/USATSI_12639119-e1557338026615-300x179.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2019/05/USATSI_12639119-e1557338026615-768x457.jpg 768w, https://cavaliersnation.com/wp-content/uploads/2019/05/USATSI_12639119-e1557338026615-1024x609.jpg 1024w" data-lazy-sizes="(max-width: 1800px) 100vw, 1800px" data-lazy-src="https://cavaliersnation.com/wp-content/uploads/2019/05/USATSI_12639119-e1557338026615.jpg" /><noscript><img class="alignnone size-full wp-image-37476" src="https://cavaliersnation.com/wp-content/uploads/2019/05/USATSI_12639119-e1557338026615.jpg" alt="Kyrie Irving Boston Celtics" width="1800" height="1071" srcset="https://cavaliersnation.com/wp-content/uploads/2019/05/USATSI_12639119-e1557338026615.jpg 1800w, https://cavaliersnation.com/wp-content/uploads/2019/05/USATSI_12639119-e1557338026615-300x179.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2019/05/USATSI_12639119-e1557338026615-768x457.jpg 768w, https://cavaliersnation.com/wp-content/uploads/2019/05/USATSI_12639119-e1557338026615-1024x609.jpg 1024w" sizes="(max-width: 1800px) 100vw, 1800px" /></noscript></p>
<p><strong>Celtics received:</strong> <a title="Kyrie Irving" href="https://cavaliersnation.com/tag/kyrie-irving/">Kyrie Irving</a></p>
<p>There is no question that Boston has been the better overall team since the Irving trade happened, but it isn’t because Irving led the team there.</p>
<p>Over two seasons with the Celtics, Irving appeared in 127 games. He averaged 24.1 points, 4.4 rebounds and 6.1 assists per game in Boston. The team came up short in the playoffs in both of his seasons in Boston, and Irving bolted for the Brooklyn Nets the second he became a free agent.</p>
<p>However, for the same reasons why Cleveland didn’t win this deal easily, Boston didn’t really give up much for Irving in the long run. The team held onto core pieces such as Jayson Tatum, Jaylen Brown and Marcus Smart, who ended up leading the Celtics to the NBA Finals in the 2021-22 season.</p>
<p>Sure, losing Irving after just two seasons couldn’t have been Boston’s original plan, but the Celtics have still been a perennial playoff team with or without Irving on the roster.</p>
<p>At the end of the day, neither team got exactly what it wanted in the Irving swap. Even Irving himself didn’t seem to get what he was looking for when he requested a trade from Cleveland, as he ended up teaming up with Kevin Durant in Brooklyn.</p>
<p>That era has gone just about as rocky as Irving’s time in Boston.</p>
<p>The Celtics are expected to continue to be one of the best teams in the Eastern Conference as long as Tatum and Brown are around and healthy, so the fact that they held onto both players in this deal makes this somewhat of a win.</p>
<p><strong>Grade: B</strong></p>
<div class="OUTBRAIN" data-widget-id="GS_1"></div>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type="text/javascript" async="async" src="https://cavaliersnation.com/wp-content/cache/min/1/outbrain.js?ver=1661215681"></script>
<div class="post-tags">
<a href="https://cavaliersnation.com/tag/ante-zizic/" rel="tag">ante zizic</a><a href="https://cavaliersnation.com/tag/boston-celtics/" rel="tag">boston celtics</a><a href="https://cavaliersnation.com/tag/cleveland-cavaliers/" rel="tag">cleveland cavaliers</a><a href="https://cavaliersnation.com/tag/collin-sexton/" rel="tag">collin sexton</a><a href="https://cavaliersnation.com/tag/featured/" rel="tag">featured</a><a href="https://cavaliersnation.com/tag/isaiah-thomas/" rel="tag">Isaiah Thomas</a><a href="https://cavaliersnation.com/tag/jae-crowder/" rel="tag">jae crowder</a><a href="https://cavaliersnation.com/tag/kyrie-irving/" rel="tag">kyrie irving</a><a href="https://cavaliersnation.com/tag/news-ticker/" rel="tag">news ticker</a>
</div>
<div class="prev-next-wrapper">
<div class="prev-post">
&larr; Previous Story <a href="https://cavaliersnation.com/2022/04/11/3-keys-for-the-cavs-to-take-down-the-nets-in-the-nbas-play-in-tournament/" rel="prev">3 keys for the Cavs to take down the Nets in the NBA&#8217;s play-in tournament</a>
</div>
<div class="next-post">
</div>
</div>
</div>
<div id="related-posts">
<h3>Related Posts</h3>
<ul>
<li>
<div class="related-image">
<a href="https://cavaliersnation.com/2022/08/20/report-collin-sexton-has-been-described-as-fast-and-explosive-by-those-who-have-seen-him-this-offseason/" rel="bookmark" title="Report: Collin Sexton described as &#8216;fast&#8217; and &#8216;explosive&#8217; by those who have seen him this offseason"><img width="300" height="195" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20195'%3E%3C/svg%3E" class="attachment-large-thumb size-large-thumb wp-post-image" alt="Collin Sexton" loading="lazy" data-lazy-srcset="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919-108x70.jpg 108w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919-300x195.jpg" /><noscript><img width="300" height="195" src="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919-300x195.jpg" class="attachment-large-thumb size-large-thumb wp-post-image" alt="Collin Sexton" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a>
</div>
<div class="related-text">
<a href="https://cavaliersnation.com/2022/08/20/report-collin-sexton-has-been-described-as-fast-and-explosive-by-those-who-have-seen-him-this-offseason/" class="main-headline">Report: Collin Sexton described as &#8216;fast&#8217; and &#8216;explosive&#8217; by those who have seen him this offseason</a>
</div>
</li>
<li>
<div class="related-image">
<a href="https://cavaliersnation.com/2022/08/20/report-cavs-have-had-conversations-with-mavericks-about-sign-and-trade-for-collin-sexton/" rel="bookmark" title="Report: Cavs have had conversations with Mavericks about sign-and-trade for Collin Sexton"><img width="300" height="195" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20195'%3E%3C/svg%3E" class="attachment-large-thumb size-large-thumb wp-post-image" alt="Collin Sexton" loading="lazy" data-lazy-srcset="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_13746898-scaled-e1661001705107-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_13746898-scaled-e1661001705107-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_13746898-scaled-e1661001705107-108x70.jpg 108w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_13746898-scaled-e1661001705107-300x195.jpg" /><noscript><img width="300" height="195" src="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_13746898-scaled-e1661001705107-300x195.jpg" class="attachment-large-thumb size-large-thumb wp-post-image" alt="Collin Sexton" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_13746898-scaled-e1661001705107-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_13746898-scaled-e1661001705107-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_13746898-scaled-e1661001705107-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a>
</div>
<div class="related-text">
<a href="https://cavaliersnation.com/2022/08/20/report-cavs-have-had-conversations-with-mavericks-about-sign-and-trade-for-collin-sexton/" class="main-headline">Report: Cavs have had conversations with Mavericks about sign-and-trade for Collin Sexton</a>
</div>
</li>
<li>
<div class="related-image">
<a href="https://cavaliersnation.com/2022/08/19/video-development-team-has-been-working-with-evan-mobley-using-kevin-durant-as-study-sample/" rel="bookmark" title="Video: Development team has been working with Evan Mobley, using Kevin Durant as study sample"><img width="300" height="195" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20195'%3E%3C/svg%3E" class="attachment-large-thumb size-large-thumb wp-post-image" alt="Evan Mobley" loading="lazy" data-lazy-srcset="https://cavaliersnation.com/wp-content/uploads/2022/08/Screen-Shot-2022-08-19-at-12.29.51-PM-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/08/Screen-Shot-2022-08-19-at-12.29.51-PM-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2022/08/Screen-Shot-2022-08-19-at-12.29.51-PM-108x70.jpg 108w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://cavaliersnation.com/wp-content/uploads/2022/08/Screen-Shot-2022-08-19-at-12.29.51-PM-300x195.jpg" /><noscript><img width="300" height="195" src="https://cavaliersnation.com/wp-content/uploads/2022/08/Screen-Shot-2022-08-19-at-12.29.51-PM-300x195.jpg" class="attachment-large-thumb size-large-thumb wp-post-image" alt="Evan Mobley" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2022/08/Screen-Shot-2022-08-19-at-12.29.51-PM-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/08/Screen-Shot-2022-08-19-at-12.29.51-PM-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2022/08/Screen-Shot-2022-08-19-at-12.29.51-PM-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a>
</div>
<div class="related-text">
<a href="https://cavaliersnation.com/2022/08/19/video-development-team-has-been-working-with-evan-mobley-using-kevin-durant-as-study-sample/" class="main-headline">Video: Development team has been working with Evan Mobley, using Kevin Durant as study sample</a>
</div>
</li>
</ul></div>
<div id="comments">
<p>
You must be logged in to post a comment
<a href="https://cavaliersnation.com/wp-login.php?redirect_to=https%3A%2F%2Fcavaliersnation.com%2F2022%2F08%2F22%2Fwho-won-grading-the-kyrie-irving-trade-from-the-cavs-to-the-celtics-5-years-later%2F">
Login
</a>
</p>
</div>
</div>

<div id="sidebar-wrapper">
<div class="widget-container">
<div class="widget-inner">
<h4 class="widget-header">About Peter Dewey</h4>
<div class="author-image">
<img class="avatar avatar-60 photo" width="64" height="64" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-lazy-src="https://cavaliersnation.com/wp-content/uploads/2020/05/IMG_7975-1-150x150-1.jpg" /><noscript><img class="avatar avatar-60 photo" width="64" height="64" src="https://cavaliersnation.com/wp-content/uploads/2020/05/IMG_7975-1-150x150-1.jpg"/></noscript>
</div>
<p class="author-box gd-widgets">Peter is a graduate of Quinnipiac University where he covered the MAAC and college basketball for three years. He has worked for NBC Sports, the Connecticut Sun and the Meriden Record-Journal covering basketball and other major sports. Follow him on Twitter @peterdewey2.</p>
</div>
</div>
<div class="widget-container">
<span class="blog-cat-title">Recent</span>
<div class="widget-img">
<a href="https://cavaliersnation.com/2022/08/20/report-collin-sexton-has-been-described-as-fast-and-explosive-by-those-who-have-seen-him-this-offseason/" rel="bookmark" title="Report: Collin Sexton described as &#8216;fast&#8217; and &#8216;explosive&#8217; by those who have seen him this offseason"><img width="400" height="280" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20400%20280'%3E%3C/svg%3E" class="attachment-xlarge-thumb size-xlarge-thumb wp-post-image" alt="Collin Sexton" loading="lazy" data-lazy-srcset="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919.jpg 1200w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919-300x210.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919-1024x717.jpg 1024w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919-768x538.jpg 768w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919.jpg" /><noscript><img width="400" height="280" src="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919.jpg" class="attachment-xlarge-thumb size-xlarge-thumb wp-post-image" alt="Collin Sexton" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919.jpg 1200w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919-300x210.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919-1024x717.jpg 1024w, https://cavaliersnation.com/wp-content/uploads/2022/08/USATSI_17129817-scaled-e1659360608919-768x538.jpg 768w" sizes="(max-width: 400px) 100vw, 400px" /></noscript></a>
</div>
<div class="widget-inner">
<h3 class="home-title1"><a href="https://cavaliersnation.com/2022/08/20/report-collin-sexton-has-been-described-as-fast-and-explosive-by-those-who-have-seen-him-this-offseason/" rel="bookmark">Report: Collin Sexton described as &#8216;fast&#8217; and &#8216;explosive&#8217; by those who have seen him this offseason</a></h3>
<p class="gd-widgets">Coming off last season&#8217;s injury-shortened campaign, guard Collin Sexton is showing many signs of being fully recovered and ready...</p>
<ul class="home-links1">
<li><a href="https://cavaliersnation.com/2022/08/20/report-cavs-have-had-conversations-with-mavericks-about-sign-and-trade-for-collin-sexton/" rel="bookmark">Report: Cavs have had conversations with Mavericks about sign-and-trade for Collin Sexton</a></li>
<li><a href="https://cavaliersnation.com/2022/08/17/report-cavs-have-discussed-cedi-osman-in-several-trade-scenarios-this-offseason/" rel="bookmark">Report: Cavs have discussed Cedi Osman in &#8216;several trade scenarios&#8217; this offseason</a></li>
<li><a href="https://cavaliersnation.com/2022/08/16/cavs-insider-says-team-will-have-decent-amount-of-nationally-televised-games/" rel="bookmark">Cavs insider says team will have &#8216;decent&#8217; amount of nationally televised games this season</a></li>
<li><a href="https://cavaliersnation.com/2022/08/12/report-isaac-okoro-has-been-working-his-a-s-off-this-summer-and-showing-great-signs-of-development/" rel="bookmark">Report: Isaac Okoro has been &#8216;working his a-s off&#8217; this summer and showing &#8216;great&#8217; signs of development</a></li>
</ul>
</div>
</div>
<div class="widget-container"><div id="yikes_easy_mc_widget-5" class="widget-inner widget_yikes_easy_mc_widget"><h4 class="widget-header">Subscribe to get your daily Cleveland Cavaliers news, rumors, and videos!</h4>
<section id="yikes-mailchimp-container-1" class="yikes-mailchimp-container yikes-mailchimp-container-1 ">
<form id="cavaliers-nation-1" class="yikes-easy-mc-form yikes-easy-mc-form-1  " method="POST" data-attr-form-id="1">
<label for="yikes-easy-mc-form-1-EMAIL" class="EMAIL-label yikes-mailchimp-field-required ">

<span class="EMAIL-label">
Email Address </span>

<input id="yikes-easy-mc-form-1-EMAIL" name="EMAIL" placeholder="" class="yikes-easy-mc-email " required="required" type="email" value="">

</label>
<label for="yikes-easy-mc-form-1-FNAME" class="FNAME-label ">

<span class="FNAME-label">
First Name </span>

<input id="yikes-easy-mc-form-1-FNAME" name="FNAME" placeholder="" class="yikes-easy-mc-text " type="text" value="">

</label>
<label for="yikes-easy-mc-form-1-LNAME" class="LNAME-label ">

<span class="LNAME-label">
Last Name </span>

<input id="yikes-easy-mc-form-1-LNAME" name="LNAME" placeholder="" class="yikes-easy-mc-text " type="text" value="">

</label>

<input type="hidden" name="yikes-mailchimp-honeypot" id="yikes-mailchimp-honeypot-1" value="">

<input type="hidden" name="yikes-mailchimp-associated-list-id" id="yikes-mailchimp-associated-list-id-1" value="fd937dddf1">

<input type="hidden" name="yikes-mailchimp-submitted-form" id="yikes-mailchimp-submitted-form-1" value="1">

<button type="submit" class="yikes-easy-mc-submit-button yikes-easy-mc-submit-button-1 btn btn-primary "> <span class="yikes-mailchimp-submit-button-span-text">Submit</span></button> 
<input type="hidden" id="yikes_easy_mc_new_subscriber_1" name="yikes_easy_mc_new_subscriber" value="2989652cbc">
<input type="hidden" name="_wp_http_referer" value="/2022/08/22/who-won-grading-the-kyrie-irving-trade-from-the-cavs-to-the-celtics-5-years-later/" />
</form>

</section>
</div></div>
</div>
</div>
</div>
</div>
</div>
</div>
<div id="footer-wrapper">
<div id="footer">
<div id="footer-nav">
<div class="menu-home-container"><ul id="menu-home-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75"><a href="https://cavaliersnation.com/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-41"><a title="Categories">Categories</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a href="https://cavaliersnation.com/category/game-reports/">Game Reports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-82"><a href="https://cavaliersnation.com/category/editorials/">Editorials</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84"><a href="https://cavaliersnation.com/category/team-news/">Team News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a href="https://cavaliersnation.com/category/rumors/">Rumors</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83"><a href="https://cavaliersnation.com/category/media/">Media</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-86"><a href="https://cavaliersnation.com/category/videos/">Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://cavaliersnation.com/schedule/">Schedule</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48"><a href="https://cavaliersnation.com/contributors/">Contributors</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a href="https://cavaliersnation.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9117"><a href="https://cavaliersnation.com/career/">Career</a></li>
</ul></div>
</div>
<div id="copyright">
<p>Copyright © 2014 Cavaliers Nation, All Rights Reserved. Property of <a href="https://ahnfiredigital.com">Ahn Fire Digital</a>. Partner with USA Today Sports Digital
Properties. <a href="https://cavaliersnation.com/privacy-policy">Privacy Policy</a> </p>
</div>
</div>
</div>
</div>
<script data-no-optimize='1' data-cfasync='false' id='cls-insertion-144ef04'>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</script><script data-no-optimize="1" data-cfasync="false">(function () {var clsElements = document.querySelectorAll("script[id^='cls-']"); window.adthriveCLS && clsElements && clsElements.length === 0 ? window.adthriveCLS.injectedFromPlugin = false : ""; })();</script>
<script type="rocketlazyloadscript" data-rocket-type="text/javascript">



//<![CDATA[



(function() {



    window.PinIt = window.PinIt || { loaded:false };



    if (window.PinIt.loaded) return;



    window.PinIt.loaded = true;



    function async_load(){



        var s = document.createElement("script");



        s.type = "text/javascript";



        s.async = true;



        s.src = "https://assets.pinterest.com/js/pinit.js";



        var x = document.getElementsByTagName("script")[0];



        x.parentNode.insertBefore(s, x);



    }



    if (window.attachEvent)



        window.attachEvent("onload", async_load);



    else



        window.addEventListener("load", async_load, false);



})();



//]]>



</script>
<script type="rocketlazyloadscript" data-rocket-type="text/javascript">



//<![CDATA[



  (function() {



    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;



    po.src = 'https://apis.google.com/js/plusone.js';



    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);



  })();



//]]>



</script>
<div id="fb-root"></div>
<script type="rocketlazyloadscript" data-rocket-type="text/javascript">



//<![CDATA[



(function(d, s, id) {



  var js, fjs = d.getElementsByTagName(s)[0];



  if (d.getElementById(id)) return;



  js = d.createElement(s); js.id = id;



  js.async = true;



  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";



  fjs.parentNode.insertBefore(js, fjs);



}(document, 'script', 'facebook-jssdk'));



//]]>



</script>
<script type="rocketlazyloadscript" data-rocket-type="text/javascript">

    const observer = lozad('.lozad', {

		load: el => {

			const bq = document.createElement('blockquote');

			bq.className = 'twitter-tweet';



			const p = document.createElement('p');

			p.lang = 'ja';

			p.dir = 'ltr';

			bq.appendChild(p);



			const twitterSrc = el.dataset.twitterSrc;

			const a = document.createElement('a');

			a.href = twitterSrc;

			bq.appendChild(a);



			const script = document.createElement('script');

			script.src = 'https://platform.twitter.com/widgets.js';

			script.charset = 'utf-8';

			script.async = true;



			el.insertAdjacentElement('beforeEnd', bq);

			el.insertAdjacentElement('beforeEnd', script);

		}

	});

	observer.observe();



	const observerYoutube = lozad('.lozad-youtube', {

		load: el => {



			const youtubeSrc = el.dataset.twitterSrc;

			const embedUrl = youtubeSrc.replace('https://www.youtube.com/watch?v=', 'https://www.youtube.com/embed/') + '?feature=oembed';



			//const iframe = '<iframe loading="lazy" width="615" height="346" src="' + youtubeSrc + '" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe>';

			// https://www.youtube.com/embed/tQwsBRUj5Uo?feature=oembed

			// https://www.youtube.com/watch?v=tQwsBRUj5Uo



			const iframe = document.createElement('iframe');

			iframe.loading = 'lazy';

			iframe.width = 615;

			iframe.height =346;

			iframe.src =  embedUrl;

			iframe.frameborder = 0;

			iframe.allow = 'accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture';

			iframe.allowfullscreen = '';



			el.insertAdjacentElement('beforeEnd', iframe);

		}

	});

	observerYoutube.observe();



</script>
<link rel='stylesheet' id='yikes-inc-easy-mailchimp-public-styles-css' href='https://cavaliersnation.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/css/yikes-inc-easy-mailchimp-extender-public.min.css?ver=6.0.1' type='text/css' media='all' />
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/comment-reply.min.js?ver=6.0.1' id='comment-reply-js' defer></script>
<script type='text/javascript' id='stickThis-js-extra'>
/* <![CDATA[ */
var sticky_anything_engage = {"element":".ad-728","topspace":"0","minscreenwidth":"0","maxscreenwidth":"999999","zindex":"1","legacymode":"","dynamicmode":"","debugmode":"","pushup":"","adminbar":"1"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-content/cache/min/1/wp-content/plugins/sticky-menu-or-anything-on-scroll/assets/js/stickThis.js?ver=1661215681' id='stickThis-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(?:.+\/)?feed(?:\/(?:.+\/?)?)?$|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/refer\/|\/go\/|\/recommend\/|\/recommends\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php|html|htm","siteUrl":"https:\/\/cavaliersnation.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-content/cache/min/1/wp-content/themes/gameday/js/jquery.flexslider.js?ver=1661215681' id='flexslider-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-content/cache/min/1/wp-content/themes/gameday/js/jquery.elastislide.js?ver=1661215681' id='elastislide-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-content/cache/min/1/wp-content/themes/gameday/js/scripts.js?ver=1661215681' id='gameday-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-content/cache/min/1/wp-content/themes/gameday/js/ticker.js?ver=1661215681' id='ticker-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/respond.min.js?ver=6.0.1' id='respond-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-content/cache/min/1/wp-content/themes/gameday/js/retina.js?ver=1661215681' id='retina-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-content/cache/min/1/sdks/OneSignalSDK.js?ver=1661215681' async='async' id='remote_sdk-js'></script>
<script type='text/javascript' id='yikes-easy-mc-ajax-js-extra'>
/* <![CDATA[ */
var yikes_mailchimp_ajax = {"ajax_url":"https:\/\/cavaliersnation.com\/wp-admin\/admin-ajax.php","page_data":"56714","interest_group_checkbox_error":"This field is required.","preloader_url":"https:\/\/cavaliersnation.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/ripple.svg","loading_dots":"https:\/\/cavaliersnation.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/bars.svg","ajax_security_nonce":"d938fcda1e","feedback_message_placement":"before"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/yikes-mc-ajax-forms.min.js?ver=6.8.6' id='yikes-easy-mc-ajax-js' defer></script>
<script type='text/javascript' id='form-submission-helpers-js-extra'>
/* <![CDATA[ */
var form_submission_helpers = {"ajax_url":"https:\/\/cavaliersnation.com\/wp-admin\/admin-ajax.php","preloader_url":"https:\/\/cavaliersnation.com\/wp-admin\/images\/wpspin_light.gif","countries_with_zip":{"US":"US","GB":"GB","CA":"CA","IE":"IE","CN":"CN","IN":"IN","AU":"AU","BR":"BR","MX":"MX","IT":"IT","NZ":"NZ","JP":"JP","FR":"FR","GR":"GR","DE":"DE","NL":"NL","PT":"PT","ES":"ES"},"page_data":"56714"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/form-submission-helpers.min.js?ver=6.8.6' id='form-submission-helpers-js' defer></script>
<script type="rocketlazyloadscript">!function(){"use strict";!function(e){if(-1===e.cookie.indexOf("__adblocker")){e.cookie="__adblocker=; expires=Thu, 01 Jan 1970 00:00:00 GMT; path=/";var t=new XMLHttpRequest;t.open("GET","https://www.npttech.com/advertising.js",!0),t.onreadystatechange=function(){if(XMLHttpRequest.DONE===t.readyState)if(200===t.status){var n=e.createElement("script");n.innerHTML=t.responseText,e.getElementsByTagName("head")[0].appendChild(n)}else{var a=new Date;a.setTime(a.getTime()+3e5),e.cookie="__adblocker=true; expires="+a.toUTCString()+"; path=/"}},t.send()}}(document)}();
</script><script type="rocketlazyloadscript">!function(){"use strict";var e;e=document,function(){var t,n;function r(){var t=e.createElement("script");t.src="https://cafemedia-com.videoplayerhub.com/galleryplayer.js",e.head.appendChild(t)}function a(){var t=e.cookie.match("(^|[^;]+)\\s*__adblocker\\s*=\\s*([^;]+)");return t&&t.pop()}function c(){clearInterval(n)}return{init:function(){var e;"true"===(t=a())?r():(e=0,n=setInterval((function(){100!==e&&"false"!==t||c(),"true"===t&&(r(),c()),t=a(),e++}),50))}}}().init()}();
</script><script>window.lazyLoadOptions=[{elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}},{elements_selector:".rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,}];window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://cavaliersnation.com/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<button class="play" aria-label="play Youtube video"></button>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.parentNode.dataset.query.length?'':'&'+this.parentNode.dataset.query;e.setAttribute("src",t.replace("ID",this.parentNode.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.parentNode.replaceChild(e,this.parentNode)}document.addEventListener("DOMContentLoaded",function(){var e,t,p,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),a[t].appendChild(e),p=e.querySelector('.play'),p.onclick=lazyLoadYoutubeIframe});</script>
</body>
</html>
