<!DOCTYPE html><html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"><head> <script src="https://us.connextra.com/dcs/tagController/tag/362820167f7c/homepage" async defer></script> <meta name="verifyownership" 
 content="8b17572d9adc3b6cbc654dc1d5d043e5"/><meta name="verifyownership" 
 content="16a1e10dad87b5c0fc759f5de4f6f60e"/> <script async src="//js-sec.indexww.com/ht/p/184031-43290852983293.js"></script>  <script>var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "6035223" });
  (function() {
    var s = document.createElement("script"), el =
document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb<https://sb/>" :
"http://b<http://b/>") +
".scorecardresearch.com/beacon.js<http://scorecardresearch.com/beacon.js>";
    el.parentNode.insertBefore(s, el);
  })();</script> <noscript> <img src="https://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" /> </noscript>  <script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script> <meta name="google-site-verification" content="KStSRn6409ttzCYidg-n9MD7blSVvoj25HKqQg3hg5Y" /><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" /><meta property="og:image" content="https://cavaliersnation.com/wp-content/uploads/2022/01/Screen-Shot-2022-01-07-at-10.06.16-AM-615x400.jpg" /><link media="all" href="https://cavaliersnation.com/wp-content/cache/autoptimize/css/autoptimize_3ab1ebe21530e879b064df2be06a6f66.css" rel="stylesheet" /><title>Report: Rajon Rondo likely to make Cavs debut on Friday vs. Trail Blazers - Cavaliers Nation</title> <!--[if IE]><link rel="stylesheet" type="text/css" href="https://cavaliersnation.com/wp-content/themes/gameday/css/iecss.css" /> <![endif]--><link rel="shortcut icon" href="https://cavaliersnation.com/wp-content/uploads/2017/10/cavaliersnationlogo-1.jpg" /><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://cavaliersnation.com/feed/" /><link rel="alternate" type="text/xml" title="RSS .92" href="https://cavaliersnation.com/feed/rss/" /><link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://cavaliersnation.com/feed/atom/" /><link rel="pingback" href="https://cavaliersnation.com/xmlrpc.php" /> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-56943371-1', 'auto');
  ga('send', 'pageview');</script> <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <script>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</script> <script>(function(w, d) {
	w.adthrive = w.adthrive || {};
	w.adthrive.cmd = w.adthrive.cmd || [];
	w.adthrive.plugin = 'adthrive-ads-1.1.3';
	w.adthrive.host = 'ads.adthrive.com';

	var commitParam = (w.adthriveCLS && w.adthriveCLS.bucket !== 'prod' && w.adthriveCLS.branch) ? '&commit=' + w.adthriveCLS.branch : '';

	var s = d.createElement('script');
	s.async = true;
	s.referrerpolicy='no-referrer-when-downgrade';
	s.src = 'https://' + w.adthrive.host + '/sites/5b48a37c9be6984315eaf2ce/ads.min.js?referrer=' + w.encodeURIComponent(w.location.href) + commitParam + '&cb=' + (Math.floor(Math.random() * 100) + 1);
	var n = d.getElementsByTagName('script')[0];
	n.parentNode.insertBefore(s, n);
})(window, document);</script> <meta name="description" content="Cleveland Cavaliers guard Rajon Rondo is likely to make his debut with the team on Friday night against the Portland Trail Blazers. Rondo has cleared the NBA’s health and safety protocols and is listed as probable for Friday’s contest." /><link rel="canonical" href="https://cavaliersnation.com/2022/01/07/report-rajon-rondo-likely-to-make-cavs-debut-on-friday-vs-trail-blazers/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Report: Rajon Rondo likely to make Cavs debut on Friday vs. Trail Blazers" /><meta property="og:description" content="Cleveland Cavaliers guard Rajon Rondo is likely to make his debut with the team on Friday night against the Portland Trail Blazers. Rondo has cleared the NBA’s health and safety protocols and is listed as probable for Friday’s contest." /><meta property="og:url" content="https://cavaliersnation.com/2022/01/07/report-rajon-rondo-likely-to-make-cavs-debut-on-friday-vs-trail-blazers/" /><meta property="og:site_name" content="Cavaliers Nation" /><meta property="article:publisher" content="https://www.facebook.com/CavaliersNation/" /><meta property="article:published_time" content="2022-01-07T15:11:20+00:00" /><meta property="article:modified_time" content="2022-01-07T23:23:22+00:00" /><meta property="og:image" content="https://cavaliersnation.com/wp-content/uploads/2022/01/Screen-Shot-2022-01-07-at-10.06.16-AM.jpg" /><meta property="og:image:width" content="1300" /><meta property="og:image:height" content="1015" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@WeAreCavsNation" /><meta name="twitter:site" content="@WeAreCavsNation" /> <script type="application/ld+json" class="yoast-schema-graph">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</script> <link rel="amphtml" href="https://cavaliersnation.com/2022/01/07/report-rajon-rondo-likely-to-make-cavs-debut-on-friday-vs-trail-blazers/amp/" /><meta name="generator" content="AMP for WP 1.0.77.33"/><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Cavaliers Nation &raquo; Feed" href="https://cavaliersnation.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Cavaliers Nation &raquo; Comments Feed" href="https://cavaliersnation.com/comments/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cavaliersnation.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.3"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style id="googlefonts-css" media="all">@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 400;
  font-stretch: normal;
  src: url(/fonts.gstatic.com/s/opensans/v27/memSYaGs126MiZpBA-UvWbX2vVnXBbObj2OVZyOOSr4dVJWUgsjZ0C4n.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 700;
  font-stretch: normal;
  src: url(/fonts.gstatic.com/s/opensans/v27/memSYaGs126MiZpBA-UvWbX2vVnXBbObj2OVZyOOSr4dVJWUgsg-1y4n.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans Condensed';
  font-style: normal;
  font-weight: 300;
  src: url(/fonts.gstatic.com/s/opensanscondensed/v15/z7NFdQDnbTkabZAIOl9il_O6KJj73e7Ff1GhPuI.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans Condensed';
  font-style: normal;
  font-weight: 700;
  src: url(/fonts.gstatic.com/s/opensanscondensed/v15/z7NFdQDnbTkabZAIOl9il_O6KJj73e7Ff0GmPuI.ttf) format('truetype');
}
@font-face {
  font-family: 'Oswald';
  font-style: normal;
  font-weight: 300;
  src: url(/fonts.gstatic.com/s/oswald/v40/TK3_WkUHHAIjg75cFRf3bXL8LICs169vgUE.ttf) format('truetype');
}
@font-face {
  font-family: 'Oswald';
  font-style: normal;
  font-weight: 400;
  src: url(/fonts.gstatic.com/s/oswald/v40/TK3_WkUHHAIjg75cFRf3bXL8LICs1_FvgUE.ttf) format('truetype');
}
@font-face {
  font-family: 'Oswald';
  font-style: normal;
  font-weight: 700;
  src: url(/fonts.gstatic.com/s/oswald/v40/TK3_WkUHHAIjg75cFRf3bXL8LICs1xZogUE.ttf) format('truetype');
}
</style> <script type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/sticky-menu-or-anything-on-scroll/assets/js/jq-sticky-anything.min.js?ver=2.1.1' id='stickyAnythingLib-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/wp-retina-2x/app/picturefill.min.js?ver=1638889684' id='wr2x-picturefill-js-js'></script> <link rel="https://api.w.org/" href="https://cavaliersnation.com/wp-json/" /><link rel="alternate" type="application/json" href="https://cavaliersnation.com/wp-json/wp/v2/posts/54138" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://cavaliersnation.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cavaliersnation.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.8.3" /><link rel='shortlink' href='https://cavaliersnation.com/?p=54138' /><link rel="alternate" type="application/json+oembed" href="https://cavaliersnation.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcavaliersnation.com%2F2022%2F01%2F07%2Freport-rajon-rondo-likely-to-make-cavs-debut-on-friday-vs-trail-blazers%2F" /><link rel="alternate" type="text/xml+oembed" href="https://cavaliersnation.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcavaliersnation.com%2F2022%2F01%2F07%2Freport-rajon-rondo-likely-to-make-cavs-debut-on-friday-vs-trail-blazers%2F&#038;format=xml" /><meta name="onesignal" content="wordpress-plugin"/> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://cavaliersnation.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'b691d3c3-97cc-4969-a5c2-2d07e83c1aba';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://cavaliersnation.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.28671d66-3da8-4a50-bcc4-1b29e015670b";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script> <link rel="icon" href="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" sizes="32x32" /><link rel="icon" href="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" sizes="192x192" /><link rel="apple-touch-icon" href="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" /><meta name="msapplication-TileImage" content="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" /> <script id=cls-disable-ads-bd3bbeb>var cls_disable_ads=function(t){"use strict";var e=function(t){var e=window.location.href;return t.some((function(t){return new RegExp(t,"i").test(e)}))},i=function(){function t(t){this.adthrive=t,this.all=!1,this.content=!1,this.recipe=!1,this.video=!1,this.locations=new Set,this.reasons=new Set,(this.urlHasEmail(window.location.href)||this.urlHasEmail(window.document.referrer))&&(this.all=!0,this.reasons.add("all_email"));try{this.checkCommandQueue(),null!==document.querySelector(".tag-novideo")&&(this.video=!0,this.locations.add("Video"),this.reasons.add("video_tag"))}catch(t){console.log(t)}}return t.prototype.checkCommandQueue=function(){var t=this;this.adthrive&&this.adthrive.cmd&&this.adthrive.cmd.forEach((function(e){var i=e.toString(),a=t.extractAPICall(i,"disableAds");a&&t.disableAllAds(t.extractPatterns(a));var n=t.extractAPICall(i,"disableContentAds");n&&t.disableContentAds(t.extractPatterns(n));var s=t.extractAPICall(i,"disablePlaylistPlayers");s&&t.disablePlaylistPlayers(t.extractPatterns(s))}))},t.prototype.extractPatterns=function(t){var e=t.match(/\'(.*?)\'/g);if(null!==e)return e.map((function(t){return t.replace(/'/g,"")}))},t.prototype.extractAPICall=function(t,e){var i=new RegExp(e+"\\((.*?)\\)","g"),a=t.match(i);return null!==a&&a[0]},t.prototype.disableAllAds=function(t){t&&!e(t)||(this.all=!0,this.reasons.add("all_page"))},t.prototype.disableContentAds=function(t){t&&!e(t)||(this.content=!0,this.recipe=!0,this.locations.add("Content"),this.locations.add("Recipe"),this.reasons.add("content_plugin"))},t.prototype.disablePlaylistPlayers=function(t){t&&!e(t)||(this.video=!0,this.locations.add("Video"),this.reasons.add("video_page"))},t.prototype.urlHasEmail=function(t){if(!t)return!1;return null!==/([A-Z0-9._%+-]+(@|%(25)*40)[A-Z0-9.-]+\.[A-Z]{2,})/i.exec(t)},t}();return window.adthriveCLS&&(window.adthriveCLS.disableAds=new i(window.adthrive)),t.ClsDisableAds=i,t}({});</script><script id=cls-header-insertion-bd3bbeb>var cls_header_insertion=function(e){"use strict";function t(e,t){var i="function"==typeof Symbol&&e[Symbol.iterator];if(!i)return e;var n,r,o=i.call(e),a=[];try{for(;(void 0===t||t-- >0)&&!(n=o.next()).done;)a.push(n.value)}catch(e){r={error:e}}finally{try{n&&!n.done&&(i=o.return)&&i.call(o)}finally{if(r)throw r.error}}return a}function i(){for(var e=[],i=0;i<arguments.length;i++)e=e.concat(t(arguments[i]));return e}var n=function(e,t){return null==e||e!=e?t:e},r=function(){function e(e){this.adthriveCLS=e,this._supportedSizes=[[728,90],[300,250],[300,600],[320,50],[970,250],[160,600],[300,1050],[336,280],[970,90],[300,50],[320,100],[468,60],[250,250],[120,240],[1,1],[300,300],[552,334],[300,420],[728,250],[320,300],[300,390]],this.deviceToMinHeight={desktop:"90px",tablet:"90px",phone:"50px"},this._adUnitAuctionPriorityMap=new Map([["Footer",1],["Header",2],["Sidebar",3],["Content",4],["Recipe",5],["Sidebar_sticky",6],["Below Post",7]]);var t=this.adthriveCLS.siteAds.breakpoints,i=t.tablet,n=t.desktop;this._device=function(e,t){var i=window.innerWidth;return i>=t?"desktop":i>=e?"tablet":"phone"}(i,n)}return e.prototype.start=function(){for(var e=this,t=this.get().filter((function(t){return e.locationEnabled(t)})).filter((function(t){return e.forDevice(t,e._device)})),i=0;i<t.length;i++)window.requestAnimationFrame(this.inject.bind(this,t[i],document))},e.prototype.inject=function(e,t){if(void 0===t&&(t=document),"complete"!==document.readyState){if(0!==e.pageSelector.length)if(!document.querySelector(e.pageSelector))return void window.requestAnimationFrame(this.inject.bind(this,e,document));var n=this.getElements(e.elementSelector,t);if(n){var r=this.getDynamicElementId(e),o="adthrive-"+e.location.replace("_","-").toLowerCase(),a=i([o,o+"-"+e.sequence],e.classNames),c=this.addAd(n,r,e.position,a);if(c){var d=this.filterAdUnitSizes(e,c);if(d.length>0){var s={clsDynamicAd:e,dynamicAd:e,element:c,sizes:d,name:"Header_1",infinite:t!==document};this.adthriveCLS.injectedSlots.some((function(e){return"Header_1"===e.name}))||this.adthriveCLS.injectedSlots.push(s),c.style.minHeight=this.deviceToMinHeight[this._device]}}}else window.requestAnimationFrame(this.inject.bind(this,e,document))}},e.prototype.getDynamicElementId=function(e){return"AdThrive_"+e.location+"_"+e.sequence+"_"+this._device},e.prototype.getElements=function(e,t){return void 0===t&&(t=document),t.querySelector(e)},e.prototype.addAd=function(e,t,i,n){if(void 0===n&&(n=[]),!document.getElementById(t)){var r='<div id="'+t+'" class="adthrive-ad '+n.join(" ")+'"></div>';e.insertAdjacentHTML(i,r)}return document.getElementById(t)},e.prototype.get=function(){var e=this;return this.adthriveCLS.siteAds.adUnits.filter((function(e){return void 0!==e.dynamic&&e.dynamic.enabled})).map((function(t){var r=t.location.replace(/\s+/g,"_");return{auctionPriority:e._adUnitAuctionPriorityMap.get(r)||8,location:r,sequence:n(t.sequence,1),sizes:e.onlySupportedAdSizes(t.adSizes).filter((function(i){return e.excludeTallSizeFromFooter(t.location,i)})),devices:t.devices,pageSelector:n(t.dynamic.pageSelector,"").trim(),elementSelector:n(t.dynamic.elementSelector,"").trim(),position:n(t.dynamic.position,"beforebegin"),min:Math.floor(n(t.dynamic.min,0)),max:Math.floor(n(t.dynamic.max,0)),spacing:n(t.dynamic.spacing,0),skip:Math.floor(n(t.dynamic.skip,0)),every:Math.max(Math.floor(n(t.dynamic.every,1)),1),classNames:t.dynamic.classNames||[],sticky:"Footer"===t.location||t.sticky,stickyOverlapSelector:n(t.stickyOverlapSelector,"").trim(),autosize:t.autosize,special:n(t.targeting,[]).filter((function(e){return"special"===e.key})).reduce((function(e,t){return e.concat.apply(e,i(t.value))}),[]),lazy:n(t.dynamic.lazy,!1),lazyMax:n(t.dynamic.lazyMax,2),lazyMaxDefaulted:0!==t.dynamic.lazyMax&&!t.dynamic.lazyMax}}))},e.prototype.locationEnabled=function(e){return!(this.adthriveCLS.disableAds&&this.adthriveCLS.disableAds.all)&&"Header"===e.location&&1===e.sequence&&1===e.max&&0===e.spacing},e.prototype.forDevice=function(e,t){return-1!==e.devices.indexOf(t)},e.prototype.onlySupportedAdSizes=function(e){return this._supportedSizes.filter((function(i){var n=t(i,2),r=n[0],o=n[1];return e.some((function(e){var i=t(e,2),n=i[0],a=i[1];return r===n&&o===a}))}))},e.prototype.filterAdUnitSizes=function(e,t){var i=function(e){var t=e.clientWidth;if(getComputedStyle){var i=getComputedStyle(e,null);t-=parseFloat(i.paddingLeft||"0")+parseFloat(i.paddingRight||"0")}return t}(t),n=e.sticky&&"Sidebar"===e.location;return e.sizes.filter((function(t){var r=!e.autosize||(t[0]<=i||t[0]<=320),o=!n||t[1]<=window.innerHeight-100;return r&&o}))},e.prototype.excludeTallSizeFromFooter=function(e,i){var n=t(i,2),r=n[0],o=n[1];return!("Footer"===e&&"phone"===this._device&&320===r&&100===o)},e}();return window.adthriveCLS&&window.adthriveCLS.siteAds&&window.requestAnimationFrame&&"classList"in document.createElement("_")&&new r(window.adthriveCLS).start(),e.ClsHeaderInjector=r,e}({});</script> </head><body data-rsssl=1 class="post-template-default single single-post postid-54138 single-format-standard custom-background"><div id="site"><div id="wrapper"><div id="nav-main-wrapper"><div id="nav-main"><div id="nav-main-left"><div id="nav-logo"> <a href="https://cavaliersnation.com"><img src="https://cavaliersnation.com/wp-content/uploads/2019/05/cnwebsite12.png" alt="Cavaliers Nation" /></a></div><ul class="nav-main"><div class="menu-home-container"><ul id="menu-home" class="menu"><li id="menu-item-75" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75"><a href="https://cavaliersnation.com/">Home</a></li><li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-41"><a title="Categories">Categories</a><ul class="sub-menu"><li id="menu-item-81" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a href="https://cavaliersnation.com/category/game-reports/">Game Reports</a></li><li id="menu-item-82" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82"><a href="https://cavaliersnation.com/category/editorials/">Editorials</a></li><li id="menu-item-84" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-84"><a href="https://cavaliersnation.com/category/team-news/">Team News</a></li><li id="menu-item-85" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a href="https://cavaliersnation.com/category/rumors/">Rumors</a></li><li id="menu-item-83" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83"><a href="https://cavaliersnation.com/category/media/">Media</a></li><li id="menu-item-86" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-86"><a href="https://cavaliersnation.com/category/videos/">Videos</a></li></ul></li><li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://cavaliersnation.com/schedule/">Schedule</a></li><li id="menu-item-48" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48"><a href="https://cavaliersnation.com/contributors/">Contributors</a></li><li id="menu-item-40" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a href="https://cavaliersnation.com/about/">About</a></li><li id="menu-item-9117" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9117"><a href="https://cavaliersnation.com/career/">Career</a></li></ul></div></ul><div id="nav-mobi"><div class="menu-home-container"><select><option value="#">Menu</option><option value="https://cavaliersnation.com/">Home</option><option value="">Categories<option value="https://cavaliersnation.com/category/game-reports/">-Game Reports</option><option value="https://cavaliersnation.com/category/editorials/">-Editorials</option><option value="https://cavaliersnation.com/category/team-news/">-Team News</option><option value="https://cavaliersnation.com/category/rumors/">-Rumors</option><option value="https://cavaliersnation.com/category/media/">-Media</option><option value="https://cavaliersnation.com/category/videos/">-Videos</option></option><option value="https://cavaliersnation.com/schedule/">Schedule</option><option value="https://cavaliersnation.com/contributors/">Contributors</option><option value="https://cavaliersnation.com/about/">About</option><option value="https://cavaliersnation.com/career/">Career</option> </select></div></div></div><div id="nav-search"><form method="get" id="searchform" action="https://cavaliersnation.com/"> <input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' /> <input type="hidden" id="search-button" /></form></div></div></div><div id="main-wrapper"><div id="top-spacer"></div><div id="content-outer"><div id="main-top"><div id="ticker"> <span class="ticker-heading">Don't Miss</span><ul class="ticker-list"><li><a href="https://cavaliersnation.com/2022/01/07/report-cavs-looking-for-more-playmaking-despite-trading-for-rajon-rondo/">Report: Cavs looking for more playmaking despite trading for Rajon Rondo</a></li><li><a href="https://cavaliersnation.com/2022/01/07/report-cavs-guaranteeing-lamar-stevens-contract-for-the-rest-of-the-season/">Report: Cavs guaranteeing Lamar Stevens&#8217; contract for the rest of the season</a></li><li><a href="https://cavaliersnation.com/2022/01/07/report-rajon-rondo-likely-to-make-cavs-debut-on-friday-vs-trail-blazers/">Report: Rajon Rondo likely to make Cavs debut on Friday vs. Trail Blazers</a></li><li><a href="https://cavaliersnation.com/2022/01/06/kevin-love-offers-opposite-reaction-of-lebron-james-on-wizards-analysts-nasty-words-about-kevin-porter-jr-father/">Kevin Love offers opposite reaction of LeBron on Wizards analyst&#8217;s nasty words about Kevin Porter Jr.&#8217;s father</a></li><li><a href="https://cavaliersnation.com/2022/01/06/kevin-love-congratulates-dirk-nowitzki-on-his-jersey-retirement-with-heartwarming-message/">Kevin Love congratulates Dirk Nowitzki on his jersey retirement with heartwarming message</a></li><li><a href="https://cavaliersnation.com/2022/01/05/rajon-rondo-explains-why-hes-willing-to-go-to-war-with-darius-garland/">Rajon Rondo explains why he&#8217;s willing to &#8216;go to war&#8217; with Darius Garland</a></li><li><a href="https://cavaliersnation.com/2022/01/05/j-b-bickerstaff-discloses-how-many-minutes-per-game-rajon-rondo-will-play-for-the-cavs/">J.B. Bickerstaff discloses how many minutes per game Rajon Rondo will play for the Cavs</a></li><li><a href="https://cavaliersnation.com/2022/01/05/kyle-kuzmas-emphatic-1-word-description-of-darius-garland/">Kyle Kuzma&#8217;s emphatic 1-word description of Darius Garland</a></li><li><a href="https://cavaliersnation.com/2022/01/04/report-darius-garland-expected-to-return-to-cavs-lineup-vs-grizzlies-after-clearing-health-and-safety-protocols/">Report: Darius Garland clears health and safety protocols, expected to return to Cavs lineup vs. Grizzlies</a></li><li><a href="https://cavaliersnation.com/2022/01/03/report-cavs-provided-update-timetable-for-isaac-okoros-return-from-injury/">Report: Cavs provided update timetable for Isaac Okoro&#8217;s return from injury</a></li></ul></div><div id="content-social"><ul><li><a href="https://www.facebook.com/cavaliersnation" alt="Facebook" class="fb-but" target="_blank"></a></li><li><a href="https://www.twitter.com/wearecavsnation" alt="Twitter" class="twitter-but" target="_blank"></a></li><li><a href="https://www.instagram.com/cavaliersnationdotcom" alt="Instagram" class="instagram-but" target="_blank"></a></li><li><a href="https://cavaliersnation.com/feed/rss/" alt="RSS Feed" class="rss-but"></a></li></ul></div></div><div id="content-inner"><div id="main"><div class="breadcrumb"><div id="crumbs"><a href="https://cavaliersnation.com">Home</a> / <a href="https://cavaliersnation.com/category/team-news/">Team News</a> / <span class="current">Report: Rajon Rondo likely to make Cavs debut on Friday vs. Trail Blazers</span></div></div><h1 class="headline">Report: Rajon Rondo likely to make Cavs debut on Friday vs. Trail Blazers</h1><div id="post-info-wrapper"><ul class="post-info"><li><div class="post-author">By <a href="https://cavaliersnation.com/author/peter-dewey/" title="Posts by Peter Dewey" rel="author">Peter Dewey</a></div></li><li><ul class="post-social"><li><div class="fb-like" data-send="false" data-layout="button_count" data-width="90" data-show-faces="false"></div></li><li> <a href="https://twitter.com/share" class="twitter-share-button" data-lang="en" data-count="horizontal">Tweet</a></li><li> <g:plusone size="medium" annotation="bubble" width="120"></g:plusone></li><li> <a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fcavaliersnation.com%2F2022%2F01%2F07%2Freport-rajon-rondo-likely-to-make-cavs-debut-on-friday-vs-trail-blazers%2F&media=https://cavaliersnation.com/wp-content/uploads/2022/01/Screen-Shot-2022-01-07-at-10.06.16-AM.jpg&description=Report: Rajon Rondo likely to make Cavs debut on Friday vs. Trail Blazers" class="pin-it-button" count-layout="horizontal">Pin It</a></li></ul></li><li><div class="post-update">Updated: January 7, 2022</div></li></ul></div><div id="post-area" class="post-54138 post type-post status-publish format-standard has-post-thumbnail category-team-news tag-cleveland-cavaliers tag-featured tag-news-ticker tag-rajon-rondo"><div class="post-image"> <img width="1300" height="1015" src="https://cavaliersnation.com/wp-content/uploads/2022/01/Screen-Shot-2022-01-07-at-10.06.16-AM.jpg" class="attachment-post-thumb size-post-thumb wp-post-image" alt="Rajon Rondo" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2022/01/Screen-Shot-2022-01-07-at-10.06.16-AM.jpg 1300w, https://cavaliersnation.com/wp-content/uploads/2022/01/Screen-Shot-2022-01-07-at-10.06.16-AM-300x234.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/01/Screen-Shot-2022-01-07-at-10.06.16-AM-1024x800.jpg 1024w, https://cavaliersnation.com/wp-content/uploads/2022/01/Screen-Shot-2022-01-07-at-10.06.16-AM-300x234@2x.jpg 600w" sizes="(max-width: 1300px) 100vw, 1300px" /></div><div id="content-area"><p><a title="Cleveland Cavaliers" href="https://cavaliersnation.com/tag/cleveland-cavaliers/">Cleveland Cavaliers</a> guard <a title="Rajon Rondo" href="https://cavaliersnation.com/tag/rajon-rondo/">Rajon Rondo</a> is likely to make his debut with the team on Friday night against the Portland Trail Blazers.</p><p>Rondo has cleared the NBA’s health and safety protocols and is listed as probable for Friday’s contest.</p><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr"><a href="https://twitter.com/hashtag/Cavs?src=hash&amp;ref_src=twsrc%5Etfw">#Cavs</a> <a title="Cedi Osman" href="https://cavaliersnation.com/tag/cedi-osman/">Cedi Osman</a> and <a title="Rajon Rondo" href="https://cavaliersnation.com/tag/rajon-rondo/">Rajon Rondo</a> have been cleared from health and safety protocols. They are both listed as probable to play tomorrow night against the Trail Blazers.</p><p>&mdash; Camryn Justice (@camijustice) <a href="https://twitter.com/camijustice/status/1479228348496809986?ref_src=twsrc%5Etfw">January 6, 2022</a></p></blockquote><p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><p>The Cavaliers acquired Rondo in a <a href="https://lakersdaily.com/report-lakers-to-send-denzel-valentine-to-knicks-as-rajon-rondo-deal-becomes-a-3-team-trade/">three-team deal</a> with the Los Angeles Lakers and New York Knicks.</p><p>With <a title="Collin Sexton" href="https://cavaliersnation.com/tag/collin-sexton/">Collin Sexton</a> (torn meniscus) and <a title="Ricky Rubio" href="https://cavaliersnation.com/tag/ricky-rubio/">Ricky Rubio</a> (torn ACL) both out for the season, the Cavaliers brought Rondo in to fix their depth at the guard position behind <a title="Darius Garland" href="https://cavaliersnation.com/tag/darius-garland/">Darius Garland</a>.</p><p>Rondo, a four-time All-Star, should help steady the Cavs’ backcourt for the remainder of the 2021-22 season. This season, the veteran point guard is averaging 3.1 points, 2.7 rebounds and 3.7 assists in 16.1 minutes per game.</p><p>The 35-year-old appeared in 18 games for the Lakers this season, and he shot 32.4 percent from the field and 26.7 percent from beyond the arc for Los Angeles.</p><p>The Cavs really found a need for Rondo after Garland <a href="https://cavaliersnation.com/2021/12/28/darius-garland-enters-health-and-safety-protocols-for-cavs/">entered</a> the league’s health and safety protocols. Cleveland was forced to play Kevin Pangos in Garland&#8217;s place. Garland has since <a href="https://cavaliersnation.com/2022/01/04/report-darius-garland-expected-to-return-to-cavs-lineup-vs-grizzlies-after-clearing-health-and-safety-protocols/">returned</a> to the Cavs lineup.</p><p>Cleveland has been one of the league’s biggest surprises this season, as the Cavs are 21-17 and currently hold the No. 6 spot in the Eastern Conference.</p><p>The Trail Blazers have not fared nearly as well, as they enter Friday’s game with a 14-23 record.</p><p>The Cavs and Blazers are scheduled to tip off at 10 p.m. EST on Friday night from Moda Center. It will be interesting to see <a href="https://cavaliersnation.com/2022/01/05/j-b-bickerstaff-discloses-how-many-minutes-per-game-rajon-rondo-will-play-for-the-cavs/">how much</a> Rondo plays in his debut for Cleveland.</p><div id="contentad123909"></div> <script type="text/javascript">(function(d) {
        var params =
        {
            id: "e576b5e3-63b7-43fe-8588-310c094931f8",
            d:  "Y2F2YWxpZXJzbmF0aW9uLmNvbQ==",
            wid: "123909",
            cb: (new Date()).getTime()
        };

        var qs=[];
        for(var key in params) qs.push(key+'='+encodeURIComponent(params[key]));
        var s = d.createElement('script');s.type='text/javascript';s.async=true;
        var p = 'https:' == document.location.protocol ? 'https' : 'http';
        s.src = p + "://api.content-ad.net/Scripts/widget2.aspx?" + qs.join('&');
        d.getElementById("contentad123909").appendChild(s);
    })(document);</script> <div class="post-tags"> <a href="https://cavaliersnation.com/tag/cleveland-cavaliers/" rel="tag">cleveland cavaliers</a><a href="https://cavaliersnation.com/tag/featured/" rel="tag">featured</a><a href="https://cavaliersnation.com/tag/news-ticker/" rel="tag">news ticker</a><a href="https://cavaliersnation.com/tag/rajon-rondo/" rel="tag">rajon rondo</a></div><div class="prev-next-wrapper"><div class="prev-post"> &larr; Previous Story <a href="https://cavaliersnation.com/2022/01/04/report-darius-garland-expected-to-return-to-cavs-lineup-vs-grizzlies-after-clearing-health-and-safety-protocols/" rel="prev">Report: Darius Garland clears health and safety protocols, expected to return to Cavs lineup vs. Grizzlies</a></div><div class="next-post"> Next Story &rarr; <a href="https://cavaliersnation.com/2022/01/07/report-cavs-guaranteeing-lamar-stevens-contract-for-the-rest-of-the-season/" rel="next">Report: Cavs guaranteeing Lamar Stevens&#8217; contract for the rest of the season</a></div></div></div><div id="related-posts"><h3>Related Posts</h3><ul><li><div class="related-image"> <a href="https://cavaliersnation.com/2022/01/07/report-cavs-looking-for-more-playmaking-despite-trading-for-rajon-rondo/" rel="bookmark" title="Report: Cavs looking for more playmaking despite trading for Rajon Rondo"><img width="300" height="195" src="https://cavaliersnation.com/wp-content/uploads/2021/12/USATSI_17284477-300x195.jpg" class="attachment-large-thumb size-large-thumb wp-post-image" alt="J.B. Bickerstaff and Darius Garland" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2021/12/USATSI_17284477-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2021/12/USATSI_17284477-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2021/12/USATSI_17284477-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="related-text"> <a href="https://cavaliersnation.com/2022/01/07/report-cavs-looking-for-more-playmaking-despite-trading-for-rajon-rondo/" class="main-headline">Report: Cavs looking for more playmaking despite trading for Rajon Rondo</a></div></li><li><div class="related-image"> <a href="https://cavaliersnation.com/2022/01/07/report-cavs-guaranteeing-lamar-stevens-contract-for-the-rest-of-the-season/" rel="bookmark" title="Report: Cavs guaranteeing Lamar Stevens&#8217; contract for the rest of the season"><img width="300" height="195" src="https://cavaliersnation.com/wp-content/uploads/2022/01/USATSI_17444988-1-300x195.jpg" class="attachment-large-thumb size-large-thumb wp-post-image" alt="Lamar Stevens" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2022/01/USATSI_17444988-1-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/01/USATSI_17444988-1-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2022/01/USATSI_17444988-1-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="related-text"> <a href="https://cavaliersnation.com/2022/01/07/report-cavs-guaranteeing-lamar-stevens-contract-for-the-rest-of-the-season/" class="main-headline">Report: Cavs guaranteeing Lamar Stevens&#8217; contract for the rest of the season</a></div></li><li><div class="related-image"> <a href="https://cavaliersnation.com/2022/01/06/kevin-love-offers-opposite-reaction-of-lebron-james-on-wizards-analysts-nasty-words-about-kevin-porter-jr-father/" rel="bookmark" title="Kevin Love offers opposite reaction of LeBron on Wizards analyst&#8217;s nasty words about Kevin Porter Jr.&#8217;s father"><img width="300" height="195" src="https://cavaliersnation.com/wp-content/uploads/2021/10/USATSI_16897298_168386351_lowres-300x195.jpg" class="attachment-large-thumb size-large-thumb wp-post-image" alt="Kevin Love Cavs" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2021/10/USATSI_16897298_168386351_lowres-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2021/10/USATSI_16897298_168386351_lowres-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2021/10/USATSI_16897298_168386351_lowres-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="related-text"> <a href="https://cavaliersnation.com/2022/01/06/kevin-love-offers-opposite-reaction-of-lebron-james-on-wizards-analysts-nasty-words-about-kevin-porter-jr-father/" class="main-headline">Kevin Love offers opposite reaction of LeBron on Wizards analyst&#8217;s nasty words about Kevin Porter Jr.&#8217;s father</a></div></li></ul></div><div id="comments"><p> You must be logged in to post a comment <a href="https://cavaliersnation.com/wp-login.php?redirect_to=https%3A%2F%2Fcavaliersnation.com%2F2022%2F01%2F07%2Freport-rajon-rondo-likely-to-make-cavs-debut-on-friday-vs-trail-blazers%2F"> Login </a></p></div></div><div id="sidebar-wrapper"><div class="widget-container"><div class="widget-inner"><h4 class="widget-header">About Peter Dewey</h4><div class="author-image"> <img class="avatar avatar-60 photo" width="64" height="64" src="https://cavaliersnation.com/wp-content/uploads/2020/05/IMG_7975-1-150x150-1.jpg"/></div><p class="author-box gd-widgets">Peter is a graduate of Quinnipiac University where he covered the MAAC and college basketball for three years. He has worked for NBC Sports, the Connecticut Sun and the Meriden Record-Journal covering basketball and other major sports. Follow him on Twitter @peterdewey2.</p></div></div><div class="widget-container"> <span class="blog-cat-title">Recent</span><div class="widget-img"> <a href="https://cavaliersnation.com/2022/01/07/report-cavs-looking-for-more-playmaking-despite-trading-for-rajon-rondo/" rel="bookmark" title="Report: Cavs looking for more playmaking despite trading for Rajon Rondo"><img width="300" height="195" src="https://cavaliersnation.com/wp-content/uploads/2021/12/USATSI_17284477-300x195.jpg" class="attachment-large-thumb size-large-thumb wp-post-image" alt="J.B. Bickerstaff and Darius Garland" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2021/12/USATSI_17284477-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2021/12/USATSI_17284477-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2021/12/USATSI_17284477-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="widget-inner"><h3 class="home-title1"><a href="https://cavaliersnation.com/2022/01/07/report-cavs-looking-for-more-playmaking-despite-trading-for-rajon-rondo/" rel="bookmark">Report: Cavs looking for more playmaking despite trading for Rajon Rondo</a></h3><p class="gd-widgets">The Cleveland Cavaliers are looking for more playmaking despite recently landing guard Rajon Rondo, according to NBA insider Marc...</p><ul class="home-links1"><li><a href="https://cavaliersnation.com/2022/01/02/report-cavs-believe-they-have-3-future-all-stars-in-darius-garland-jarrett-allen-and-evan-mobley/" rel="bookmark">Report: Cavs believe they have 3 future All-Stars in Darius Garland, Jarrett Allen and Evan Mobley</a></li><li><a href="https://cavaliersnation.com/2022/01/02/report-cavs-have-2-adamant-stipulations-for-any-major-trade-as-ben-simmons-rumors-heat-up/" rel="bookmark">Report: Cavs have 2 adamant stipulations for any major trade as Ben Simmons rumors heat up</a></li><li><a href="https://cavaliersnation.com/2021/12/30/report-cavs-in-serious-talks-to-acquire-rajon-rondo-from-lakers/" rel="bookmark">Report: Cavs in ‘serious talks’ to acquire Rajon Rondo from Lakers</a></li><li><a href="https://cavaliersnation.com/2021/12/28/report-there-was-some-chin-rubbing-in-evan-mobleys-camp-when-cavs-gave-jarrett-allen-a-monster-deal-in-offseason/" rel="bookmark">Report: There was &#8216;chin rubbing&#8217; in Evan Mobley&#8217;s camp when Cavs gave Jarrett Allen a monster deal</a></li></ul></div></div><div class="widget-container"><div id="yikes_easy_mc_widget-5" class="widget-inner widget_yikes_easy_mc_widget"><h4 class="widget-header">Subscribe to get your daily Cleveland Cavaliers news, rumors, and videos!</h4><section id="yikes-mailchimp-container-1" class="yikes-mailchimp-container yikes-mailchimp-container-1 "><form id="cavaliers-nation-1" class="yikes-easy-mc-form yikes-easy-mc-form-1  " method="POST" data-attr-form-id="1"> <label for="yikes-easy-mc-form-1-EMAIL"  class="EMAIL-label yikes-mailchimp-field-required "> <span class="EMAIL-label"> Email Address </span> <input id="yikes-easy-mc-form-1-EMAIL"  name="EMAIL"  placeholder=""  class="yikes-easy-mc-email "  required="required" type="email"  value=""> </label> <label for="yikes-easy-mc-form-1-FNAME"  class="FNAME-label "> <span class="FNAME-label"> First Name </span> <input id="yikes-easy-mc-form-1-FNAME"  name="FNAME"  placeholder=""  class="yikes-easy-mc-text "   type="text"  value=""> </label> <label for="yikes-easy-mc-form-1-LNAME"  class="LNAME-label "> <span class="LNAME-label"> Last Name </span> <input id="yikes-easy-mc-form-1-LNAME"  name="LNAME"  placeholder=""  class="yikes-easy-mc-text "   type="text"  value=""> </label> <input type="hidden" name="yikes-mailchimp-honeypot" id="yikes-mailchimp-honeypot-1" value=""> <input type="hidden" name="yikes-mailchimp-associated-list-id" id="yikes-mailchimp-associated-list-id-1" value="fd937dddf1"> <input type="hidden" name="yikes-mailchimp-submitted-form" id="yikes-mailchimp-submitted-form-1" value="1"> <button type="submit" class="yikes-easy-mc-submit-button yikes-easy-mc-submit-button-1 btn btn-primary "> <span class="yikes-mailchimp-submit-button-span-text">Submit</span></button> <input type="hidden" id="yikes_easy_mc_new_subscriber_1" name="yikes_easy_mc_new_subscriber" value="a4e03e5f43"> <input type="hidden" name="_wp_http_referer" value="/2022/01/07/report-rajon-rondo-likely-to-make-cavs-debut-on-friday-vs-trail-blazers/" /></form></section></div></div></div></div></div></div></div></div><div id="footer-wrapper"><div id="footer"><div id="footer-nav"><div class="menu-home-container"><ul id="menu-home-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75"><a href="https://cavaliersnation.com/">Home</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-41"><a title="Categories">Categories</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a href="https://cavaliersnation.com/category/game-reports/">Game Reports</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82"><a href="https://cavaliersnation.com/category/editorials/">Editorials</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-84"><a href="https://cavaliersnation.com/category/team-news/">Team News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a href="https://cavaliersnation.com/category/rumors/">Rumors</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83"><a href="https://cavaliersnation.com/category/media/">Media</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-86"><a href="https://cavaliersnation.com/category/videos/">Videos</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://cavaliersnation.com/schedule/">Schedule</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48"><a href="https://cavaliersnation.com/contributors/">Contributors</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a href="https://cavaliersnation.com/about/">About</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9117"><a href="https://cavaliersnation.com/career/">Career</a></li></ul></div></div><div id="copyright"><p>Copyright © 2014 Cavaliers Nation, All Rights Reserved. Property of <a href="https://ahnfiredigital.com">Ahn Fire Digital</a>. Partner with USA Today Sports Digital
Properties. <a href="https://cavaliersnation.com/privacy-policy">Privacy Policy</a></p></div></div></div></div> <script id=cls-insertion-bd3bbeb>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</script><script>(function () {var clsElements = document.querySelectorAll("script[id^='cls-']"); window.adthriveCLS && clsElements && clsElements.length === 0 ? window.adthriveCLS.injectedFromPlugin = false : ""; })();</script> <script type='text/javascript'>//

jQuery(document).ready(function($){

  $(window).load(function(){

    $('.flexslider').flexslider({

	animation: 'fade',

	slideshowSpeed: 8000

    	});

  	});



$('.carousel').elastislide({

	imageW 	: 80,

	minItems	: 2,

	margin		: 3

});

});

//</script> <script type="text/javascript">//

!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.async=true;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");

//</script> <script type="text/javascript">//

(function() {

    window.PinIt = window.PinIt || { loaded:false };

    if (window.PinIt.loaded) return;

    window.PinIt.loaded = true;

    function async_load(){

        var s = document.createElement("script");

        s.type = "text/javascript";

        s.async = true;

        s.src = "https://assets.pinterest.com/js/pinit.js";

        var x = document.getElementsByTagName("script")[0];

        x.parentNode.insertBefore(s, x);

    }

    if (window.attachEvent)

        window.attachEvent("onload", async_load);

    else

        window.addEventListener("load", async_load, false);

})();

//</script> <script type="text/javascript">//

  (function() {

    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;

    po.src = 'https://apis.google.com/js/plusone.js';

    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);

  })();

//</script> <div id="fb-root"></div> <script type="text/javascript">//

(function(d, s, id) {

  var js, fjs = d.getElementsByTagName(s)[0];

  if (d.getElementById(id)) return;

  js = d.createElement(s); js.id = id;

  js.async = true;

  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";

  fjs.parentNode.insertBefore(js, fjs);

}(document, 'script', 'facebook-jssdk'));

//</script> <script type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/comment-reply.min.js?ver=5.8.3' id='comment-reply-js'></script> <script type='text/javascript' id='stickThis-js-extra'>var sticky_anything_engage = {"element":".ad-728","topspace":"0","minscreenwidth":"0","maxscreenwidth":"999999","zindex":"1","legacymode":"","dynamicmode":"","debugmode":"","pushup":"","adminbar":"1"};</script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/sticky-menu-or-anything-on-scroll/assets/js/stickThis.js?ver=2.1.1' id='stickThis-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/jquery.flexslider.js?ver=5.8.3' id='flexslider-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/jquery.elastislide.js?ver=5.8.3' id='elastislide-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/scripts.js?ver=5.8.3' id='gameday-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/ticker.js?ver=5.8.3' id='ticker-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/respond.min.js?ver=5.8.3' id='respond-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/css3-mediaqueries.js?ver=5.8.3' id='queries-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/retina.js?ver=5.8.3' id='retina-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/wp-embed.min.js?ver=5.8.3' id='wp-embed-js'></script> <script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.8.3' async='async' id='remote_sdk-js'></script> <script type='text/javascript' id='yikes-easy-mc-ajax-js-extra'>var yikes_mailchimp_ajax = {"ajax_url":"https:\/\/cavaliersnation.com\/wp-admin\/admin-ajax.php","page_data":"53970","interest_group_checkbox_error":"This field is required.","preloader_url":"https:\/\/cavaliersnation.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/ripple.svg","loading_dots":"https:\/\/cavaliersnation.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/bars.svg","ajax_security_nonce":"c8cf6e8da6","feedback_message_placement":"before"};</script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/yikes-mc-ajax-forms.min.js?ver=6.8.6' id='yikes-easy-mc-ajax-js'></script> <script type='text/javascript' id='form-submission-helpers-js-extra'>var form_submission_helpers = {"ajax_url":"https:\/\/cavaliersnation.com\/wp-admin\/admin-ajax.php","preloader_url":"https:\/\/cavaliersnation.com\/wp-admin\/images\/wpspin_light.gif","countries_with_zip":{"US":"US","GB":"GB","CA":"CA","IE":"IE","CN":"CN","IN":"IN","AU":"AU","BR":"BR","MX":"MX","IT":"IT","NZ":"NZ","JP":"JP","FR":"FR","GR":"GR","DE":"DE","NL":"NL","PT":"PT","ES":"ES"},"page_data":"53970"};</script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/form-submission-helpers.min.js?ver=6.8.6' id='form-submission-helpers-js'></script> <script>!function(){"use strict";!function(e){if(-1===e.cookie.indexOf("__adblocker")){e.cookie="__adblocker=; expires=Thu, 01 Jan 1970 00:00:00 GMT; path=/";var t=new XMLHttpRequest;t.open("GET","https://www.npttech.com/advertising.js",!0),t.onreadystatechange=function(){if(XMLHttpRequest.DONE===t.readyState)if(200===t.status){var n=e.createElement("script");n.innerHTML=t.responseText,e.getElementsByTagName("head")[0].appendChild(n)}else{var a=new Date;a.setTime(a.getTime()+3e5),e.cookie="__adblocker=true; expires="+a.toUTCString()+"; path=/"}},t.send()}}(document)}();</script><script>!function(){"use strict";var e;e=document,function(){var t,n;function r(){var t=e.createElement("script");t.src="https://cafemedia-com.videoplayerhub.com/galleryplayer.js",e.head.appendChild(t)}function a(){var t=e.cookie.match("(^|[^;]+)\\s*__adblocker\\s*=\\s*([^;]+)");return t&&t.pop()}function c(){clearInterval(n)}return{init:function(){var e;"true"===(t=a())?r():(e=0,n=setInterval((function(){100!==e&&"false"!==t||c(),"true"===t&&(r(),c()),t=a(),e++}),50))}}}().init()}();</script> </body></html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Object Caching 150/182 objects using disk
Page Caching using disk: enhanced 

Served from: cavaliersnation.com @ 2022-01-07 18:25:01 by W3 Total Cache
-->