<!DOCTYPE html><html
xmlns=http://www.w3.org/1999/xhtml lang=en-US><head> <script src="https://us.connextra.com/dcs/tagController/tag/362820167f7c/homepage" async defer></script> <meta
name="verifyownership"
content="8b17572d9adc3b6cbc654dc1d5d043e5"><meta
name="verifyownership"
content="16a1e10dad87b5c0fc759f5de4f6f60e"> <script async src=//js-sec.indexww.com/ht/p/184031-43290852983293.js></script>  <script>var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "6035223" });
  (function() {
    var s = document.createElement("script"), el =
document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb<https://sb/>" :
"http://b<http://b/>") +
".scorecardresearch.com/beacon.js<http://scorecardresearch.com/beacon.js>";
    el.parentNode.insertBefore(s, el);
  })();</script> <noscript>
<img
src="https://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1">
</noscript>
 <script async custom-element=amp-ad src=https://cdn.ampproject.org/v0/amp-ad-0.1.js></script> <meta
name="google-site-verification" content="KStSRn6409ttzCYidg-n9MD7blSVvoj25HKqQg3hg5Y"><meta
http-equiv="Content-Type" content="text/html; charset=UTF-8"><meta
name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1"><meta
property="og:image" content="https://cavaliersnation.com/wp-content/uploads/2020/06/Larry-Nance-Jr-615x400.jpg"><link
media=all href=https://cavaliersnation.com/wp-content/cache/autoptimize/css/autoptimize_f01b2e86798ecc5933f7e7ff34aebfa3.css rel=stylesheet><title>Larry Nance Jr. fires back at hater who tells him to &#039;get your a-- out there&#039; amidst injury recovery | Cavaliers Nation</title><!--[if IE]><link
rel=stylesheet type=text/css href=https://cavaliersnation.com/wp-content/themes/gameday/css/iecss.css><![endif]--><link
rel="shortcut icon" href=https://cavaliersnation.com/wp-content/uploads/2017/10/cavaliersnationlogo-1.jpg><link
rel=alternate type=application/rss+xml title="RSS 2.0" href=https://cavaliersnation.com/feed/ ><link
rel=alternate type=text/xml title="RSS .92" href=https://cavaliersnation.com/feed/rss/ ><link
rel=alternate type=application/atom+xml title="Atom 0.3" href=https://cavaliersnation.com/feed/atom/ ><link
rel=pingback href=https://cavaliersnation.com/xmlrpc.php> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-56943371-1', 'auto');
  ga('send', 'pageview');</script> <script>(function(w, d) {
	w.adthrive = w.adthrive || {};
	w.adthrive.cmd = w.adthrive.cmd || [];
	w.adthrive.plugin = 'adthrive-ads-1.0.43';
	w.adthrive.host = 'ads.adthrive.com';

	var s = d.createElement('script');
	s.async = true;
	s.referrerpolicy='no-referrer-when-downgrade';
	s.src = 'https://' + w.adthrive.host + '/sites/5b48a37c9be6984315eaf2ce/ads.min.js?referrer=' + w.encodeURIComponent(w.location.href);
	var n = d.getElementsByTagName('script')[0];
	n.parentNode.insertBefore(s, n);
})(window, document);</script> <meta
name="description" content="Cleveland Cavaliers forward Larry Nance Jr. will be out for a significant period of time after undergoing surgery on his hand last week. The Cavs forward was in the midst of a solid season, as he was averaging 9.3 points, 6.8 rebounds and 3.2 assists per game before he was injured."><meta
name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><link
rel=canonical href=https://cavaliersnation.com/2021/02/16/larry-nance-jr-fires-back-at-hater-who-tells-him-to-get-your-a-out-there-amidst-injury-recovery/ ><meta
property="og:locale" content="en_US"><meta
property="og:type" content="article"><meta
property="og:title" content="Larry Nance Jr. fires back at hater who tells him to &#039;get your a-- out there&#039; amidst injury recovery"><meta
property="og:description" content="Cleveland Cavaliers forward Larry Nance Jr. will be out for a significant period of time after undergoing surgery on his hand last week. The Cavs forward was in the midst of a solid season, as he was averaging 9.3 points, 6.8 rebounds and 3.2 assists per game before he was injured."><meta
property="og:url" content="https://cavaliersnation.com/2021/02/16/larry-nance-jr-fires-back-at-hater-who-tells-him-to-get-your-a-out-there-amidst-injury-recovery/"><meta
property="og:site_name" content="Cavaliers Nation"><meta
property="article:publisher" content="https://www.facebook.com/CavaliersNation/"><meta
property="article:published_time" content="2021-02-16T16:33:00+00:00"><meta
property="article:modified_time" content="2021-02-16T16:42:32+00:00"><meta
property="og:image" content="https://cavaliersnation.com/wp-content/uploads/2020/06/Larry-Nance-Jr.jpg"><meta
property="og:image:width" content="1800"><meta
property="og:image:height" content="1200"><meta
name="twitter:card" content="summary_large_image"><meta
name="twitter:creator" content="@WeAreCavsNation"><meta
name="twitter:site" content="@WeAreCavsNation"> <script type=application/ld+json class=yoast-schema-graph>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</script> <link
rel=amphtml href=https://cavaliersnation.com/2021/02/16/larry-nance-jr-fires-back-at-hater-who-tells-him-to-get-your-a-out-there-amidst-injury-recovery/amp/ ><meta
name="generator" content="AMP for WP 1.0.76.1"><link
rel=dns-prefetch href=//fonts.googleapis.com><link
rel=dns-prefetch href=//s.w.org><link
rel=alternate type=application/rss+xml title="Cavaliers Nation &raquo; Feed" href=https://cavaliersnation.com/feed/ ><link
rel=alternate type=application/rss+xml title="Cavaliers Nation &raquo; Comments Feed" href=https://cavaliersnation.com/comments/feed/ > <script>window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cavaliersnation.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link
rel=stylesheet id=googlefonts-css  href='https://fonts.googleapis.com/css?family=Open+Sans+Condensed%3A300%2C700%7COpen+Sans%3A400%2C700%7COswald%3A300%2C400%2C700&#038;subset=latin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese&#038;ver=5.6.1' type=text/css media=all> <script src='https://cavaliersnation.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id=jquery-core-js></script> <script src='https://cavaliersnation.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id=jquery-migrate-js></script> <script src='https://cavaliersnation.com/wp-content/plugins/sticky-menu-or-anything-on-scroll/assets/js/jq-sticky-anything.min.js?ver=2.1.1' id=stickyAnythingLib-js></script> <script src='https://cavaliersnation.com/wp-content/plugins/wp-retina-2x/app/picturefill.min.js?ver=1610032081' id=wr2x-picturefill-js-js></script> <link
rel=https://api.w.org/ href=https://cavaliersnation.com/wp-json/ ><link
rel=alternate type=application/json href=https://cavaliersnation.com/wp-json/wp/v2/posts/50050><link
rel=EditURI type=application/rsd+xml title=RSD href=https://cavaliersnation.com/xmlrpc.php?rsd><link
rel=wlwmanifest type=application/wlwmanifest+xml href=https://cavaliersnation.com/wp-includes/wlwmanifest.xml><meta
name="generator" content="WordPress 5.6.1"><link
rel=shortlink href='https://cavaliersnation.com/?p=50050'><link
rel=alternate type=application/json+oembed href="https://cavaliersnation.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcavaliersnation.com%2F2021%2F02%2F16%2Flarry-nance-jr-fires-back-at-hater-who-tells-him-to-get-your-a-out-there-amidst-injury-recovery%2F"><link
rel=alternate type=text/xml+oembed href="https://cavaliersnation.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcavaliersnation.com%2F2021%2F02%2F16%2Flarry-nance-jr-fires-back-at-hater-who-tells-him-to-get-your-a-out-there-amidst-injury-recovery%2F&#038;format=xml"><meta
name="onesignal" content="wordpress-plugin"> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://cavaliersnation.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'b691d3c3-97cc-4969-a5c2-2d07e83c1aba';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://cavaliersnation.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.28671d66-3da8-4a50-bcc4-1b29e015670b";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script> <link
rel=icon href=https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg sizes=32x32><link
rel=icon href=https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg sizes=192x192><link
rel=apple-touch-icon href=https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg><meta
name="msapplication-TileImage" content="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg"></head><body
data-rsssl=1 class="post-template-default single single-post postid-50050 single-format-standard custom-background"><div
id=site><div
id=wrapper><div
id=nav-main-wrapper><div
id=nav-main><div
id=nav-main-left><div
id=nav-logo>
<a
href=https://cavaliersnation.com><img
src=https://cavaliersnation.com/wp-content/uploads/2019/05/cnwebsite12.png alt="Cavaliers Nation"></a></div><ul
class=nav-main><div
class=menu-home-container><ul
id=menu-home class=menu><li
id=menu-item-75 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75"><a
href=https://cavaliersnation.com/ >Home</a></li><li
id=menu-item-41 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-41"><a
title=Categories>Categories</a><ul
class=sub-menu><li
id=menu-item-81 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a
href=https://cavaliersnation.com/category/game-reports/ >Game Reports</a></li><li
id=menu-item-82 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82"><a
href=https://cavaliersnation.com/category/editorials/ >Editorials</a></li><li
id=menu-item-84 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84"><a
href=https://cavaliersnation.com/category/team-news/ >Team News</a></li><li
id=menu-item-85 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a
href=https://cavaliersnation.com/category/rumors/ >Rumors</a></li><li
id=menu-item-83 class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83"><a
href=https://cavaliersnation.com/category/media/ >Media</a></li><li
id=menu-item-86 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-86"><a
href=https://cavaliersnation.com/category/videos/ >Videos</a></li></ul></li><li
id=menu-item-39 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a
href=https://cavaliersnation.com/schedule/ >Schedule</a></li><li
id=menu-item-48 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48"><a
href=https://cavaliersnation.com/contributors/ >Contributors</a></li><li
id=menu-item-40 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a
href=https://cavaliersnation.com/about/ >About</a></li><li
id=menu-item-9117 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9117"><a
href=https://cavaliersnation.com/career/ >Career</a></li></ul></div></ul><div
id=nav-mobi><div
class=menu-home-container><select><option
value=#>Menu</option><option
value=https://cavaliersnation.com/ >Home</option><option
value>Categories<option
value=https://cavaliersnation.com/category/game-reports/ >-Game Reports</option><option
value=https://cavaliersnation.com/category/editorials/ >-Editorials</option><option
value=https://cavaliersnation.com/category/team-news/ >-Team News</option><option
value=https://cavaliersnation.com/category/rumors/ >-Rumors</option><option
value=https://cavaliersnation.com/category/media/ >-Media</option><option
value=https://cavaliersnation.com/category/videos/ >-Videos</option></option><option
value=https://cavaliersnation.com/schedule/ >Schedule</option><option
value=https://cavaliersnation.com/contributors/ >Contributors</option><option
value=https://cavaliersnation.com/about/ >About</option><option
value=https://cavaliersnation.com/career/ >Career</option>
</select></div></div></div><div
id=nav-search><form
method=get id=searchform action=https://cavaliersnation.com/ >
<input
type=text name=s id=s value=Search onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }'>
<input
type=hidden id=search-button></form></div></div></div><div
id=main-wrapper><div
id=top-spacer></div><div
id=content-outer><div
id=main-top><div
id=ticker><span
class=ticker-heading>Don't Miss</span><ul
class=ticker-list><li><a
href=https://cavaliersnation.com/2021/02/16/larry-nance-jr-fires-back-at-hater-who-tells-him-to-get-your-a-out-there-amidst-injury-recovery/ >Larry Nance Jr. fires back at hater who tells him to &#8216;get your a&#8211; out there&#8217; amidst injury recovery</a></li><li><a
href=https://cavaliersnation.com/2021/02/16/draymond-green-uses-andre-drummond-as-powerful-example-while-destroying-nbas-treatment-of-players/ >Draymond Green cites Andre Drummond as he destroys NBA’s treatment of players</a></li><li><a
href=https://cavaliersnation.com/2021/02/16/video-draymond-green-humiliates-cedi-osman-after-he-airballs-3-pointer-vs-warriors/ >Video: Draymond Green humiliates Cedi Osman after he airballs 3-pointer vs. Warriors</a></li><li><a
href=https://cavaliersnation.com/2021/02/15/video-angry-jarrett-allen-gets-into-it-with-collin-sexton-during-game-vs-warriors/ >Video: Angry Jarrett Allen goes off on Collin Sexton during game vs. Warriors</a></li><li><a
href=https://cavaliersnation.com/2021/02/15/report-mavericks-and-nets-targeting-andre-drummond-via-buyout-market/ >Report: Mavericks and Nets targeting Andre Drummond via buyout market</a></li><li><a
href=https://cavaliersnation.com/2021/02/15/scout-rips-andre-drummond-he-can-get-you-30-20-have-no-impact-on-game/ >NBA scout rips Andre Drummond: &#8216;He can get you 30-20 and have no impact on the game&#8217;</a></li><li><a
href=https://cavaliersnation.com/2021/02/15/report-cavs-wont-play-andre-drummond-again-as-they-engage-in-active-trade-talks-with-raptors/ >Report: Cavs won&#8217;t play Andre Drummond again as they engage in active trade talks with Raptors</a></li><li><a
href=https://cavaliersnation.com/2021/02/14/kevin-love-highlights-lifetime-love-for-kate-bock-on-valentines-day/ >Kevin Love highlights &#8216;lifetime&#8217; love for Kate Bock on Valentine&#8217;s Day</a></li><li><a
href=https://cavaliersnation.com/2021/02/14/cavs-clippers-listed-as-out-for-sunday/ >Report: Cavs announce huge change to starting lineup for matchup vs. Clippers</a></li><li><a
href=https://cavaliersnation.com/2021/02/13/andre-drummond-expresses-extreme-frustration-as-cavs-drop-sixth-straight-its-taking-a-toll/ >Andre Drummond expresses extreme frustration as Cavs drop 6th straight: &#8216;It&#8217;s taking a toll&#8217;</a></li></ul></div><div
id=content-social><ul><li><a href="https://www.facebook.com/cavaliersnation" alt=Facebook class=fb-but target=_blank></a></li><li><a href="https://www.twitter.com/wearecavsnation" alt=Twitter class=twitter-but target=_blank></a></li><li><a href="https://www.instagram.com/cavaliersnationdotcom" alt=Instagram class=instagram-but target=_blank></a></li><li><a
href=https://cavaliersnation.com/feed/rss/ alt="RSS Feed" class=rss-but></a></li></ul></div></div><div
id=content-inner><div
id=main><div
class=breadcrumb><div
id=crumbs><a
href=https://cavaliersnation.com>Home</a> / <a
href=https://cavaliersnation.com/category/media/ >Media</a> / <span
class=current>Larry Nance Jr. fires back at hater who tells him to &#8216;get your a&#8211; out there&#8217; amidst injury recovery</span></div></div><h1 class="headline">Larry Nance Jr. fires back at hater who tells him to &#8216;get your a&#8211; out there&#8217; amidst injury recovery</h1><div
id=post-info-wrapper><ul
class=post-info><li><div
class=post-author>By <a
href=https://cavaliersnation.com/author/peter-dewey/ title="Posts by Peter Dewey" rel=author>Peter Dewey</a></div></li><li><ul
class=post-social><li><div
class=fb-like data-send=false data-layout=button_count data-width=90 data-show-faces=false></div></li><li><a href="https://twitter.com/share" class=twitter-share-button data-lang=en data-count=horizontal>Tweet</a></li><li><g:plusone size="medium" annotation="bubble" width="120"></g:plusone></li><li>
<a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fcavaliersnation.com%2F2021%2F02%2F16%2Flarry-nance-jr-fires-back-at-hater-who-tells-him-to-get-your-a-out-there-amidst-injury-recovery%2F&media=https://cavaliersnation.com/wp-content/uploads/2020/06/Larry-Nance-Jr.jpg&description=Larry Nance Jr. fires back at hater who tells him to &#8216;get your a&#8211; out there&#8217; amidst injury recovery" class=pin-it-button count-layout=horizontal>Pin It</a></li></ul></li><li><div
class=post-update>Updated: February 16, 2021</div></li></ul></div><div
id=post-area class="post-50050 post type-post status-publish format-standard has-post-thumbnail category-media tag-cleveland-cavaliers tag-featured tag-larry-nance-jr tag-news-ticker"><div
class=post-image><img
width=1800 height=1200 src=https://cavaliersnation.com/wp-content/uploads/2020/06/Larry-Nance-Jr.jpg class="attachment-post-thumb size-post-thumb wp-post-image" alt="Larry Nance Jr Cavaliers" loading=lazy srcset="https://cavaliersnation.com/wp-content/uploads/2020/06/Larry-Nance-Jr.jpg 1800w, https://cavaliersnation.com/wp-content/uploads/2020/06/Larry-Nance-Jr-300x200.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2020/06/Larry-Nance-Jr-1024x683.jpg 1024w, https://cavaliersnation.com/wp-content/uploads/2020/06/Larry-Nance-Jr-768x512.jpg 768w, https://cavaliersnation.com/wp-content/uploads/2020/06/Larry-Nance-Jr-1536x1024.jpg 1536w, https://cavaliersnation.com/wp-content/uploads/2020/06/Larry-Nance-Jr-300x200@2x.jpg 600w" sizes="(max-width: 1800px) 100vw, 1800px"></div><div
id=content-area><p><a
title="Cleveland Cavaliers" href=https://cavaliersnation.com/tag/cleveland-cavaliers/ >Cleveland Cavaliers</a> forward <a
title="Larry Nance Jr" href=https://cavaliersnation.com/tag/larry-nance-jr/ >Larry Nance Jr</a>. will be out for a significant period of time after undergoing surgery on his hand last week.</p><p>The Cavs forward was in the midst of a solid season, as he was averaging 9.3 points, 6.8 rebounds and 3.2 assists per game before he was injured.</p><p>While Nance’s injury is serious, a fan on Twitter told the 28-year-old to suit up and play again.</p><p>Not only did the fan get Nance’s injury wrong, but the Cavs forward fired back at him for suggesting that he play through the injury.</p><blockquote
class=twitter-tweet data-width=550 data-dnt=true><p
lang=en dir=ltr>My calf feels great man! Although I did have surgery on my hand (1 plate, 9 screws) last Monday. Thanks for your concern! <a
href=https://t.co/QpdyfFsiWL>https://t.co/QpdyfFsiWL</a></p><p>&mdash; <a
title="Larry Nance Jr" href=https://cavaliersnation.com/tag/larry-nance-jr/ >Larry Nance Jr</a> (@Larrydn22) <a
href="https://twitter.com/Larrydn22/status/1361507382816309251?ref_src=twsrc%5Etfw">February 16, 2021</a></p></blockquote><p><script async src=https://platform.twitter.com/widgets.js charset=utf-8></script></p><p>The Cavs have struggled recently, as they have lost eight consecutive games to fall to 10-19 on the season.</p><p>While Nance’s absence certainly doesn’t help, the Cavs are a young team in a rebuild and weren’t expected to make much noise this season.</p><p>To rush Nance back and risk further injury could jeopardize the team’s future, so the Cavs are being smart by taking the cautious approach in his recovery.</p><p>Fans may want the Cavs to get everyone out on the floor to try to win games, but there is no reason to risk Nance&#8217;s long-term future.</p><div
id=contentad123909></div> <script>(function(d) {
        var params =
        {
            id: "e576b5e3-63b7-43fe-8588-310c094931f8",
            d:  "Y2F2YWxpZXJzbmF0aW9uLmNvbQ==",
            wid: "123909",
            cb: (new Date()).getTime()
        };

        var qs=[];
        for(var key in params) qs.push(key+'='+encodeURIComponent(params[key]));
        var s = d.createElement('script');s.type='text/javascript';s.async=true;
        var p = 'https:' == document.location.protocol ? 'https' : 'http';
        s.src = p + "://api.content-ad.net/Scripts/widget2.aspx?" + qs.join('&');
        d.getElementById("contentad123909").appendChild(s);
    })(document);</script> <div
class=post-tags><a
href=https://cavaliersnation.com/tag/cleveland-cavaliers/ rel=tag>cleveland cavaliers</a><a
href=https://cavaliersnation.com/tag/featured/ rel=tag>featured</a><a
href=https://cavaliersnation.com/tag/larry-nance-jr/ rel=tag>larry nance jr.</a><a
href=https://cavaliersnation.com/tag/news-ticker/ rel=tag>news ticker</a></div><div
class=prev-next-wrapper><div
class=prev-post>&larr; Previous Story <a
href=https://cavaliersnation.com/2021/02/15/scout-rips-andre-drummond-he-can-get-you-30-20-have-no-impact-on-game/ rel=prev>NBA scout rips Andre Drummond: &#8216;He can get you 30-20 and have no impact on the game&#8217;</a></div><div
class=next-post></div></div></div><div
id=related-posts><h3>Related Posts</h3><ul><li><div
class=related-image>
<a
href=https://cavaliersnation.com/2021/02/16/draymond-green-uses-andre-drummond-as-powerful-example-while-destroying-nbas-treatment-of-players/ rel=bookmark title="Draymond Green cites Andre Drummond as he destroys NBA’s treatment of players"><img
width=300 height=195 src=https://cavaliersnation.com/wp-content/uploads/2021/02/Untitled-collage-58-300x195.jpg class="attachment-large-thumb size-large-thumb wp-post-image" alt="Draymond Green and Andre Drummond" loading=lazy srcset="https://cavaliersnation.com/wp-content/uploads/2021/02/Untitled-collage-58-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2021/02/Untitled-collage-58-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2021/02/Untitled-collage-58-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px"></a></div><div
class=related-text><a
href=https://cavaliersnation.com/2021/02/16/draymond-green-uses-andre-drummond-as-powerful-example-while-destroying-nbas-treatment-of-players/ class=main-headline>Draymond Green cites Andre Drummond as he destroys NBA’s treatment of players</a></div></li><li><div
class=related-image>
<a
href=https://cavaliersnation.com/2021/02/16/video-draymond-green-humiliates-cedi-osman-after-he-airballs-3-pointer-vs-warriors/ rel=bookmark title="Video: Draymond Green humiliates Cedi Osman after he airballs 3-pointer vs. Warriors"><img
width=300 height=195 src=https://cavaliersnation.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-15-at-9.38.37-PM-300x195.jpg class="attachment-large-thumb size-large-thumb wp-post-image" alt="Draymond Green" loading=lazy srcset="https://cavaliersnation.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-15-at-9.38.37-PM-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-15-at-9.38.37-PM-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-15-at-9.38.37-PM-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px"></a></div><div
class=related-text><a
href=https://cavaliersnation.com/2021/02/16/video-draymond-green-humiliates-cedi-osman-after-he-airballs-3-pointer-vs-warriors/ class=main-headline>Video: Draymond Green humiliates Cedi Osman after he airballs 3-pointer vs. Warriors</a></div></li><li><div
class=related-image>
<a
href=https://cavaliersnation.com/2021/02/15/video-angry-jarrett-allen-gets-into-it-with-collin-sexton-during-game-vs-warriors/ rel=bookmark title="Video: Angry Jarrett Allen goes off on Collin Sexton during game vs. Warriors"><img
width=300 height=195 src=https://cavaliersnation.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-15-at-8.44.45-PM-300x195.jpg class="attachment-large-thumb size-large-thumb wp-post-image" alt="Jarrett Allen and Collin Sexton" loading=lazy srcset="https://cavaliersnation.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-15-at-8.44.45-PM-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-15-at-8.44.45-PM-1024x670.jpg 1024w, https://cavaliersnation.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-15-at-8.44.45-PM-1536x1006.jpg 1536w, https://cavaliersnation.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-15-at-8.44.45-PM-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-15-at-8.44.45-PM-108x70.jpg 108w, https://cavaliersnation.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-15-at-8.44.45-PM.jpg 1952w" sizes="(max-width: 300px) 100vw, 300px"></a></div><div
class=related-text><a
href=https://cavaliersnation.com/2021/02/15/video-angry-jarrett-allen-gets-into-it-with-collin-sexton-during-game-vs-warriors/ class=main-headline>Video: Angry Jarrett Allen goes off on Collin Sexton during game vs. Warriors</a></div></li></ul></div><div
id=comments><p>
You must be logged in to post a comment
<a
href="https://cavaliersnation.com/wp-login.php?redirect_to=https%3A%2F%2Fcavaliersnation.com%2F2021%2F02%2F16%2Flarry-nance-jr-fires-back-at-hater-who-tells-him-to-get-your-a-out-there-amidst-injury-recovery%2F">
Login
</a></p></div></div><div
id=sidebar-wrapper><div
class=widget-container><div
class=widget-inner><h4 class="widget-header">About Peter Dewey</h4><div
class=author-image>
<img
class="avatar avatar-60 photo" width=64 height=64 src=https://cavaliersnation.com/wp-content/uploads/2020/05/IMG_7975-1-150x150-1.jpg></div><p
class="author-box gd-widgets">Peter is a graduate of Quinnipiac University where he covered the MAAC and college basketball for three years. He has worked for NBC Sports, the Connecticut Sun and the Meriden Record-Journal covering basketball and other major sports. Follow him on Twitter @peterdewey2.</p></div></div><div
class=widget-container>
<span
class=blog-cat-title>Recent</span><div
class=widget-img>
<a
href=https://cavaliersnation.com/2021/02/15/report-mavericks-and-nets-targeting-andre-drummond-via-buyout-market/ rel=bookmark title="Report: Mavericks and Nets targeting Andre Drummond via buyout market"><img
width=300 height=195 src=https://cavaliersnation.com/wp-content/uploads/2021/02/USATSI_15548231_168386351_lowres-300x195.jpg class="attachment-large-thumb size-large-thumb wp-post-image" alt="Andre Drummond Cavs" loading=lazy srcset="https://cavaliersnation.com/wp-content/uploads/2021/02/USATSI_15548231_168386351_lowres-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2021/02/USATSI_15548231_168386351_lowres-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2021/02/USATSI_15548231_168386351_lowres-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px"></a></div><div
class=widget-inner><h3 class="home-title1"><a
href=https://cavaliersnation.com/2021/02/15/report-mavericks-and-nets-targeting-andre-drummond-via-buyout-market/ rel=bookmark>Report: Mavericks and Nets targeting Andre Drummond via buyout market</a></h3><p
class=gd-widgets>Cleveland Cavaliers center Andre Drummond is reportedly being discussed in trade talks with the Toronto Raptors. However, if Drummond...</p><ul
class=home-links1><li><a
href=https://cavaliersnation.com/2021/02/15/report-cavs-wont-play-andre-drummond-again-as-they-engage-in-active-trade-talks-with-raptors/ rel=bookmark>Report: Cavs won&#8217;t play Andre Drummond again as they engage in active trade talks with Raptors</a></li><li><a
href=https://cavaliersnation.com/2021/02/12/report-cavs-are-open-for-business-ahead-of-nba-trade-deadline/ rel=bookmark>Report: Cavs are &#8216;open for business&#8217; ahead of NBA trade deadline</a></li><li><a
href=https://cavaliersnation.com/2021/02/08/report-cavs-could-receive-significant-return-for-larry-nance-jr/ rel=bookmark>Report: Cavs could receive &#8216;significant return&#8217; for Larry Nance Jr.</a></li><li><a
href=https://cavaliersnation.com/2021/02/08/cavs-toronto-raptors-interested-in-andre-drummond/ rel=bookmark>Report: Toronto Raptors interested in Andre Drummond</a></li></ul></div></div><div
class=widget-container><div
id=yikes_easy_mc_widget-5 class="widget-inner widget_yikes_easy_mc_widget"><h4 class="widget-header">Subscribe to get your daily Cleveland Cavaliers news, rumors, and videos!</h4><section
id=yikes-mailchimp-container-1 class="yikes-mailchimp-container yikes-mailchimp-container-1 "><form
id=cavaliers-nation-1 class="yikes-easy-mc-form yikes-easy-mc-form-1  " method=POST data-attr-form-id=1><label
for=yikes-easy-mc-form-1-EMAIL  class="EMAIL-label yikes-mailchimp-field-required ">
<span
class=EMAIL-label>
Email Address	</span>
<input
id=yikes-easy-mc-form-1-EMAIL  name=EMAIL  placeholder  class="yikes-easy-mc-email "  required=required type=email  value>
</label>
<label
for=yikes-easy-mc-form-1-FNAME  class="FNAME-label ">
<span
class=FNAME-label>
First Name	</span>
<input
id=yikes-easy-mc-form-1-FNAME  name=FNAME  placeholder  class="yikes-easy-mc-text "   type=text  value>
</label>
<label
for=yikes-easy-mc-form-1-LNAME  class="LNAME-label ">
<span
class=LNAME-label>
Last Name	</span>
<input
id=yikes-easy-mc-form-1-LNAME  name=LNAME  placeholder  class="yikes-easy-mc-text "   type=text  value>
</label>
<input
type=hidden name=yikes-mailchimp-honeypot id=yikes-mailchimp-honeypot-1 value>
<input
type=hidden name=yikes-mailchimp-associated-list-id id=yikes-mailchimp-associated-list-id-1 value=fd937dddf1>
<input
type=hidden name=yikes-mailchimp-submitted-form id=yikes-mailchimp-submitted-form-1 value=1>
<button
type=submit class="yikes-easy-mc-submit-button yikes-easy-mc-submit-button-1 btn btn-primary "> <span
class=yikes-mailchimp-submit-button-span-text>Submit</span></button>
<input
type=hidden id=yikes_easy_mc_new_subscriber_1 name=yikes_easy_mc_new_subscriber value=49553e739c>
<input
type=hidden name=_wp_http_referer value=/2021/02/16/larry-nance-jr-fires-back-at-hater-who-tells-him-to-get-your-a-out-there-amidst-injury-recovery/ ></form></section></div></div></div></div></div></div></div></div><div
id=footer-wrapper><div
id=footer><div
id=footer-nav><div
class=menu-home-container><ul
id=menu-home-2 class=menu><li
class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75"><a
href=https://cavaliersnation.com/ >Home</a></li><li
class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-41"><a
title=Categories>Categories</a><ul
class=sub-menu><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a
href=https://cavaliersnation.com/category/game-reports/ >Game Reports</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82"><a
href=https://cavaliersnation.com/category/editorials/ >Editorials</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84"><a
href=https://cavaliersnation.com/category/team-news/ >Team News</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a
href=https://cavaliersnation.com/category/rumors/ >Rumors</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83"><a
href=https://cavaliersnation.com/category/media/ >Media</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-86"><a
href=https://cavaliersnation.com/category/videos/ >Videos</a></li></ul></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a
href=https://cavaliersnation.com/schedule/ >Schedule</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48"><a
href=https://cavaliersnation.com/contributors/ >Contributors</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a
href=https://cavaliersnation.com/about/ >About</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9117"><a
href=https://cavaliersnation.com/career/ >Career</a></li></ul></div></div><div
id=copyright><p>Copyright © 2014 Cavaliers Nation, All Rights Reserved. Property of <a
href=https://ahnfiredigital.com>Ahn Fire Digital</a>. Partner with USA Today Sports Digital
Properties. <a
href=https://cavaliersnation.com/privacy-policy>Privacy Policy</a></p></div></div></div></div> <script>jQuery(document).ready(function($){

  $(window).load(function(){

    $('.flexslider').flexslider({

	animation: 'fade',

	slideshowSpeed: 8000

    	});

  	});



$('.carousel').elastislide({

	imageW 	: 80,

	minItems	: 2,

	margin		: 3

});

});</script> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.async=true;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script> <script>(function() {

    window.PinIt = window.PinIt || { loaded:false };

    if (window.PinIt.loaded) return;

    window.PinIt.loaded = true;

    function async_load(){

        var s = document.createElement("script");

        s.type = "text/javascript";

        s.async = true;

        s.src = "https://assets.pinterest.com/js/pinit.js";

        var x = document.getElementsByTagName("script")[0];

        x.parentNode.insertBefore(s, x);

    }

    if (window.attachEvent)

        window.attachEvent("onload", async_load);

    else

        window.addEventListener("load", async_load, false);

})();</script> <script>(function() {

    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;

    po.src = 'https://apis.google.com/js/plusone.js';

    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);

  })();</script> <div
id=fb-root></div> <script>(function(d, s, id) {

  var js, fjs = d.getElementsByTagName(s)[0];

  if (d.getElementById(id)) return;

  js = d.createElement(s); js.id = id;

  js.async = true;

  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";

  fjs.parentNode.insertBefore(js, fjs);

}(document, 'script', 'facebook-jssdk'));</script> <script src='https://cavaliersnation.com/wp-includes/js/comment-reply.min.js?ver=5.6.1' id=comment-reply-js></script> <script id=stickThis-js-extra>var sticky_anything_engage = {"element":".ad-728","topspace":"0","minscreenwidth":"0","maxscreenwidth":"999999","zindex":"1","legacymode":"","dynamicmode":"","debugmode":"","pushup":"","adminbar":"1"};</script> <script src='https://cavaliersnation.com/wp-content/plugins/sticky-menu-or-anything-on-scroll/assets/js/stickThis.js?ver=2.1.1' id=stickThis-js></script> <script src='https://cavaliersnation.com/wp-content/themes/gameday/js/jquery.flexslider.js?ver=5.6.1' id=flexslider-js></script> <script src='https://cavaliersnation.com/wp-content/themes/gameday/js/jquery.elastislide.js?ver=5.6.1' id=elastislide-js></script> <script src='https://cavaliersnation.com/wp-content/themes/gameday/js/scripts.js?ver=5.6.1' id=gameday-js></script> <script src='https://cavaliersnation.com/wp-content/themes/gameday/js/ticker.js?ver=5.6.1' id=ticker-js></script> <script src='https://cavaliersnation.com/wp-content/themes/gameday/js/respond.min.js?ver=5.6.1' id=respond-js></script> <script src='https://cavaliersnation.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id=imagesloaded-js></script> <script src='https://cavaliersnation.com/wp-content/themes/gameday/js/css3-mediaqueries.js?ver=5.6.1' id=queries-js></script> <script src='https://cavaliersnation.com/wp-content/themes/gameday/js/retina.js?ver=5.6.1' id=retina-js></script> <script src='https://cavaliersnation.com/wp-includes/js/wp-embed.min.js?ver=5.6.1' id=wp-embed-js></script> <script src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.6.1' async=async id=remote_sdk-js></script> <script id=yikes-easy-mc-ajax-js-extra>var yikes_mailchimp_ajax = {"ajax_url":"https:\/\/cavaliersnation.com\/wp-admin\/admin-ajax.php","page_data":"49947","interest_group_checkbox_error":"This field is required.","preloader_url":"https:\/\/cavaliersnation.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/ripple.svg","loading_dots":"https:\/\/cavaliersnation.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/bars.svg","ajax_security_nonce":"cab2efd29b","feedback_message_placement":"before"};</script> <script src='https://cavaliersnation.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/yikes-mc-ajax-forms.min.js?ver=6.7.0' id=yikes-easy-mc-ajax-js></script> <script id=form-submission-helpers-js-extra>var form_submission_helpers = {"ajax_url":"https:\/\/cavaliersnation.com\/wp-admin\/admin-ajax.php","preloader_url":"https:\/\/cavaliersnation.com\/wp-admin\/images\/wpspin_light.gif","countries_with_zip":{"US":"US","GB":"GB","CA":"CA","IE":"IE","CN":"CN","IN":"IN","AU":"AU","BR":"BR","MX":"MX","IT":"IT","NZ":"NZ","JP":"JP","FR":"FR","GR":"GR","DE":"DE","NL":"NL","PT":"PT","ES":"ES"},"page_data":"49947"};</script> <script src='https://cavaliersnation.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/form-submission-helpers.min.js?ver=6.7.0' id=form-submission-helpers-js></script> </body></html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Object Caching 128/160 objects using disk
Page Caching using disk: enhanced 

Served from: cavaliersnation.com @ 2021-02-16 11:42:57 by W3 Total Cache
-->