<!DOCTYPE html><html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"><head> <script src="https://us.connextra.com/dcs/tagController/tag/362820167f7c/homepage" async defer></script> <meta name="verifyownership" 
 content="8b17572d9adc3b6cbc654dc1d5d043e5"/><meta name="verifyownership" 
 content="16a1e10dad87b5c0fc759f5de4f6f60e"/> <script async src="//js-sec.indexww.com/ht/p/184031-43290852983293.js"></script>  <script>var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "6035223" });
  (function() {
    var s = document.createElement("script"), el =
document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb<https://sb/>" :
"http://b<http://b/>") +
".scorecardresearch.com/beacon.js<http://scorecardresearch.com/beacon.js>";
    el.parentNode.insertBefore(s, el);
  })();</script> <noscript> <img src="https://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" /> </noscript>  <script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script> <meta name="google-site-verification" content="KStSRn6409ttzCYidg-n9MD7blSVvoj25HKqQg3hg5Y" /><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" /><meta property="og:image" content="https://cavaliersnation.com/wp-content/uploads/2021/07/USATSI_15395702-615x400.jpg" /><link media="all" href="https://cavaliersnation.com/wp-content/cache/autoptimize/css/autoptimize_e0e0357f7ae0776b81a827b0631f1942.css" rel="stylesheet" /><title>Report: Teams asking Cavs for Larry Nance Jr. or 1st-round pick in general trade conversations | Cavaliers Nation</title> <!--[if IE]><link rel="stylesheet" type="text/css" href="https://cavaliersnation.com/wp-content/themes/gameday/css/iecss.css" /> <![endif]--><link rel="shortcut icon" href="https://cavaliersnation.com/wp-content/uploads/2017/10/cavaliersnationlogo-1.jpg" /><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://cavaliersnation.com/feed/" /><link rel="alternate" type="text/xml" title="RSS .92" href="https://cavaliersnation.com/feed/rss/" /><link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://cavaliersnation.com/feed/atom/" /><link rel="pingback" href="https://cavaliersnation.com/xmlrpc.php" /> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-56943371-1', 'auto');
  ga('send', 'pageview');</script> <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <script>(function(w, d) {
	w.adthrive = w.adthrive || {};
	w.adthrive.cmd = w.adthrive.cmd || [];
	w.adthrive.plugin = 'adthrive-ads-1.0.50';
	w.adthrive.host = 'ads.adthrive.com';

	var s = d.createElement('script');
	s.async = true;
	s.referrerpolicy='no-referrer-when-downgrade';
	s.src = 'https://' + w.adthrive.host + '/sites/5b48a37c9be6984315eaf2ce/ads.min.js?referrer=' + w.encodeURIComponent(w.location.href) + '&cb=' + (Math.floor(Math.random() * 100) + 1);
	var n = d.getElementsByTagName('script')[0];
	n.parentNode.insertBefore(s, n);
})(window, document);</script> <meta name="description" content="According to a recent report, opposing teams are asking the Cleveland Cavaliers for Larry Nance Jr. or a first-round pick in trade discussions as the Cavs look to add some shooting to their roster." /><link rel="canonical" href="https://cavaliersnation.com/2021/08/04/report-teams-asking-cavs-for-larry-nance-jr-or-1st-round-pick-in-general-trade-conversations/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Report: Teams asking Cavs for Larry Nance Jr. or 1st-round pick in general trade conversations" /><meta property="og:description" content="According to a recent report, opposing teams are asking the Cleveland Cavaliers for Larry Nance Jr. or a first-round pick in trade discussions as the Cavs look to add some shooting to their roster." /><meta property="og:url" content="https://cavaliersnation.com/2021/08/04/report-teams-asking-cavs-for-larry-nance-jr-or-1st-round-pick-in-general-trade-conversations/" /><meta property="og:site_name" content="Cavaliers Nation" /><meta property="article:publisher" content="https://www.facebook.com/CavaliersNation/" /><meta property="article:published_time" content="2021-08-04T15:01:46+00:00" /><meta property="article:modified_time" content="2021-08-04T19:50:44+00:00" /><meta property="og:image" content="https://cavaliersnation.com/wp-content/uploads/2021/07/USATSI_15395702-scaled-e1627427322380.jpg" /><meta property="og:image:width" content="1300" /><meta property="og:image:height" content="736" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@WeAreCavsNation" /><meta name="twitter:site" content="@WeAreCavsNation" /> <script type="application/ld+json" class="yoast-schema-graph">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</script> <link rel="amphtml" href="https://cavaliersnation.com/2021/08/04/report-teams-asking-cavs-for-larry-nance-jr-or-1st-round-pick-in-general-trade-conversations/amp/" /><meta name="generator" content="AMP for WP 1.0.77.17"/><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Cavaliers Nation &raquo; Feed" href="https://cavaliersnation.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Cavaliers Nation &raquo; Comments Feed" href="https://cavaliersnation.com/comments/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cavaliersnation.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='googlefonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans+Condensed%3A300%2C700%7COpen+Sans%3A400%2C700%7COswald%3A300%2C400%2C700&#038;subset=latin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese&#038;ver=5.8' type='text/css' media='all' /> <script type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/sticky-menu-or-anything-on-scroll/assets/js/jq-sticky-anything.min.js?ver=2.1.1' id='stickyAnythingLib-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/wp-retina-2x/app/picturefill.min.js?ver=1625584105' id='wr2x-picturefill-js-js'></script> <link rel="https://api.w.org/" href="https://cavaliersnation.com/wp-json/" /><link rel="alternate" type="application/json" href="https://cavaliersnation.com/wp-json/wp/v2/posts/51964" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://cavaliersnation.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cavaliersnation.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.8" /><link rel='shortlink' href='https://cavaliersnation.com/?p=51964' /><link rel="alternate" type="application/json+oembed" href="https://cavaliersnation.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcavaliersnation.com%2F2021%2F08%2F04%2Freport-teams-asking-cavs-for-larry-nance-jr-or-1st-round-pick-in-general-trade-conversations%2F" /><link rel="alternate" type="text/xml+oembed" href="https://cavaliersnation.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcavaliersnation.com%2F2021%2F08%2F04%2Freport-teams-asking-cavs-for-larry-nance-jr-or-1st-round-pick-in-general-trade-conversations%2F&#038;format=xml" /><meta name="onesignal" content="wordpress-plugin"/> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://cavaliersnation.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'b691d3c3-97cc-4969-a5c2-2d07e83c1aba';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://cavaliersnation.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.28671d66-3da8-4a50-bcc4-1b29e015670b";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script> <link rel="icon" href="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" sizes="32x32" /><link rel="icon" href="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" sizes="192x192" /><link rel="apple-touch-icon" href="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" /><meta name="msapplication-TileImage" content="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" /></head><body data-rsssl=1 class="post-template-default single single-post postid-51964 single-format-standard custom-background"><div id="site"><div id="wrapper"><div id="nav-main-wrapper"><div id="nav-main"><div id="nav-main-left"><div id="nav-logo"> <a href="https://cavaliersnation.com"><img src="https://cavaliersnation.com/wp-content/uploads/2019/05/cnwebsite12.png" alt="Cavaliers Nation" /></a></div><ul class="nav-main"><div class="menu-home-container"><ul id="menu-home" class="menu"><li id="menu-item-75" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75"><a href="https://cavaliersnation.com/">Home</a></li><li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-41"><a title="Categories">Categories</a><ul class="sub-menu"><li id="menu-item-81" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a href="https://cavaliersnation.com/category/game-reports/">Game Reports</a></li><li id="menu-item-82" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82"><a href="https://cavaliersnation.com/category/editorials/">Editorials</a></li><li id="menu-item-84" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84"><a href="https://cavaliersnation.com/category/team-news/">Team News</a></li><li id="menu-item-85" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-85"><a href="https://cavaliersnation.com/category/rumors/">Rumors</a></li><li id="menu-item-83" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83"><a href="https://cavaliersnation.com/category/media/">Media</a></li><li id="menu-item-86" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-86"><a href="https://cavaliersnation.com/category/videos/">Videos</a></li></ul></li><li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://cavaliersnation.com/schedule/">Schedule</a></li><li id="menu-item-48" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48"><a href="https://cavaliersnation.com/contributors/">Contributors</a></li><li id="menu-item-40" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a href="https://cavaliersnation.com/about/">About</a></li><li id="menu-item-9117" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9117"><a href="https://cavaliersnation.com/career/">Career</a></li></ul></div></ul><div id="nav-mobi"><div class="menu-home-container"><select><option value="#">Menu</option><option value="https://cavaliersnation.com/">Home</option><option value="">Categories<option value="https://cavaliersnation.com/category/game-reports/">-Game Reports</option><option value="https://cavaliersnation.com/category/editorials/">-Editorials</option><option value="https://cavaliersnation.com/category/team-news/">-Team News</option><option value="https://cavaliersnation.com/category/rumors/">-Rumors</option><option value="https://cavaliersnation.com/category/media/">-Media</option><option value="https://cavaliersnation.com/category/videos/">-Videos</option></option><option value="https://cavaliersnation.com/schedule/">Schedule</option><option value="https://cavaliersnation.com/contributors/">Contributors</option><option value="https://cavaliersnation.com/about/">About</option><option value="https://cavaliersnation.com/career/">Career</option> </select></div></div></div><div id="nav-search"><form method="get" id="searchform" action="https://cavaliersnation.com/"> <input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' /> <input type="hidden" id="search-button" /></form></div></div></div><div id="main-wrapper"><div id="top-spacer"></div><div id="content-outer"><div id="main-top"><div id="ticker"> <span class="ticker-heading">Don't Miss</span><ul class="ticker-list"><li><a href="https://cavaliersnation.com/2021/08/04/report-cavs-among-teams-that-have-expressed-interest-in-signing-veteran-sharpshooter/">Report: Cavs among teams that have expressed interest in signing veteran sharpshooter</a></li><li><a href="https://cavaliersnation.com/2021/08/04/report-teams-asking-cavs-for-larry-nance-jr-or-1st-round-pick-in-general-trade-conversations/">Report: Teams asking Cavs for Larry Nance Jr. or 1st-round pick in general trade conversations</a></li><li><a href="https://cavaliersnation.com/2021/08/03/report-cavs-could-add-german-national-team-contributor-in-free-agency/">Report: Cavs could add German national team contributor in free agency</a></li><li><a href="https://cavaliersnation.com/2021/08/03/video-kevin-durant-raves-about-cavs-newcomer-ricky-rubio-after-he-explodes-for-38-points-against-team-usa/">Kevin Durant raves about Cavs newcomer Ricky Rubio after he drops 38 points against Team USA</a></li><li><a href="https://cavaliersnation.com/2021/08/02/report-cavs-prepared-to-offer-jarrett-allen-5-year-100-million-deal/">Report: Cavs prepared to offer Jarrett Allen 5-year, $100 million deal</a></li><li><a href="https://cavaliersnation.com/2021/08/02/larry-nance-jr-takes-a-shot-at-reporters-with-start-of-free-agency-looming/">Larry Nance Jr. takes a shot at reporters with start of free agency looming</a></li><li><a href="https://cavaliersnation.com/2021/08/01/report-cavs-no-longer-expected-to-pursue-alex-caruso-or-t-j-mcconnell-after-trade-for-ricky-rubio/">Report: Cavs no longer expected to pursue Alex Caruso or T.J. McConnell after trade for Ricky Rubio</a></li><li><a href="https://cavaliersnation.com/2021/08/01/report-cavs-showing-interest-in-doug-mcdermott-and-alec-burks/">Report: Cavs showing interest in Doug McDermott and Alec Burks</a></li><li><a href="https://cavaliersnation.com/2021/08/01/report-cavs-decline-to-extend-qualifying-offer-to-isaiah-hartenstein/">Report: Cavs decline to extend qualifying offer to Isaiah Hartenstein</a></li><li><a href="https://cavaliersnation.com/2021/08/01/report-cavs-pegged-as-potential-landing-spot-for-bucks-sharpshooter/">Report: Cavs pegged as potential landing spot for Bucks sharpshooter</a></li></ul></div><div id="content-social"><ul><li><a href="https://www.facebook.com/cavaliersnation" alt="Facebook" class="fb-but" target="_blank"></a></li><li><a href="https://www.twitter.com/wearecavsnation" alt="Twitter" class="twitter-but" target="_blank"></a></li><li><a href="https://www.instagram.com/cavaliersnationdotcom" alt="Instagram" class="instagram-but" target="_blank"></a></li><li><a href="https://cavaliersnation.com/feed/rss/" alt="RSS Feed" class="rss-but"></a></li></ul></div></div><div id="content-inner"><div id="main"><div class="breadcrumb"><div id="crumbs"><a href="https://cavaliersnation.com">Home</a> / <a href="https://cavaliersnation.com/category/rumors/">Rumors</a> / <span class="current">Report: Teams asking Cavs for Larry Nance Jr. or 1st-round pick in general trade conversations</span></div></div><h1 class="headline">Report: Teams asking Cavs for Larry Nance Jr. or 1st-round pick in general trade conversations</h1><div id="post-info-wrapper"><ul class="post-info"><li><div class="post-author">By <a href="https://cavaliersnation.com/author/sam-leweck/" title="Posts by Sam Leweck" rel="author">Sam Leweck</a></div></li><li><ul class="post-social"><li><div class="fb-like" data-send="false" data-layout="button_count" data-width="90" data-show-faces="false"></div></li><li> <a href="https://twitter.com/share" class="twitter-share-button" data-lang="en" data-count="horizontal">Tweet</a></li><li> <g:plusone size="medium" annotation="bubble" width="120"></g:plusone></li><li> <a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fcavaliersnation.com%2F2021%2F08%2F04%2Freport-teams-asking-cavs-for-larry-nance-jr-or-1st-round-pick-in-general-trade-conversations%2F&media=https://cavaliersnation.com/wp-content/uploads/2021/07/USATSI_15395702-scaled-e1627427322380.jpg&description=Report: Teams asking Cavs for Larry Nance Jr. or 1st-round pick in general trade conversations" class="pin-it-button" count-layout="horizontal">Pin It</a></li></ul></li><li><div class="post-update">Updated: August 4, 2021</div></li></ul></div><div id="post-area" class="post-51964 post type-post status-publish format-standard has-post-thumbnail category-rumors tag-cleveland-cavaliers tag-evan-mobley tag-featured tag-jarrett-allen tag-larry-nance-jr tag-news-ticker"><div class="post-image"> <img width="1300" height="736" src="https://cavaliersnation.com/wp-content/uploads/2021/07/USATSI_15395702-scaled-e1627427322380.jpg" class="attachment-post-thumb size-post-thumb wp-post-image" alt="Larry Nance Jr. Cavs" loading="lazy" /></div><div id="content-area"><p>According to a recent report, opposing teams are asking the <a title="Cleveland Cavaliers" href="https://cavaliersnation.com/tag/cleveland-cavaliers/">Cleveland Cavaliers</a> for <a title="Larry Nance Jr" href="https://cavaliersnation.com/tag/larry-nance-jr/">Larry Nance Jr</a>. or a first-round pick in trade discussions.</p><blockquote><p>&#8220;Sources tell cleveland.com the initial ask from opposing teams in general trade conversations is either <a title="Larry Nance Jr" href="https://cavaliersnation.com/tag/larry-nance-jr/">Larry Nance Jr</a>. or Cleveland’s 2022 first-round pick (with protections on it, of course),&#8221; <a href="https://www.cleveland.com/cavs/2021/08/cleveland-cavaliers-still-on-the-hunt-for-more-shooting-can-they-fill-the-void-in-free-agency.html">wrote</a> Chris Fedor.</p></blockquote><p>Nance, who is 28 years of age, seems to be getting <a href="https://cavaliersnation.com/2021/08/02/larry-nance-jr-takes-a-shot-at-reporters-with-start-of-free-agency-looming/">fed up</a> with the fact that his name is popping up in trade rumors, but that&#8217;s not going to make the rumors go away. The idea of the Cavs trading Nance away doesn&#8217;t seem too far-fetched.</p><p>In the 2020-21 season, he averaged 9.3 points, 6.7 rebounds and 3.1 assists per game while hitting 47.1 percent of his shots from the field and 36.0 percent of his shots from deep.</p><p>With the addition of Evan Mobley and the re-signing of <a title="Jarrett Allen" href="https://cavaliersnation.com/tag/jarrett-allen/">Jarrett Allen</a>, Cleveland figures to have a crowded frontcourt in the 2021-22 season and beyond. Nance would likely see decreased playing time with the team.</p><p>Funnily, if the Cavs were to trade Nance away in favor of some shooting, they&#8217;d be losing a pretty good shooter by big man standards. He is a career 33.3 percent shooter from beyond the arc.</p><p>Only time will tell which direction the organization decides to go.</p><div id="contentad123909"></div> <script type="text/javascript">(function(d) {
        var params =
        {
            id: "e576b5e3-63b7-43fe-8588-310c094931f8",
            d:  "Y2F2YWxpZXJzbmF0aW9uLmNvbQ==",
            wid: "123909",
            cb: (new Date()).getTime()
        };

        var qs=[];
        for(var key in params) qs.push(key+'='+encodeURIComponent(params[key]));
        var s = d.createElement('script');s.type='text/javascript';s.async=true;
        var p = 'https:' == document.location.protocol ? 'https' : 'http';
        s.src = p + "://api.content-ad.net/Scripts/widget2.aspx?" + qs.join('&');
        d.getElementById("contentad123909").appendChild(s);
    })(document);</script> <div class="post-tags"> <a href="https://cavaliersnation.com/tag/cleveland-cavaliers/" rel="tag">cleveland cavaliers</a><a href="https://cavaliersnation.com/tag/evan-mobley/" rel="tag">Evan Mobley</a><a href="https://cavaliersnation.com/tag/featured/" rel="tag">featured</a><a href="https://cavaliersnation.com/tag/jarrett-allen/" rel="tag">jarrett allen</a><a href="https://cavaliersnation.com/tag/larry-nance-jr/" rel="tag">larry nance jr.</a><a href="https://cavaliersnation.com/tag/news-ticker/" rel="tag">news ticker</a></div><div class="prev-next-wrapper"><div class="prev-post"> &larr; Previous Story <a href="https://cavaliersnation.com/2021/08/03/report-cavs-could-add-german-national-team-contributor-in-free-agency/" rel="prev">Report: Cavs could add German national team contributor in free agency</a></div><div class="next-post"> Next Story &rarr; <a href="https://cavaliersnation.com/2021/08/04/report-cavs-among-teams-that-have-expressed-interest-in-signing-veteran-sharpshooter/" rel="next">Report: Cavs among teams that have expressed interest in signing veteran sharpshooter</a></div></div></div><div id="related-posts"><h3>Related Posts</h3><ul><li><div class="related-image"> <a href="https://cavaliersnation.com/2021/08/04/report-cavs-among-teams-that-have-expressed-interest-in-signing-veteran-sharpshooter/" rel="bookmark" title="Report: Cavs among teams that have expressed interest in signing veteran sharpshooter"><img width="300" height="195" src="https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16196461_168386351_lowres-300x195.jpg" class="attachment-large-thumb size-large-thumb wp-post-image" alt="Danny Green 76ers" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16196461_168386351_lowres-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16196461_168386351_lowres-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16196461_168386351_lowres-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="related-text"> <a href="https://cavaliersnation.com/2021/08/04/report-cavs-among-teams-that-have-expressed-interest-in-signing-veteran-sharpshooter/" class="main-headline">Report: Cavs among teams that have expressed interest in signing veteran sharpshooter</a></div></li><li><div class="related-image"> <a href="https://cavaliersnation.com/2021/08/03/report-cavs-could-add-german-national-team-contributor-in-free-agency/" rel="bookmark" title="Report: Cavs could add German national team contributor in free agency"><img width="300" height="195" src="https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16500186_168386351_lowres-300x195.jpg" class="attachment-large-thumb size-large-thumb wp-post-image" alt="Isaac Bonga" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16500186_168386351_lowres-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16500186_168386351_lowres-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16500186_168386351_lowres-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="related-text"> <a href="https://cavaliersnation.com/2021/08/03/report-cavs-could-add-german-national-team-contributor-in-free-agency/" class="main-headline">Report: Cavs could add German national team contributor in free agency</a></div></li><li><div class="related-image"> <a href="https://cavaliersnation.com/2021/08/03/video-kevin-durant-raves-about-cavs-newcomer-ricky-rubio-after-he-explodes-for-38-points-against-team-usa/" rel="bookmark" title="Kevin Durant raves about Cavs newcomer Ricky Rubio after he drops 38 points against Team USA"><img width="300" height="195" src="https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16500750_168386351_lowres-scaled-e1628002050750-300x195.jpg" class="attachment-large-thumb size-large-thumb wp-post-image" alt="Ricky Rubio and Zach LaVine" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16500750_168386351_lowres-scaled-e1628002050750-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16500750_168386351_lowres-scaled-e1628002050750-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16500750_168386351_lowres-scaled-e1628002050750-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="related-text"> <a href="https://cavaliersnation.com/2021/08/03/video-kevin-durant-raves-about-cavs-newcomer-ricky-rubio-after-he-explodes-for-38-points-against-team-usa/" class="main-headline">Kevin Durant raves about Cavs newcomer Ricky Rubio after he drops 38 points against Team USA</a></div></li></ul></div><div id="comments"><p> You must be logged in to post a comment <a href="https://cavaliersnation.com/wp-login.php?redirect_to=https%3A%2F%2Fcavaliersnation.com%2F2021%2F08%2F04%2Freport-teams-asking-cavs-for-larry-nance-jr-or-1st-round-pick-in-general-trade-conversations%2F"> Login </a></p></div></div><div id="sidebar-wrapper"><div class="widget-container"><div class="widget-inner"><h4 class="widget-header">About Sam Leweck</h4><div class="author-image"> <img class="avatar avatar-60 photo" width="64" height="64" src="https://cavaliersnation.com/wp-content/uploads/2019/10/13509068_1021374311279727_8222685363074163976_n-7-300x300.jpg"/></div><p class="author-box gd-widgets">Sam is a passionate NBA fan who has still in awe of the 2016 NBA Finals. He thinks of the Cleveland Cavaliers’ 2016 title as one of the most meaningful championships of all time. Sam is a sports writer with several years of experience covering the NBA, NFL and MLB.</p></div></div><div class="widget-container"> <span class="blog-cat-title">Recent</span><div class="widget-img"> <a href="https://cavaliersnation.com/2021/08/04/report-cavs-among-teams-that-have-expressed-interest-in-signing-veteran-sharpshooter/" rel="bookmark" title="Report: Cavs among teams that have expressed interest in signing veteran sharpshooter"><img width="300" height="195" src="https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16196461_168386351_lowres-300x195.jpg" class="attachment-large-thumb size-large-thumb wp-post-image" alt="Danny Green 76ers" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16196461_168386351_lowres-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16196461_168386351_lowres-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2021/08/USATSI_16196461_168386351_lowres-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="widget-inner"><h3 class="home-title1"><a href="https://cavaliersnation.com/2021/08/04/report-cavs-among-teams-that-have-expressed-interest-in-signing-veteran-sharpshooter/" rel="bookmark">Report: Cavs among teams that have expressed interest in signing veteran sharpshooter</a></h3><p class="gd-widgets">According to a report, the Cleveland Cavaliers are among the teams interested in signing sharpshooter Danny Green. Multiple teams...</p><ul class="home-links1"><li><a href="https://cavaliersnation.com/2021/08/04/report-teams-asking-cavs-for-larry-nance-jr-or-1st-round-pick-in-general-trade-conversations/" rel="bookmark">Report: Teams asking Cavs for Larry Nance Jr. or 1st-round pick in general trade conversations</a></li><li><a href="https://cavaliersnation.com/2021/08/03/report-cavs-could-add-german-national-team-contributor-in-free-agency/" rel="bookmark">Report: Cavs could add German national team contributor in free agency</a></li><li><a href="https://cavaliersnation.com/2021/08/02/report-cavs-prepared-to-offer-jarrett-allen-5-year-100-million-deal/" rel="bookmark">Report: Cavs prepared to offer Jarrett Allen 5-year, $100 million deal</a></li><li><a href="https://cavaliersnation.com/2021/08/01/report-cavs-no-longer-expected-to-pursue-alex-caruso-or-t-j-mcconnell-after-trade-for-ricky-rubio/" rel="bookmark">Report: Cavs no longer expected to pursue Alex Caruso or T.J. McConnell after trade for Ricky Rubio</a></li></ul></div></div><div class="widget-container"><div id="yikes_easy_mc_widget-5" class="widget-inner widget_yikes_easy_mc_widget"><h4 class="widget-header">Subscribe to get your daily Cleveland Cavaliers news, rumors, and videos!</h4><section id="yikes-mailchimp-container-1" class="yikes-mailchimp-container yikes-mailchimp-container-1 "><form id="cavaliers-nation-1" class="yikes-easy-mc-form yikes-easy-mc-form-1  " method="POST" data-attr-form-id="1"> <label for="yikes-easy-mc-form-1-EMAIL"  class="EMAIL-label yikes-mailchimp-field-required "> <span class="EMAIL-label"> Email Address </span> <input id="yikes-easy-mc-form-1-EMAIL"  name="EMAIL"  placeholder=""  class="yikes-easy-mc-email "  required="required" type="email"  value=""> </label> <label for="yikes-easy-mc-form-1-FNAME"  class="FNAME-label "> <span class="FNAME-label"> First Name </span> <input id="yikes-easy-mc-form-1-FNAME"  name="FNAME"  placeholder=""  class="yikes-easy-mc-text "   type="text"  value=""> </label> <label for="yikes-easy-mc-form-1-LNAME"  class="LNAME-label "> <span class="LNAME-label"> Last Name </span> <input id="yikes-easy-mc-form-1-LNAME"  name="LNAME"  placeholder=""  class="yikes-easy-mc-text "   type="text"  value=""> </label> <input type="hidden" name="yikes-mailchimp-honeypot" id="yikes-mailchimp-honeypot-1" value=""> <input type="hidden" name="yikes-mailchimp-associated-list-id" id="yikes-mailchimp-associated-list-id-1" value="fd937dddf1"> <input type="hidden" name="yikes-mailchimp-submitted-form" id="yikes-mailchimp-submitted-form-1" value="1"> <button type="submit" class="yikes-easy-mc-submit-button yikes-easy-mc-submit-button-1 btn btn-primary "> <span class="yikes-mailchimp-submit-button-span-text">Submit</span></button> <input type="hidden" id="yikes_easy_mc_new_subscriber_1" name="yikes_easy_mc_new_subscriber" value="794313d46e"> <input type="hidden" name="_wp_http_referer" value="/2021/08/04/report-teams-asking-cavs-for-larry-nance-jr-or-1st-round-pick-in-general-trade-conversations/" /></form></section></div></div></div></div></div></div></div></div><div id="footer-wrapper"><div id="footer"><div id="footer-nav"><div class="menu-home-container"><ul id="menu-home-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75"><a href="https://cavaliersnation.com/">Home</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-41"><a title="Categories">Categories</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a href="https://cavaliersnation.com/category/game-reports/">Game Reports</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82"><a href="https://cavaliersnation.com/category/editorials/">Editorials</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84"><a href="https://cavaliersnation.com/category/team-news/">Team News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-85"><a href="https://cavaliersnation.com/category/rumors/">Rumors</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83"><a href="https://cavaliersnation.com/category/media/">Media</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-86"><a href="https://cavaliersnation.com/category/videos/">Videos</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://cavaliersnation.com/schedule/">Schedule</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48"><a href="https://cavaliersnation.com/contributors/">Contributors</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a href="https://cavaliersnation.com/about/">About</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9117"><a href="https://cavaliersnation.com/career/">Career</a></li></ul></div></div><div id="copyright"><p>Copyright © 2014 Cavaliers Nation, All Rights Reserved. Property of <a href="https://ahnfiredigital.com">Ahn Fire Digital</a>. Partner with USA Today Sports Digital
Properties. <a href="https://cavaliersnation.com/privacy-policy">Privacy Policy</a></p></div></div></div></div> <script type='text/javascript'>//

jQuery(document).ready(function($){

  $(window).load(function(){

    $('.flexslider').flexslider({

	animation: 'fade',

	slideshowSpeed: 8000

    	});

  	});



$('.carousel').elastislide({

	imageW 	: 80,

	minItems	: 2,

	margin		: 3

});

});

//</script> <script type="text/javascript">//

!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.async=true;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");

//</script> <script type="text/javascript">//

(function() {

    window.PinIt = window.PinIt || { loaded:false };

    if (window.PinIt.loaded) return;

    window.PinIt.loaded = true;

    function async_load(){

        var s = document.createElement("script");

        s.type = "text/javascript";

        s.async = true;

        s.src = "https://assets.pinterest.com/js/pinit.js";

        var x = document.getElementsByTagName("script")[0];

        x.parentNode.insertBefore(s, x);

    }

    if (window.attachEvent)

        window.attachEvent("onload", async_load);

    else

        window.addEventListener("load", async_load, false);

})();

//</script> <script type="text/javascript">//

  (function() {

    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;

    po.src = 'https://apis.google.com/js/plusone.js';

    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);

  })();

//</script> <div id="fb-root"></div> <script type="text/javascript">//

(function(d, s, id) {

  var js, fjs = d.getElementsByTagName(s)[0];

  if (d.getElementById(id)) return;

  js = d.createElement(s); js.id = id;

  js.async = true;

  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";

  fjs.parentNode.insertBefore(js, fjs);

}(document, 'script', 'facebook-jssdk'));

//</script> <script type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/comment-reply.min.js?ver=5.8' id='comment-reply-js'></script> <script type='text/javascript' id='stickThis-js-extra'>var sticky_anything_engage = {"element":".ad-728","topspace":"0","minscreenwidth":"0","maxscreenwidth":"999999","zindex":"1","legacymode":"","dynamicmode":"","debugmode":"","pushup":"","adminbar":"1"};</script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/sticky-menu-or-anything-on-scroll/assets/js/stickThis.js?ver=2.1.1' id='stickThis-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/jquery.flexslider.js?ver=5.8' id='flexslider-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/jquery.elastislide.js?ver=5.8' id='elastislide-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/scripts.js?ver=5.8' id='gameday-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/ticker.js?ver=5.8' id='ticker-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/respond.min.js?ver=5.8' id='respond-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/css3-mediaqueries.js?ver=5.8' id='queries-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/retina.js?ver=5.8' id='retina-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/wp-embed.min.js?ver=5.8' id='wp-embed-js'></script> <script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.8' async='async' id='remote_sdk-js'></script> <script type='text/javascript' id='yikes-easy-mc-ajax-js-extra'>var yikes_mailchimp_ajax = {"ajax_url":"https:\/\/cavaliersnation.com\/wp-admin\/admin-ajax.php","page_data":"51933","interest_group_checkbox_error":"This field is required.","preloader_url":"https:\/\/cavaliersnation.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/ripple.svg","loading_dots":"https:\/\/cavaliersnation.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/bars.svg","ajax_security_nonce":"9f7b585509","feedback_message_placement":"before"};</script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/yikes-mc-ajax-forms.min.js?ver=6.8.4' id='yikes-easy-mc-ajax-js'></script> <script type='text/javascript' id='form-submission-helpers-js-extra'>var form_submission_helpers = {"ajax_url":"https:\/\/cavaliersnation.com\/wp-admin\/admin-ajax.php","preloader_url":"https:\/\/cavaliersnation.com\/wp-admin\/images\/wpspin_light.gif","countries_with_zip":{"US":"US","GB":"GB","CA":"CA","IE":"IE","CN":"CN","IN":"IN","AU":"AU","BR":"BR","MX":"MX","IT":"IT","NZ":"NZ","JP":"JP","FR":"FR","GR":"GR","DE":"DE","NL":"NL","PT":"PT","ES":"ES"},"page_data":"51933"};</script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/form-submission-helpers.min.js?ver=6.8.4' id='form-submission-helpers-js'></script> </body></html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Object Caching 127/153 objects using disk
Page Caching using disk: enhanced 

Served from: cavaliersnation.com @ 2021-08-04 14:50:51 by W3 Total Cache
-->