<!DOCTYPE html><html
xmlns=http://www.w3.org/1999/xhtml lang=en-US><head> <script src="https://us.connextra.com/dcs/tagController/tag/362820167f7c/homepage" async defer></script> <meta
name="verifyownership"
content="8b17572d9adc3b6cbc654dc1d5d043e5"><meta
name="verifyownership"
content="16a1e10dad87b5c0fc759f5de4f6f60e"> <script async src=//js-sec.indexww.com/ht/p/184031-43290852983293.js></script> <script type=''text/javascript'' src=''http://mtrx.go.sonobi.com/morpheus.usatoday.1587.js''></script> <script type=''text/javascript" src="//usatodaysports-d.openx.net/w/1.0/jstag?nc=7103-USA_RON"></script>  <script>var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "6035223" });
  (function() {
    var s = document.createElement("script"), el =
document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb<https://sb/>" :
"http://b<http://b/>") +
".scorecardresearch.com/beacon.js<http://scorecardresearch.com/beacon.js>";
    el.parentNode.insertBefore(s, el);
  })();</script> <noscript>
<img
src="https://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1">
</noscript>
 <script async custom-element=amp-ad src=https://cdn.ampproject.org/v0/amp-ad-0.1.js></script> <meta
name="google-site-verification" content="KStSRn6409ttzCYidg-n9MD7blSVvoj25HKqQg3hg5Y"><meta
http-equiv="Content-Type" content="text/html; charset=UTF-8"><meta
name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1"><meta
property="og:image" content="https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_14120992_168386351_lowres-615x400.jpg"><link
media=all href=https://cavaliersnation.com/wp-content/cache/autoptimize/css/autoptimize_f01b2e86798ecc5933f7e7ff34aebfa3.css rel=stylesheet><title>Andre Drummond has hilarious reaction to finding out Cavs traded for another center in Jarrett Allen | Cavaliers Nation</title><!--[if IE]><link
rel=stylesheet type=text/css href=https://cavaliersnation.com/wp-content/themes/gameday/css/iecss.css><![endif]--><link
rel="shortcut icon" href=https://cavaliersnation.com/wp-content/uploads/2017/10/cavaliersnationlogo-1.jpg><link
rel=alternate type=application/rss+xml title="RSS 2.0" href=https://cavaliersnation.com/feed/ ><link
rel=alternate type=text/xml title="RSS .92" href=https://cavaliersnation.com/feed/rss/ ><link
rel=alternate type=application/atom+xml title="Atom 0.3" href=https://cavaliersnation.com/feed/atom/ ><link
rel=pingback href=https://cavaliersnation.com/xmlrpc.php> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-56943371-1', 'auto');
  ga('send', 'pageview');</script> <script>(function(w, d) {
	w.adthrive = w.adthrive || {};
	w.adthrive.cmd = w.adthrive.cmd || [];
	w.adthrive.plugin = 'adthrive-ads-1.0.41';
	w.adthrive.host = 'ads.adthrive.com';

	var s = d.createElement('script');
	s.async = true;
	s.referrerpolicy='no-referrer-when-downgrade';
	s.src = 'https://' + w.adthrive.host + '/sites/5b48a37c9be6984315eaf2ce/ads.min.js?referrer=' + w.encodeURIComponent(w.location.href);
	var n = d.getElementsByTagName('script')[0];
	n.parentNode.insertBefore(s, n);
})(window, document);</script> <meta
name="description" content="Another blockbuster trade in the NBA went down on Wednesday with the Brooklyn Nets acquiring superstar James Harden from the Houston Rockets. The Cleveland Cavaliers also got involved in the action with a deal of their own."><meta
name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><link
rel=canonical href=https://cavaliersnation.com/2021/01/13/andre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen/ ><meta
property="og:locale" content="en_US"><meta
property="og:type" content="article"><meta
property="og:title" content="Andre Drummond Has Hilarious Reaction to Finding Out Cavs Traded for Another Center in Jarrett Allen"><meta
property="og:description" content="Another blockbuster trade in the NBA went down on Wednesday with the Brooklyn Nets acquiring superstar James Harden from the Houston Rockets. The Cleveland Cavaliers also got involved in the action with a deal of their own."><meta
property="og:url" content="https://cavaliersnation.com/2021/01/13/andre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen/"><meta
property="og:site_name" content="Cavaliers Nation"><meta
property="article:publisher" content="https://www.facebook.com/CavaliersNation/"><meta
property="article:published_time" content="2021-01-14T00:46:29+00:00"><meta
property="article:modified_time" content="2021-01-14T00:47:08+00:00"><meta
property="og:image" content="https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_14120992_168386351_lowres-e1604858495964.jpg"><meta
property="og:image:width" content="1800"><meta
property="og:image:height" content="1200"><meta
name="twitter:card" content="summary_large_image"><meta
name="twitter:creator" content="@WeAreCavsNation"><meta
name="twitter:site" content="@WeAreCavsNation"> <script type=application/ld+json class=yoast-schema-graph>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://cavaliersnation.com/#organization","name":"Cavaliers Nation","url":"https://cavaliersnation.com/","sameAs":["https://www.facebook.com/CavaliersNation/","https://www.instagram.com/cavaliersnationdotcom/","https://twitter.com/WeAreCavsNation"],"logo":{"@type":"ImageObject","@id":"https://cavaliersnation.com/#logo","inLanguage":"en-US","url":"https://cavaliersnation.com/wp-content/uploads/2018/08/cn-logo.jpg","width":567,"height":567,"caption":"Cavaliers Nation"},"image":{"@id":"https://cavaliersnation.com/#logo"}},{"@type":"WebSite","@id":"https://cavaliersnation.com/#website","url":"https://cavaliersnation.com/","name":"Cavaliers Nation","description":"Cavs News and Rumors 24/7","publisher":{"@id":"https://cavaliersnation.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://cavaliersnation.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://cavaliersnation.com/2021/01/13/andre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen/#primaryimage","inLanguage":"en-US","url":"https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_14120992_168386351_lowres-e1604858495964.jpg","width":1800,"height":1200,"caption":"Ken Blaze-USA TODAY Sports"},{"@type":"WebPage","@id":"https://cavaliersnation.com/2021/01/13/andre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen/#webpage","url":"https://cavaliersnation.com/2021/01/13/andre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen/","name":"Andre Drummond has hilarious reaction to finding out Cavs traded for another center in Jarrett Allen | Cavaliers Nation","isPartOf":{"@id":"https://cavaliersnation.com/#website"},"primaryImageOfPage":{"@id":"https://cavaliersnation.com/2021/01/13/andre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen/#primaryimage"},"datePublished":"2021-01-14T00:46:29+00:00","dateModified":"2021-01-14T00:47:08+00:00","description":"Another blockbuster trade in the NBA went down on Wednesday with the Brooklyn Nets acquiring superstar James Harden from the Houston Rockets. The Cleveland Cavaliers also got involved in the action with a deal of their own.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://cavaliersnation.com/2021/01/13/andre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen/"]}]},{"@type":["Article","NewsArticle"],"@id":"https://cavaliersnation.com/2021/01/13/andre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen/#article","isPartOf":{"@id":"https://cavaliersnation.com/2021/01/13/andre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen/#webpage"},"author":{"@id":"https://cavaliersnation.com/#/schema/person/30ff77d05acd807792c8602628ea9390"},"headline":"Andre Drummond has hilarious reaction to finding out Cavs traded for another center in Jarrett Allen","datePublished":"2021-01-14T00:46:29+00:00","dateModified":"2021-01-14T00:47:08+00:00","mainEntityOfPage":{"@id":"https://cavaliersnation.com/2021/01/13/andre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen/#webpage"},"publisher":{"@id":"https://cavaliersnation.com/#organization"},"image":{"@id":"https://cavaliersnation.com/2021/01/13/andre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen/#primaryimage"},"keywords":"andre drummond,brooklyn nets,cleveland cavaliers,featured,jarrett allen,news ticker","articleSection":"Media","inLanguage":"en-US"},{"@type":"Person","@id":"https://cavaliersnation.com/#/schema/person/30ff77d05acd807792c8602628ea9390","name":"Ryan Ward","image":{"@type":"ImageObject","@id":"https://cavaliersnation.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/91e45048f2bd8fb71209a5ef0402b5af?s=96&d=mm&r=g","caption":"Ryan Ward"},"description":"Ryan is a veteran sportswriter with nearly a decade of experience covering the NBA. From interviewing players and coaches to covering games as a credentialed member of the media, Ryan has done it all. Follow him on Twitter @RyanWardLA."}]}</script> <link
rel=amphtml href=https://cavaliersnation.com/2021/01/13/andre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen/amp/ ><meta
name="generator" content="AMP for WP 1.0.74"><link
rel=dns-prefetch href=//fonts.googleapis.com><link
rel=dns-prefetch href=//s.w.org><link
rel=alternate type=application/rss+xml title="Cavaliers Nation &raquo; Feed" href=https://cavaliersnation.com/feed/ ><link
rel=alternate type=application/rss+xml title="Cavaliers Nation &raquo; Comments Feed" href=https://cavaliersnation.com/comments/feed/ > <script>window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cavaliersnation.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link
rel=stylesheet id=googlefonts-css  href='https://fonts.googleapis.com/css?family=Open+Sans+Condensed%3A300%2C700%7COpen+Sans%3A400%2C700%7COswald%3A300%2C400%2C700&#038;subset=latin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese&#038;ver=5.6' type=text/css media=all> <script src='https://cavaliersnation.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id=jquery-core-js></script> <script src='https://cavaliersnation.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id=jquery-migrate-js></script> <script src='https://cavaliersnation.com/wp-content/plugins/sticky-menu-or-anything-on-scroll/assets/js/jq-sticky-anything.min.js?ver=2.1.1' id=stickyAnythingLib-js></script> <script src='https://cavaliersnation.com/wp-content/plugins/wp-retina-2x/app/picturefill.min.js?ver=1610032081' id=wr2x-picturefill-js-js></script> <link
rel=https://api.w.org/ href=https://cavaliersnation.com/wp-json/ ><link
rel=alternate type=application/json href=https://cavaliersnation.com/wp-json/wp/v2/posts/49445><link
rel=EditURI type=application/rsd+xml title=RSD href=https://cavaliersnation.com/xmlrpc.php?rsd><link
rel=wlwmanifest type=application/wlwmanifest+xml href=https://cavaliersnation.com/wp-includes/wlwmanifest.xml><meta
name="generator" content="WordPress 5.6"><link
rel=shortlink href='https://cavaliersnation.com/?p=49445'><link
rel=alternate type=application/json+oembed href="https://cavaliersnation.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcavaliersnation.com%2F2021%2F01%2F13%2Fandre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen%2F"><link
rel=alternate type=text/xml+oembed href="https://cavaliersnation.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcavaliersnation.com%2F2021%2F01%2F13%2Fandre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen%2F&#038;format=xml"><meta
name="onesignal" content="wordpress-plugin"> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://cavaliersnation.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'b691d3c3-97cc-4969-a5c2-2d07e83c1aba';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://cavaliersnation.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.28671d66-3da8-4a50-bcc4-1b29e015670b";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script> <link
rel=icon href=https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg sizes=32x32><link
rel=icon href=https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg sizes=192x192><link
rel=apple-touch-icon href=https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg><meta
name="msapplication-TileImage" content="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg"></head><body
data-rsssl=1 class="post-template-default single single-post postid-49445 single-format-standard custom-background"><div
id=site><div
id=wrapper><div
id=nav-main-wrapper><div
id=nav-main><div
id=nav-main-left><div
id=nav-logo>
<a
href=https://cavaliersnation.com><img
src=https://cavaliersnation.com/wp-content/uploads/2019/05/cnwebsite12.png alt="Cavaliers Nation"></a></div><ul
class=nav-main><div
class=menu-home-container><ul
id=menu-home class=menu><li
id=menu-item-75 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75"><a
href=https://cavaliersnation.com/ >Home</a></li><li
id=menu-item-41 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-41"><a
title=Categories>Categories</a><ul
class=sub-menu><li
id=menu-item-81 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a
href=https://cavaliersnation.com/category/game-reports/ >Game Reports</a></li><li
id=menu-item-82 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82"><a
href=https://cavaliersnation.com/category/editorials/ >Editorials</a></li><li
id=menu-item-84 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84"><a
href=https://cavaliersnation.com/category/team-news/ >Team News</a></li><li
id=menu-item-85 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a
href=https://cavaliersnation.com/category/rumors/ >Rumors</a></li><li
id=menu-item-83 class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83"><a
href=https://cavaliersnation.com/category/media/ >Media</a></li><li
id=menu-item-86 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-86"><a
href=https://cavaliersnation.com/category/videos/ >Videos</a></li></ul></li><li
id=menu-item-39 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a
href=https://cavaliersnation.com/schedule/ >Schedule</a></li><li
id=menu-item-48 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48"><a
href=https://cavaliersnation.com/contributors/ >Contributors</a></li><li
id=menu-item-40 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a
href=https://cavaliersnation.com/about/ >About</a></li><li
id=menu-item-9117 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9117"><a
href=https://cavaliersnation.com/career/ >Career</a></li></ul></div></ul><div
id=nav-mobi><div
class=menu-home-container><select><option
value=#>Menu</option><option
value=https://cavaliersnation.com/ >Home</option><option
value>Categories<option
value=https://cavaliersnation.com/category/game-reports/ >-Game Reports</option><option
value=https://cavaliersnation.com/category/editorials/ >-Editorials</option><option
value=https://cavaliersnation.com/category/team-news/ >-Team News</option><option
value=https://cavaliersnation.com/category/rumors/ >-Rumors</option><option
value=https://cavaliersnation.com/category/media/ >-Media</option><option
value=https://cavaliersnation.com/category/videos/ >-Videos</option></option><option
value=https://cavaliersnation.com/schedule/ >Schedule</option><option
value=https://cavaliersnation.com/contributors/ >Contributors</option><option
value=https://cavaliersnation.com/about/ >About</option><option
value=https://cavaliersnation.com/career/ >Career</option>
</select></div></div></div><div
id=nav-search><form
method=get id=searchform action=https://cavaliersnation.com/ >
<input
type=text name=s id=s value=Search onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }'>
<input
type=hidden id=search-button></form></div></div></div><div
id=main-wrapper><div
id=top-spacer></div><div
id=content-outer><div
id=main-top><div
id=ticker><span
class=ticker-heading>Don't Miss</span><ul
class=ticker-list><li><a
href=https://cavaliersnation.com/2021/01/13/andre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen/ >Andre Drummond has hilarious reaction to finding out Cavs traded for another center in Jarrett Allen</a></li><li><a
href=https://cavaliersnation.com/2021/01/13/report-cavs-waive-2-players-in-aftermath-of-blockbuster-james-harden-trade/ >Report: Cavs waive 2 players in aftermath of blockbuster James Harden trade</a></li><li><a
href=https://cavaliersnation.com/2021/01/13/report-cavs-acquire-jarrett-allen-and-taurean-prince-in-blockbuster-james-harden-deal/ >Report: Cavs acquire Jarrett Allen and Taurean Prince in blockbuster James Harden deal</a></li><li><a
href=https://cavaliersnation.com/2021/01/13/report-cavs-helping-kevin-porter-jr-get-his-life-together-before-putting-him-on-the-court/ >Report: Cavs helping Kevin Porter Jr. &#8216;get his life together before putting him on the court&#8217;</a></li><li><a
href=https://cavaliersnation.com/2021/01/12/report-cavs-reveal-mri-results-of-collin-sextons-latest-injury/ >Report: Cavs reveal MRI results of Collin Sexton&#8217;s latest injury</a></li><li><a
href=https://cavaliersnation.com/2021/01/12/report-cavs-considered-adding-jeremy-lin-before-signing-yogi-ferrell/ >Report: Cavs considered adding Jeremy Lin before signing Yogi Ferrell</a></li><li><a
href=https://cavaliersnation.com/2021/01/11/kevin-porter-jr-highlights-relationship-with-carmelo-anthony-as-he-remains-away-from-cavs/ >Kevin Porter Jr. highlights relationship with Carmelo Anthony as he remains away from Cavs</a></li><li><a
href=https://cavaliersnation.com/2021/01/11/report-steve-nash-continues-to-have-no-update-on-kyrie-irvings-mysterious-absence-from-nets/ >Report: Steve Nash continues to have no update on Kyrie Irving&#8217;s mysterious absence from Nets</a></li><li><a
href=https://cavaliersnation.com/2021/01/11/cavs-sign-guard-to-contract/ >Report: Cavs sign veteran guard to 10-day contract with hardship exception</a></li><li><a
href=https://cavaliersnation.com/2021/01/10/larry-nance-jr-blown-away-with-andre-drummond-after-he-leaves-insane-tip-at-restaurant/ >Larry Nance Jr. blown away with Andre Drummond after he leaves insane tip at restaurant</a></li></ul></div><div
id=content-social><ul><li><a href="https://www.facebook.com/cavaliersnation" alt=Facebook class=fb-but target=_blank></a></li><li><a href="https://www.twitter.com/wearecavsnation" alt=Twitter class=twitter-but target=_blank></a></li><li><a href="https://www.instagram.com/cavaliersnationdotcom" alt=Instagram class=instagram-but target=_blank></a></li><li><a
href=https://cavaliersnation.com/feed/rss/ alt="RSS Feed" class=rss-but></a></li></ul></div></div><div
id=content-inner><div
id=main><div
class=breadcrumb><div
id=crumbs><a
href=https://cavaliersnation.com>Home</a> / <a
href=https://cavaliersnation.com/category/media/ >Media</a> / <span
class=current>Andre Drummond has hilarious reaction to finding out Cavs traded for another center in Jarrett Allen</span></div></div><h1 class="headline">Andre Drummond has hilarious reaction to finding out Cavs traded for another center in Jarrett Allen</h1><div
id=post-info-wrapper><ul
class=post-info><li><div
class=post-author>By <a
href=https://cavaliersnation.com/author/ryan-ward/ title="Posts by Ryan Ward" rel=author>Ryan Ward</a></div></li><li><ul
class=post-social><li><div
class=fb-like data-send=false data-layout=button_count data-width=90 data-show-faces=false></div></li><li><a href="https://twitter.com/share" class=twitter-share-button data-lang=en data-count=horizontal>Tweet</a></li><li><g:plusone size="medium" annotation="bubble" width="120"></g:plusone></li><li>
<a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fcavaliersnation.com%2F2021%2F01%2F13%2Fandre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen%2F&media=https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_14120992_168386351_lowres-e1604858495964.jpg&description=Andre Drummond has hilarious reaction to finding out Cavs traded for another center in Jarrett Allen" class=pin-it-button count-layout=horizontal>Pin It</a></li></ul></li><li><div
class=post-update>Updated: January 13, 2021</div></li></ul></div><div
id=post-area class="post-49445 post type-post status-publish format-standard has-post-thumbnail category-media tag-andre-drummond tag-brooklyn-nets tag-cleveland-cavaliers tag-featured tag-jarrett-allen tag-news-ticker"><div
class=post-image><img
width=1800 height=1200 src=https://cavaliersnation.com/wp-content/uploads/2020/11/USATSI_14120992_168386351_lowres-e1604858495964.jpg class="attachment-post-thumb size-post-thumb wp-post-image" alt="Andre Drummond Cavs" loading=lazy></div><div
id=content-area><p>Another blockbuster trade in the NBA went down on Wednesday with the <a
href=https://ahnfiredigital.com/nba/houston-rockets/report-brooklyn-nets-acquire-james-harden-in-monster-3-team-deal/ >Brooklyn Nets acquiring superstar James Harden</a> from the Houston Rockets. The <a
title="Cleveland Cavaliers" href=https://cavaliersnation.com/tag/cleveland-cavaliers/ >Cleveland Cavaliers</a> also got involved in the action with a deal of their own.</p><p>The Cavs made a move to <a
href=https://cavaliersnation.com/2021/01/13/report-cavs-acquire-jarrett-allen-and-taurean-prince-in-blockbuster-james-harden-deal/ >acquire center Jarrett Allen and Taurean Prince from the Nets</a>. Although Allen is a talented player, Cavs center <a
title="Andre Drummond" href=https://cavaliersnation.com/tag/andre-drummond/ >Andre Drummond</a> couldn&#8217;t help but crack up about a tweet about Cleveland&#8217;s future lineup.</p><blockquote
class=twitter-tweet data-width=550 data-dnt=true><p
lang=en dir=ltr>Lmaoooooo I’m weak 😂😂 <a
href=https://t.co/ka6HHe6Ttv>https://t.co/ka6HHe6Ttv</a></p><p>&mdash; <a
title="Andre Drummond" href=https://cavaliersnation.com/tag/andre-drummond/ >Andre Drummond</a> (@AndreDrummond) <a
href="https://twitter.com/AndreDrummond/status/1349469406129246211?ref_src=twsrc%5Etfw">January 13, 2021</a></p></blockquote><p><script async src=https://platform.twitter.com/widgets.js charset=utf-8></script></p><p>Cleveland has made some head-scratching moves ever since <a
title="LeBron James" href=https://cavaliersnation.com/tag/lebron-james/ >LeBron James</a> left the team to sign with the Los Angeles Lakers in free agency. The team has seemingly been stockpiling centers, with Allen being the latest along with Drummond and <a
href=https://cavaliersnation.com/2020/11/22/report-cavs-send-trade-package-to-lakers-for-javale-mcgee/ >JaVale McGee. </a></p><p>It remains unclear what the team&#8217;s motivation was behind acquiring Allen with proven veterans Drummond and McGee already on the roster.</p><p>In 12 games this season, Allen has averaged a double-double with 11.2 points and 10.4 rebounds per game while shooting 67.7 percent from the floor for the Nets.</p><div
id=contentad123909></div> <script>(function(d) {
        var params =
        {
            id: "e576b5e3-63b7-43fe-8588-310c094931f8",
            d:  "Y2F2YWxpZXJzbmF0aW9uLmNvbQ==",
            wid: "123909",
            cb: (new Date()).getTime()
        };

        var qs=[];
        for(var key in params) qs.push(key+'='+encodeURIComponent(params[key]));
        var s = d.createElement('script');s.type='text/javascript';s.async=true;
        var p = 'https:' == document.location.protocol ? 'https' : 'http';
        s.src = p + "://api.content-ad.net/Scripts/widget2.aspx?" + qs.join('&');
        d.getElementById("contentad123909").appendChild(s);
    })(document);</script> <div
class=post-tags><a
href=https://cavaliersnation.com/tag/andre-drummond/ rel=tag>andre drummond</a><a
href=https://cavaliersnation.com/tag/brooklyn-nets/ rel=tag>brooklyn nets</a><a
href=https://cavaliersnation.com/tag/cleveland-cavaliers/ rel=tag>cleveland cavaliers</a><a
href=https://cavaliersnation.com/tag/featured/ rel=tag>featured</a><a
href=https://cavaliersnation.com/tag/jarrett-allen/ rel=tag>jarrett allen</a><a
href=https://cavaliersnation.com/tag/news-ticker/ rel=tag>news ticker</a></div><div
class=prev-next-wrapper><div
class=prev-post>&larr; Previous Story <a
href=https://cavaliersnation.com/2021/01/11/kevin-porter-jr-highlights-relationship-with-carmelo-anthony-as-he-remains-away-from-cavs/ rel=prev>Kevin Porter Jr. highlights relationship with Carmelo Anthony as he remains away from Cavs</a></div><div
class=next-post></div></div></div><div
id=related-posts><h3>Related Posts</h3><ul><li><div
class=related-image>
<a
href=https://cavaliersnation.com/2021/01/13/report-cavs-waive-2-players-in-aftermath-of-blockbuster-james-harden-trade/ rel=bookmark title="Report: Cavs waive 2 players in aftermath of blockbuster James Harden trade"><img
width=300 height=195 src=https://cavaliersnation.com/wp-content/uploads/2021/01/USATSI_15425961_168386351_lowres-300x195.jpg class="attachment-large-thumb size-large-thumb wp-post-image" alt="Yogi Ferrell" loading=lazy srcset="https://cavaliersnation.com/wp-content/uploads/2021/01/USATSI_15425961_168386351_lowres-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2021/01/USATSI_15425961_168386351_lowres-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2021/01/USATSI_15425961_168386351_lowres-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px"></a></div><div
class=related-text><a
href=https://cavaliersnation.com/2021/01/13/report-cavs-waive-2-players-in-aftermath-of-blockbuster-james-harden-trade/ class=main-headline>Report: Cavs waive 2 players in aftermath of blockbuster James Harden trade</a></div></li><li><div
class=related-image>
<a
href=https://cavaliersnation.com/2021/01/13/report-cavs-acquire-jarrett-allen-and-taurean-prince-in-blockbuster-james-harden-deal/ rel=bookmark title="Report: Cavs acquire Jarrett Allen and Taurean Prince in blockbuster James Harden deal"><img
width=300 height=195 src=https://cavaliersnation.com/wp-content/uploads/2021/01/gettyimages-1192978254-1-300x195.jpg class="attachment-large-thumb size-large-thumb wp-post-image" alt="Jarrett Allen and Taurean Prince" loading=lazy srcset="https://cavaliersnation.com/wp-content/uploads/2021/01/gettyimages-1192978254-1-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2021/01/gettyimages-1192978254-1-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2021/01/gettyimages-1192978254-1-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px"></a></div><div
class=related-text><a
href=https://cavaliersnation.com/2021/01/13/report-cavs-acquire-jarrett-allen-and-taurean-prince-in-blockbuster-james-harden-deal/ class=main-headline>Report: Cavs acquire Jarrett Allen and Taurean Prince in blockbuster James Harden deal</a></div></li><li><div
class=related-image>
<a
href=https://cavaliersnation.com/2021/01/13/report-cavs-helping-kevin-porter-jr-get-his-life-together-before-putting-him-on-the-court/ rel=bookmark title="Report: Cavs helping Kevin Porter Jr. &#8216;get his life together before putting him on the court&#8217;"><img
width=300 height=195 src=https://cavaliersnation.com/wp-content/uploads/2020/03/USATSI_14120705-300x195.jpg class="attachment-large-thumb size-large-thumb wp-post-image" alt="Kevin Porter Jr. Cavs" loading=lazy srcset="https://cavaliersnation.com/wp-content/uploads/2020/03/USATSI_14120705-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2020/03/USATSI_14120705-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2020/03/USATSI_14120705-108x70.jpg 108w, https://cavaliersnation.com/wp-content/uploads/2020/03/USATSI_14120705-300x195@2x.jpg 600w, https://cavaliersnation.com/wp-content/uploads/2020/03/USATSI_14120705-615x400@2x.jpg 1230w, https://cavaliersnation.com/wp-content/uploads/2020/03/USATSI_14120705-108x70@2x.jpg 216w" sizes="(max-width: 300px) 100vw, 300px"></a></div><div
class=related-text><a
href=https://cavaliersnation.com/2021/01/13/report-cavs-helping-kevin-porter-jr-get-his-life-together-before-putting-him-on-the-court/ class=main-headline>Report: Cavs helping Kevin Porter Jr. &#8216;get his life together before putting him on the court&#8217;</a></div></li></ul></div><div
id=comments><p>
You must be logged in to post a comment
<a
href="https://cavaliersnation.com/wp-login.php?redirect_to=https%3A%2F%2Fcavaliersnation.com%2F2021%2F01%2F13%2Fandre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen%2F">
Login
</a></p></div></div><div
id=sidebar-wrapper><div
class=widget-container><div
class=widget-inner><h4 class="widget-header">About Ryan Ward</h4><div
class=author-image>
<img
class="avatar avatar-60 photo" width=64 height=64 srcset="https://cavaliersnation.com/wp-content/uploads/2020/09/0C5939BD-E6C1-4F80-A787-B79611875224-150x150.jpg, https://cavaliersnation.com/wp-content/uploads/2020/09/0C5939BD-E6C1-4F80-A787-B79611875224-150x150@2x.jpg 2x"></div><p
class="author-box gd-widgets">Ryan is a veteran sportswriter with nearly a decade of experience covering the NBA. From interviewing players and coaches to covering games as a credentialed member of the media, Ryan has done it all. Follow him on Twitter @RyanWardLA.</p></div></div><div
class=widget-container>
<span
class=blog-cat-title>Recent</span><div
class=widget-img>
<a
href=https://cavaliersnation.com/2021/01/13/report-cavs-helping-kevin-porter-jr-get-his-life-together-before-putting-him-on-the-court/ rel=bookmark title="Report: Cavs helping Kevin Porter Jr. &#8216;get his life together before putting him on the court&#8217;"><img
width=300 height=195 src=https://cavaliersnation.com/wp-content/uploads/2020/03/USATSI_14120705-300x195.jpg class="attachment-large-thumb size-large-thumb wp-post-image" alt="Kevin Porter Jr. Cavs" loading=lazy srcset="https://cavaliersnation.com/wp-content/uploads/2020/03/USATSI_14120705-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2020/03/USATSI_14120705-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2020/03/USATSI_14120705-108x70.jpg 108w, https://cavaliersnation.com/wp-content/uploads/2020/03/USATSI_14120705-300x195@2x.jpg 600w, https://cavaliersnation.com/wp-content/uploads/2020/03/USATSI_14120705-615x400@2x.jpg 1230w, https://cavaliersnation.com/wp-content/uploads/2020/03/USATSI_14120705-108x70@2x.jpg 216w" sizes="(max-width: 300px) 100vw, 300px"></a></div><div
class=widget-inner><h3 class="home-title1"><a
href=https://cavaliersnation.com/2021/01/13/report-cavs-helping-kevin-porter-jr-get-his-life-together-before-putting-him-on-the-court/ rel=bookmark>Report: Cavs helping Kevin Porter Jr. &#8216;get his life together before putting him on the court&#8217;</a></h3><p
class=gd-widgets>The Cleveland Cavaliers have been without the services of youngster Kevin Porter Jr. for the beginning of the 2020-21...</p><ul
class=home-links1><li><a
href=https://cavaliersnation.com/2021/01/12/report-cavs-considered-adding-jeremy-lin-before-signing-yogi-ferrell/ rel=bookmark>Report: Cavs considered adding Jeremy Lin before signing Yogi Ferrell</a></li><li><a
href=https://cavaliersnation.com/2021/01/07/report-cavs-front-office-has-considered-kevin-love-integral-component-to-the-teams-functionality-on-offense/ rel=bookmark>Report: Cavs front office considers Kevin Love &#8216;integral component to the team’s functionality on offense&#8217;</a></li><li><a
href=https://cavaliersnation.com/2021/01/05/report-cavs-release-timetable-on-dante-exums-return-from-injury/ rel=bookmark>Report: Cavs release timetable on Dante Exum’s return from injury</a></li><li><a
href=https://cavaliersnation.com/2021/01/02/report-cavs-concerned-with-kevin-porter-jr-s-maturity-dont-want-him-to-return-until-hes-emotionally-ready/ rel=bookmark>Report: Cavs concerned with Kevin Porter Jr.&#8217;s maturity, don&#8217;t want him back until he&#8217;s &#8217;emotionally ready&#8217;</a></li></ul></div></div><div
class=widget-container><div
id=yikes_easy_mc_widget-5 class="widget-inner widget_yikes_easy_mc_widget"><h4 class="widget-header">Subscribe to get your daily Cleveland Cavaliers news, rumors, and videos!</h4><section
id=yikes-mailchimp-container-1 class="yikes-mailchimp-container yikes-mailchimp-container-1 "><form
id=cavaliers-nation-1 class="yikes-easy-mc-form yikes-easy-mc-form-1  " method=POST data-attr-form-id=1><label
for=yikes-easy-mc-form-1-EMAIL  class="EMAIL-label yikes-mailchimp-field-required ">
<span
class=EMAIL-label>
Email Address	</span>
<input
id=yikes-easy-mc-form-1-EMAIL  name=EMAIL  placeholder  class="yikes-easy-mc-email "  required=required type=email  value>
</label>
<label
for=yikes-easy-mc-form-1-FNAME  class="FNAME-label ">
<span
class=FNAME-label>
First Name	</span>
<input
id=yikes-easy-mc-form-1-FNAME  name=FNAME  placeholder  class="yikes-easy-mc-text "   type=text  value>
</label>
<label
for=yikes-easy-mc-form-1-LNAME  class="LNAME-label ">
<span
class=LNAME-label>
Last Name	</span>
<input
id=yikes-easy-mc-form-1-LNAME  name=LNAME  placeholder  class="yikes-easy-mc-text "   type=text  value>
</label>
<input
type=hidden name=yikes-mailchimp-honeypot id=yikes-mailchimp-honeypot-1 value>
<input
type=hidden name=yikes-mailchimp-associated-list-id id=yikes-mailchimp-associated-list-id-1 value=fd937dddf1>
<input
type=hidden name=yikes-mailchimp-submitted-form id=yikes-mailchimp-submitted-form-1 value=1>
<button
type=submit class="yikes-easy-mc-submit-button yikes-easy-mc-submit-button-1 btn btn-primary "> <span
class=yikes-mailchimp-submit-button-span-text>Submit</span></button>
<input
type=hidden id=yikes_easy_mc_new_subscriber_1 name=yikes_easy_mc_new_subscriber value=e532846d0e>
<input
type=hidden name=_wp_http_referer value=/2021/01/13/andre-drummond-has-hilarious-reaction-to-finding-out-cavs-traded-for-another-center-in-jarrett-allen/ ></form></section></div></div></div></div></div></div></div></div><div
id=footer-wrapper><div
id=footer><div
id=footer-nav><div
class=menu-home-container><ul
id=menu-home-2 class=menu><li
class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75"><a
href=https://cavaliersnation.com/ >Home</a></li><li
class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-41"><a
title=Categories>Categories</a><ul
class=sub-menu><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a
href=https://cavaliersnation.com/category/game-reports/ >Game Reports</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82"><a
href=https://cavaliersnation.com/category/editorials/ >Editorials</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84"><a
href=https://cavaliersnation.com/category/team-news/ >Team News</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a
href=https://cavaliersnation.com/category/rumors/ >Rumors</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83"><a
href=https://cavaliersnation.com/category/media/ >Media</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-86"><a
href=https://cavaliersnation.com/category/videos/ >Videos</a></li></ul></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a
href=https://cavaliersnation.com/schedule/ >Schedule</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48"><a
href=https://cavaliersnation.com/contributors/ >Contributors</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a
href=https://cavaliersnation.com/about/ >About</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9117"><a
href=https://cavaliersnation.com/career/ >Career</a></li></ul></div></div><div
id=copyright><p>Copyright © 2014 Cavaliers Nation, All Rights Reserved. Property of <a
href=https://ahnfiredigital.com>Ahn Fire Digital</a>. Partner with USA Today Sports Digital
Properties. <a
href=https://cavaliersnation.com/privacy-policy>Privacy Policy</a></p></div></div></div></div> <script>jQuery(document).ready(function($){

  $(window).load(function(){

    $('.flexslider').flexslider({

	animation: 'fade',

	slideshowSpeed: 8000

    	});

  	});



$('.carousel').elastislide({

	imageW 	: 80,

	minItems	: 2,

	margin		: 3

});

});</script> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.async=true;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script> <script>(function() {

    window.PinIt = window.PinIt || { loaded:false };

    if (window.PinIt.loaded) return;

    window.PinIt.loaded = true;

    function async_load(){

        var s = document.createElement("script");

        s.type = "text/javascript";

        s.async = true;

        s.src = "https://assets.pinterest.com/js/pinit.js";

        var x = document.getElementsByTagName("script")[0];

        x.parentNode.insertBefore(s, x);

    }

    if (window.attachEvent)

        window.attachEvent("onload", async_load);

    else

        window.addEventListener("load", async_load, false);

})();</script> <script>(function() {

    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;

    po.src = 'https://apis.google.com/js/plusone.js';

    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);

  })();</script> <div
id=fb-root></div> <script>(function(d, s, id) {

  var js, fjs = d.getElementsByTagName(s)[0];

  if (d.getElementById(id)) return;

  js = d.createElement(s); js.id = id;

  js.async = true;

  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";

  fjs.parentNode.insertBefore(js, fjs);

}(document, 'script', 'facebook-jssdk'));</script> <script src='https://cavaliersnation.com/wp-includes/js/comment-reply.min.js?ver=5.6' id=comment-reply-js></script> <script id=stickThis-js-extra>var sticky_anything_engage = {"element":".ad-728","topspace":"0","minscreenwidth":"0","maxscreenwidth":"999999","zindex":"1","legacymode":"","dynamicmode":"","debugmode":"","pushup":"","adminbar":"1"};</script> <script src='https://cavaliersnation.com/wp-content/plugins/sticky-menu-or-anything-on-scroll/assets/js/stickThis.js?ver=2.1.1' id=stickThis-js></script> <script src='https://cavaliersnation.com/wp-content/themes/gameday/js/jquery.flexslider.js?ver=5.6' id=flexslider-js></script> <script src='https://cavaliersnation.com/wp-content/themes/gameday/js/jquery.elastislide.js?ver=5.6' id=elastislide-js></script> <script src='https://cavaliersnation.com/wp-content/themes/gameday/js/scripts.js?ver=5.6' id=gameday-js></script> <script src='https://cavaliersnation.com/wp-content/themes/gameday/js/ticker.js?ver=5.6' id=ticker-js></script> <script src='https://cavaliersnation.com/wp-content/themes/gameday/js/respond.min.js?ver=5.6' id=respond-js></script> <script src='https://cavaliersnation.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id=imagesloaded-js></script> <script src='https://cavaliersnation.com/wp-content/themes/gameday/js/css3-mediaqueries.js?ver=5.6' id=queries-js></script> <script src='https://cavaliersnation.com/wp-content/themes/gameday/js/retina.js?ver=5.6' id=retina-js></script> <script src='https://cavaliersnation.com/wp-includes/js/wp-embed.min.js?ver=5.6' id=wp-embed-js></script> <script src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.6' async=async id=remote_sdk-js></script> <script id=yikes-easy-mc-ajax-js-extra>var yikes_mailchimp_ajax = {"ajax_url":"https:\/\/cavaliersnation.com\/wp-admin\/admin-ajax.php","page_data":"49274","interest_group_checkbox_error":"This field is required.","preloader_url":"https:\/\/cavaliersnation.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/ripple.svg","loading_dots":"https:\/\/cavaliersnation.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/bars.svg","ajax_security_nonce":"1885ee4c70","feedback_message_placement":"before"};</script> <script src='https://cavaliersnation.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/yikes-mc-ajax-forms.min.js?ver=6.7.0' id=yikes-easy-mc-ajax-js></script> <script id=form-submission-helpers-js-extra>var form_submission_helpers = {"ajax_url":"https:\/\/cavaliersnation.com\/wp-admin\/admin-ajax.php","preloader_url":"https:\/\/cavaliersnation.com\/wp-admin\/images\/wpspin_light.gif","countries_with_zip":{"US":"US","GB":"GB","CA":"CA","IE":"IE","CN":"CN","IN":"IN","AU":"AU","BR":"BR","MX":"MX","IT":"IT","NZ":"NZ","JP":"JP","FR":"FR","GR":"GR","DE":"DE","NL":"NL","PT":"PT","ES":"ES"},"page_data":"49274"};</script> <script src='https://cavaliersnation.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/form-submission-helpers.min.js?ver=6.7.0' id=form-submission-helpers-js></script> </body></html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Object Caching 127/198 objects using disk
Page Caching using disk: enhanced 

Served from: cavaliersnation.com @ 2021-01-13 19:47:12 by W3 Total Cache
-->