<!DOCTYPE html><html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"><head> <script src="https://us.connextra.com/dcs/tagController/tag/362820167f7c/homepage" async defer></script> <meta name="verifyownership" 
 content="8b17572d9adc3b6cbc654dc1d5d043e5"/><meta name="verifyownership" 
 content="16a1e10dad87b5c0fc759f5de4f6f60e"/> <script async src="//js-sec.indexww.com/ht/p/184031-43290852983293.js"></script>  <script>var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "6035223" });
  (function() {
    var s = document.createElement("script"), el =
document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb<https://sb/>" :
"http://b<http://b/>") +
".scorecardresearch.com/beacon.js<http://scorecardresearch.com/beacon.js>";
    el.parentNode.insertBefore(s, el);
  })();</script> <noscript> <img src="https://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" /> </noscript>  <script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script> <meta name="google-site-verification" content="KStSRn6409ttzCYidg-n9MD7blSVvoj25HKqQg3hg5Y" /><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" /><meta property="og:image" content="https://cavaliersnation.com/wp-content/uploads/2022/02/Isaac-Okoro-and-J.B.-Bickerstaff-1-615x400.jpg" /><link media="all" href="https://cavaliersnation.com/wp-content/cache/autoptimize/css/autoptimize_27ec70361f7135c20c0a20c6712ede3d.css" rel="stylesheet" /><title>Isaac Okoro shows off epic new award created by Cavs to honor team&#039;s gritty mentality - Cavaliers Nation</title> <!--[if IE]><link rel="stylesheet" type="text/css" href="https://cavaliersnation.com/wp-content/themes/gameday/css/iecss.css" /> <![endif]--><link rel="shortcut icon" href="https://cavaliersnation.com/wp-content/uploads/2017/10/cavaliersnationlogo-1.jpg" /><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://cavaliersnation.com/feed/" /><link rel="alternate" type="text/xml" title="RSS .92" href="https://cavaliersnation.com/feed/rss/" /><link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://cavaliersnation.com/feed/atom/" /><link rel="pingback" href="https://cavaliersnation.com/xmlrpc.php" /> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-56943371-1', 'auto');
  ga('send', 'pageview');</script> <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <script>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</script> <script>(function(w, d) {
	w.adthrive = w.adthrive || {};
	w.adthrive.cmd = w.adthrive.cmd || [];
	w.adthrive.plugin = 'adthrive-ads-1.1.4';
	w.adthrive.host = 'ads.adthrive.com';
	w.adthrive.integration = 'plugin';

	var commitParam = (w.adthriveCLS && w.adthriveCLS.bucket !== 'prod' && w.adthriveCLS.branch) ? '&commit=' + w.adthriveCLS.branch : '';

	var s = d.createElement('script');
	s.async = true;
	s.referrerpolicy='no-referrer-when-downgrade';
	s.src = 'https://' + w.adthrive.host + '/sites/5b48a37c9be6984315eaf2ce/ads.min.js?referrer=' + w.encodeURIComponent(w.location.href) + commitParam + '&cb=' + (Math.floor(Math.random() * 100) + 1);
	var n = d.getElementsByTagName('script')[0];
	n.parentNode.insertBefore(s, n);
})(window, document);</script> <meta name="description" content="The Cleveland Cavaliers eked out a 92-86 win over the Washington Wizards on Saturday night. The team needed a solid and gritty defensive effort from its players to snap a three-game losing streak." /><link rel="canonical" href="https://cavaliersnation.com/?p=54939" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Isaac Okoro shows off epic new award created by Cavs to honor team&#039;s gritty mentality" /><meta property="og:description" content="The Cleveland Cavaliers eked out a 92-86 win over the Washington Wizards on Saturday night. The team needed a solid and gritty defensive effort from its players to snap a three-game losing streak." /><meta property="og:url" content="https://cavaliersnation.com/?p=54939" /><meta property="og:site_name" content="Cavaliers Nation" /><meta property="article:publisher" content="https://www.facebook.com/CavaliersNation/" /><meta property="article:published_time" content="2022-02-27T15:11:16+00:00" /><meta property="og:image" content="https://cavaliersnation.com/wp-content/uploads/2022/02/Isaac-Okoro-and-J.B.-Bickerstaff-1.jpg" /><meta property="og:image:width" content="1300" /><meta property="og:image:height" content="968" /><meta property="og:image:type" content="image/jpeg" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@WeAreCavsNation" /><meta name="twitter:site" content="@WeAreCavsNation" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://cavaliersnation.com/#organization","name":"Cavaliers Nation","url":"https://cavaliersnation.com/","sameAs":["https://www.facebook.com/CavaliersNation/","https://www.instagram.com/cavaliersnationdotcom/","https://twitter.com/WeAreCavsNation"],"logo":{"@type":"ImageObject","@id":"https://cavaliersnation.com/#logo","inLanguage":"en-US","url":"https://cavaliersnation.com/wp-content/uploads/2018/08/cn-logo.jpg","contentUrl":"https://cavaliersnation.com/wp-content/uploads/2018/08/cn-logo.jpg","width":567,"height":567,"caption":"Cavaliers Nation"},"image":{"@id":"https://cavaliersnation.com/#logo"}},{"@type":"WebSite","@id":"https://cavaliersnation.com/#website","url":"https://cavaliersnation.com/","name":"Cavaliers Nation","description":"Cavs News and Rumors 24/7","publisher":{"@id":"https://cavaliersnation.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://cavaliersnation.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://cavaliersnation.com/?p=54939#primaryimage","inLanguage":"en-US","url":"https://cavaliersnation.com/wp-content/uploads/2022/02/Isaac-Okoro-and-J.B.-Bickerstaff-1.jpg","contentUrl":"https://cavaliersnation.com/wp-content/uploads/2022/02/Isaac-Okoro-and-J.B.-Bickerstaff-1.jpg","width":1300,"height":968,"caption":"Isaac Okoro and J.B. Bickerstaff"},{"@type":"WebPage","@id":"https://cavaliersnation.com/?p=54939#webpage","url":"https://cavaliersnation.com/?p=54939","name":"Isaac Okoro shows off epic new award created by Cavs to honor team's gritty mentality - Cavaliers Nation","isPartOf":{"@id":"https://cavaliersnation.com/#website"},"primaryImageOfPage":{"@id":"https://cavaliersnation.com/?p=54939#primaryimage"},"datePublished":"2022-02-27T15:11:16+00:00","dateModified":"2022-02-27T15:11:16+00:00","description":"The Cleveland Cavaliers eked out a 92-86 win over the Washington Wizards on Saturday night. The team needed a solid and gritty defensive effort from its players to snap a three-game losing streak.","breadcrumb":{"@id":"https://cavaliersnation.com/?p=54939#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://cavaliersnation.com/?p=54939"]}]},{"@type":"BreadcrumbList","@id":"https://cavaliersnation.com/?p=54939#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://cavaliersnation.com/"},{"@type":"ListItem","position":2,"name":"Isaac Okoro shows off epic new award created by Cavs to honor team&#8217;s gritty mentality"}]},{"@type":"NewsArticle","@id":"https://cavaliersnation.com/?p=54939#article","isPartOf":{"@id":"https://cavaliersnation.com/?p=54939#webpage"},"author":{"@id":"https://cavaliersnation.com/#/schema/person/e0c699158cb4229422ff73d2169d8108"},"headline":"Isaac Okoro shows off epic new award created by Cavs to honor team&#8217;s gritty mentality","datePublished":"2022-02-27T15:11:16+00:00","dateModified":"2022-02-27T15:11:16+00:00","mainEntityOfPage":{"@id":"https://cavaliersnation.com/?p=54939#webpage"},"wordCount":432,"publisher":{"@id":"https://cavaliersnation.com/#organization"},"image":{"@id":"https://cavaliersnation.com/?p=54939#primaryimage"},"thumbnailUrl":"https://cavaliersnation.com/wp-content/uploads/2022/02/Isaac-Okoro-and-J.B.-Bickerstaff-1.jpg","keywords":["cleveland cavaliers","featured","isaac okoro","j.b. bickerstaff","news ticker"],"articleSection":["Media"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://cavaliersnation.com/#/schema/person/e0c699158cb4229422ff73d2169d8108","name":"Orel Dizon","image":{"@type":"ImageObject","@id":"https://cavaliersnation.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/db0d2a17911729b03579fa3d636b4cfb?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/db0d2a17911729b03579fa3d636b4cfb?s=96&d=mm&r=g","caption":"Orel Dizon"},"description":"Orel is a freelance writer who is passionate about the NBA. He has followed the league since the late '90s and found increased interest in it in 2003 – when an 18-year-old prodigy from Akron, Ohio took the league by storm.","url":"https://cavaliersnation.com/author/orel-dizon/"}]}</script> <link rel="amphtml" href="https://cavaliersnation.com/2022/02/27/isaac-okoro-shows-off-epic-new-award-created-by-cavs-to-honor-teams-gritty-mentality/amp/" /><meta name="generator" content="AMP for WP 1.0.77.36"/><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Cavaliers Nation &raquo; Feed" href="https://cavaliersnation.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Cavaliers Nation &raquo; Comments Feed" href="https://cavaliersnation.com/comments/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cavaliersnation.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style id="googlefonts-css" media="all">@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 400;
  font-stretch: normal;
  src: url(/fonts.gstatic.com/s/opensans/v27/memSYaGs126MiZpBA-UvWbX2vVnXBbObj2OVZyOOSr4dVJWUgsjZ0C4n.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 700;
  font-stretch: normal;
  src: url(/fonts.gstatic.com/s/opensans/v27/memSYaGs126MiZpBA-UvWbX2vVnXBbObj2OVZyOOSr4dVJWUgsg-1y4n.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans Condensed';
  font-style: normal;
  font-weight: 300;
  src: url(/fonts.gstatic.com/s/opensanscondensed/v21/z7NFdQDnbTkabZAIOl9il_O6KJj73e7Ff1GhPuI.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans Condensed';
  font-style: normal;
  font-weight: 700;
  src: url(/fonts.gstatic.com/s/opensanscondensed/v21/z7NFdQDnbTkabZAIOl9il_O6KJj73e7Ff0GmPuI.ttf) format('truetype');
}
@font-face {
  font-family: 'Oswald';
  font-style: normal;
  font-weight: 300;
  src: url(/fonts.gstatic.com/s/oswald/v41/TK3_WkUHHAIjg75cFRf3bXL8LICs169vgUE.ttf) format('truetype');
}
@font-face {
  font-family: 'Oswald';
  font-style: normal;
  font-weight: 400;
  src: url(/fonts.gstatic.com/s/oswald/v41/TK3_WkUHHAIjg75cFRf3bXL8LICs1_FvgUE.ttf) format('truetype');
}
@font-face {
  font-family: 'Oswald';
  font-style: normal;
  font-weight: 700;
  src: url(/fonts.gstatic.com/s/oswald/v41/TK3_WkUHHAIjg75cFRf3bXL8LICs1xZogUE.ttf) format('truetype');
}
</style> <script type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/sticky-menu-or-anything-on-scroll/assets/js/jq-sticky-anything.min.js?ver=2.1.1' id='stickyAnythingLib-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/wp-retina-2x/app/picturefill.min.js?ver=1643339284' id='wr2x-picturefill-js-js'></script> <link rel="https://api.w.org/" href="https://cavaliersnation.com/wp-json/" /><link rel="alternate" type="application/json" href="https://cavaliersnation.com/wp-json/wp/v2/posts/54939" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://cavaliersnation.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cavaliersnation.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.9.1" /><link rel='shortlink' href='https://cavaliersnation.com/?p=54939' /><link rel="alternate" type="application/json+oembed" href="https://cavaliersnation.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcavaliersnation.com%2F2022%2F02%2F27%2Fisaac-okoro-shows-off-epic-new-award-created-by-cavs-to-honor-teams-gritty-mentality%2F" /><link rel="alternate" type="text/xml+oembed" href="https://cavaliersnation.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcavaliersnation.com%2F2022%2F02%2F27%2Fisaac-okoro-shows-off-epic-new-award-created-by-cavs-to-honor-teams-gritty-mentality%2F&#038;format=xml" /><meta name="onesignal" content="wordpress-plugin"/> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://cavaliersnation.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'b691d3c3-97cc-4969-a5c2-2d07e83c1aba';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://cavaliersnation.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.28671d66-3da8-4a50-bcc4-1b29e015670b";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script> <link rel="icon" href="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" sizes="32x32" /><link rel="icon" href="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" sizes="192x192" /><link rel="apple-touch-icon" href="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" /><meta name="msapplication-TileImage" content="https://cavaliersnation.com/wp-content/uploads/2016/08/cavaliersnationlogofavicon.jpg" /> <script id='cls-disable-ads-886f5bb'>var cls_disable_ads=function(t){"use strict";var e=function(t){var e=window.location.href;return t.some((function(t){return new RegExp(t,"i").test(e)}))},i=function(){function t(t){this.adthrive=t,this.all=!1,this.content=!1,this.recipe=!1,this.video=!1,this.locations=new Set,this.reasons=new Set,(this.urlHasEmail(window.location.href)||this.urlHasEmail(window.document.referrer))&&(this.all=!0,this.reasons.add("all_email"));try{this.checkCommandQueue(),null!==document.querySelector(".tag-novideo")&&(this.video=!0,this.locations.add("Video"),this.reasons.add("video_tag"))}catch(t){}}return t.prototype.checkCommandQueue=function(){var t=this;this.adthrive&&this.adthrive.cmd&&this.adthrive.cmd.forEach((function(e){var i=e.toString(),a=t.extractAPICall(i,"disableAds");a&&t.disableAllAds(t.extractPatterns(a));var n=t.extractAPICall(i,"disableContentAds");n&&t.disableContentAds(t.extractPatterns(n));var s=t.extractAPICall(i,"disablePlaylistPlayers");s&&t.disablePlaylistPlayers(t.extractPatterns(s))}))},t.prototype.extractPatterns=function(t){var e=t.match(/\'(.*?)\'/g);if(null!==e)return e.map((function(t){return t.replace(/'/g,"")}))},t.prototype.extractAPICall=function(t,e){var i=new RegExp(e+"\\((.*?)\\)","g"),a=t.match(i);return null!==a&&a[0]},t.prototype.disableAllAds=function(t){t&&!e(t)||(this.all=!0,this.reasons.add("all_page"))},t.prototype.disableContentAds=function(t){t&&!e(t)||(this.content=!0,this.recipe=!0,this.locations.add("Content"),this.locations.add("Recipe"),this.reasons.add("content_plugin"))},t.prototype.disablePlaylistPlayers=function(t){t&&!e(t)||(this.video=!0,this.locations.add("Video"),this.reasons.add("video_page"))},t.prototype.urlHasEmail=function(t){if(!t)return!1;return null!==/([A-Z0-9._%+-]+(@|%(25)*40)[A-Z0-9.-]+\.[A-Z]{2,})/i.exec(t)},t}(),a=window.adthriveCLS;return a&&(a.disableAds=new i(window.adthrive)),t.ClsDisableAds=i,Object.defineProperty(t,"__esModule",{value:!0}),t}({});</script><script id='cls-header-insertion-886f5bb'>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</script> </head><body data-rsssl=1 class="post-template-default single single-post postid-54939 single-format-standard custom-background"><div id="site"><div id="wrapper"><div id="nav-main-wrapper"><div id="nav-main"><div id="nav-main-left"><div id="nav-logo"> <a href="https://cavaliersnation.com"><img src="https://cavaliersnation.com/wp-content/uploads/2019/05/cnwebsite12.png" alt="Cavaliers Nation" /></a></div><ul class="nav-main"><div class="menu-home-container"><ul id="menu-home" class="menu"><li id="menu-item-75" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75"><a href="https://cavaliersnation.com/">Home</a></li><li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-41"><a title="Categories">Categories</a><ul class="sub-menu"><li id="menu-item-81" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a href="https://cavaliersnation.com/category/game-reports/">Game Reports</a></li><li id="menu-item-82" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82"><a href="https://cavaliersnation.com/category/editorials/">Editorials</a></li><li id="menu-item-84" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84"><a href="https://cavaliersnation.com/category/team-news/">Team News</a></li><li id="menu-item-85" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a href="https://cavaliersnation.com/category/rumors/">Rumors</a></li><li id="menu-item-83" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83"><a href="https://cavaliersnation.com/category/media/">Media</a></li><li id="menu-item-86" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-86"><a href="https://cavaliersnation.com/category/videos/">Videos</a></li></ul></li><li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://cavaliersnation.com/schedule/">Schedule</a></li><li id="menu-item-48" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48"><a href="https://cavaliersnation.com/contributors/">Contributors</a></li><li id="menu-item-40" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a href="https://cavaliersnation.com/about/">About</a></li><li id="menu-item-9117" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9117"><a href="https://cavaliersnation.com/career/">Career</a></li></ul></div></ul><div id="nav-mobi"><div class="menu-home-container"><select><option value="#">Menu</option><option value="https://cavaliersnation.com/">Home</option><option value="">Categories<option value="https://cavaliersnation.com/category/game-reports/">-Game Reports</option><option value="https://cavaliersnation.com/category/editorials/">-Editorials</option><option value="https://cavaliersnation.com/category/team-news/">-Team News</option><option value="https://cavaliersnation.com/category/rumors/">-Rumors</option><option value="https://cavaliersnation.com/category/media/">-Media</option><option value="https://cavaliersnation.com/category/videos/">-Videos</option></option><option value="https://cavaliersnation.com/schedule/">Schedule</option><option value="https://cavaliersnation.com/contributors/">Contributors</option><option value="https://cavaliersnation.com/about/">About</option><option value="https://cavaliersnation.com/career/">Career</option> </select></div></div></div><div id="nav-search"><form method="get" id="searchform" action="https://cavaliersnation.com/"> <input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' /> <input type="hidden" id="search-button" /></form></div></div></div><div id="main-wrapper"><div id="top-spacer"></div><div id="content-outer"><div id="main-top"><div id="ticker"> <span class="ticker-heading">Don't Miss</span><ul class="ticker-list"><li><a href="https://cavaliersnation.com/2022/02/27/isaac-okoro-shows-off-epic-new-award-created-by-cavs-to-honor-teams-gritty-mentality/">Isaac Okoro shows off epic new award created by Cavs to honor team&#8217;s gritty mentality</a></li><li><a href="https://cavaliersnation.com/2022/02/26/report-wizards-star-set-to-miss-clash-vs-cavs/">Report: Wizards star set to miss clash vs. Cavs</a></li><li><a href="https://cavaliersnation.com/2022/02/25/heres-what-j-b-bickerstaff-says-he-needs-from-evan-mobley-going-forward/">Here&#8217;s what J.B. Bickerstaff says he needs from Evan Mobley going forward</a></li><li><a href="https://cavaliersnation.com/2022/02/25/report-lebron-james-museum-opening-in-akron-in-2023/">Report: LeBron James museum opening in Akron in 2023</a></li><li><a href="https://cavaliersnation.com/2022/02/25/j-b-bickerstaff-speaks-on-why-darius-garland-participated-in-all-star-weekend-despite-his-injury/">J.B. Bickerstaff speaks on why Darius Garland participated in All-Star Weekend despite his injury</a></li><li><a href="https://cavaliersnation.com/2022/02/24/report-darius-garlands-injury-will-need-to-be-managed-for-the-remainder-of-the-season/">Report: Darius Garland&#8217;s injury will need to be managed for the remainder of the season</a></li><li><a href="https://cavaliersnation.com/2022/02/24/report-key-update-offered-on-caris-leverts-timetable-for-return/">Report: Key update offered on Caris LeVert&#8217;s timetable for return</a></li><li><a href="https://cavaliersnation.com/2022/02/24/video-members-of-the-2016-cavs-title-team-gloat-about-the-new-kevin-love/">Video: Members of the 2016 Cavs title team gloat about the ‘new’ Kevin Love</a></li><li><a href="https://cavaliersnation.com/2022/02/23/lebron-james-elated-reaction-to-cavs-big-front-office-news/">LeBron James’ elated reaction to Cavs’ big front office news</a></li><li><a href="https://cavaliersnation.com/2022/02/23/jalen-rose-says-lebron-james-should-join-the-cavs-on-a-minimum-contract-if-he-really-wants-to-win-another-title/">Jalen Rose says LeBron James should join the Cavs on a minimum contract if he wants to win a title</a></li></ul></div><div id="content-social"><ul><li><a href="https://www.facebook.com/cavaliersnation" alt="Facebook" class="fb-but" target="_blank"></a></li><li><a href="https://www.twitter.com/wearecavsnation" alt="Twitter" class="twitter-but" target="_blank"></a></li><li><a href="https://www.instagram.com/cavaliersnationdotcom" alt="Instagram" class="instagram-but" target="_blank"></a></li><li><a href="https://cavaliersnation.com/feed/rss/" alt="RSS Feed" class="rss-but"></a></li></ul></div></div><div id="content-inner"><div id="main"><div class="breadcrumb"><div id="crumbs"><a href="https://cavaliersnation.com">Home</a> / <a href="https://cavaliersnation.com/category/media/">Media</a> / <span class="current">Isaac Okoro shows off epic new award created by Cavs to honor team&#8217;s gritty mentality</span></div></div><h1 class="headline">Isaac Okoro shows off epic new award created by Cavs to honor team&#8217;s gritty mentality</h1><div id="post-info-wrapper"><ul class="post-info"><li><div class="post-author">By <a href="https://cavaliersnation.com/author/orel-dizon/" title="Posts by Orel Dizon" rel="author">Orel Dizon</a></div></li><li><ul class="post-social"><li><div class="fb-like" data-send="false" data-layout="button_count" data-width="90" data-show-faces="false"></div></li><li> <a href="https://twitter.com/share" class="twitter-share-button" data-lang="en" data-count="horizontal">Tweet</a></li><li> <g:plusone size="medium" annotation="bubble" width="120"></g:plusone></li><li> <a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fcavaliersnation.com%2F2022%2F02%2F27%2Fisaac-okoro-shows-off-epic-new-award-created-by-cavs-to-honor-teams-gritty-mentality%2F&media=https://cavaliersnation.com/wp-content/uploads/2022/02/Isaac-Okoro-and-J.B.-Bickerstaff-1.jpg&description=Isaac Okoro shows off epic new award created by Cavs to honor team&#8217;s gritty mentality" class="pin-it-button" count-layout="horizontal">Pin It</a></li></ul></li><li><div class="post-update">Updated: February 27, 2022</div></li></ul></div><div id="post-area" class="post-54939 post type-post status-publish format-standard has-post-thumbnail category-media tag-cleveland-cavaliers tag-featured tag-isaac-okoro tag-j-b-bickerstaff tag-news-ticker"><div class="post-image"> <img width="1300" height="968" src="https://cavaliersnation.com/wp-content/uploads/2022/02/Isaac-Okoro-and-J.B.-Bickerstaff-1.jpg" class="attachment-post-thumb size-post-thumb wp-post-image" alt="Isaac Okoro and J.B. Bickerstaff" srcset="https://cavaliersnation.com/wp-content/uploads/2022/02/Isaac-Okoro-and-J.B.-Bickerstaff-1.jpg 1300w, https://cavaliersnation.com/wp-content/uploads/2022/02/Isaac-Okoro-and-J.B.-Bickerstaff-1-300x223.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/02/Isaac-Okoro-and-J.B.-Bickerstaff-1-1024x762.jpg 1024w, https://cavaliersnation.com/wp-content/uploads/2022/02/Isaac-Okoro-and-J.B.-Bickerstaff-1-300x223@2x.jpg 600w" sizes="(max-width: 1300px) 100vw, 1300px" /></div><div id="content-area"><p>The <a title="Cleveland Cavaliers" href="https://cavaliersnation.com/tag/cleveland-cavaliers/">Cleveland Cavaliers</a> eked out a 92-86 win over the Washington Wizards on Saturday night.</p><p>The team needed a solid and gritty defensive effort from its players to snap a three-game losing streak. Second-year wing <a title="Isaac Okoro" href="https://cavaliersnation.com/tag/isaac-okoro/">Isaac Okoro</a> was among those who stepped up on that end of the floor.</p><p>For his effort, the coaching staff bestowed him the Junkyard Dog Award. According to Chris Fedor, the recognition is a recently launched post-victory tradition by Cavs head coach <a title="J.B. Bickerstaff" href="https://cavaliersnation.com/tag/j-b-bickerstaff/">J.B. Bickerstaff</a>.</p><blockquote><p>“It’s a symbol of what we value,” Bickerstaff <a href="https://www.cleveland.com/cavs/2022/02/cleveland-cavaliers-create-junkyard-dog-award-to-help-celebrate-gritty-hard-nosed-style.html">told</a> cleveland.com following the 92-86 victory. “It’s something that was created by our guys, so we tried to come up with something that would celebrate that and add to our culture. We wanted to celebrate their mentality.”</p></blockquote><p>Okoro&#8217;s numbers did not stand out on Saturday. He recorded just six points, four rebounds and three assists. But the tenacity he displayed in the victory did not go unnoticed. There was even a particular play late in the fourth quarter where he poked the ball away from Kyle Kuzma to disrupt the Wizards&#8217; offense.</p><p>The 21-year-old helped limit Kuzma in the fourth quarter after the Wizards forward recorded 28 points before the final frame. Kuzma finished with 34 points.</p><p>Okoro proudly showed off his new hardware on Instagram after the contest.</p><blockquote class="instagram-media" style="background: #FFF; border: 0; border-radius: 3px; box-shadow: 0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width: 540px; min-width: 326px; padding: 0; width: calc(100% - 2px);" data-instgrm-captioned="" data-instgrm-permalink="https://www.instagram.com/p/Cad_PoQuErI/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="14"><div style="padding: 16px;"><p>&nbsp;</p><div style="display: flex; flex-direction: row; align-items: center;"><div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display: block; height: 50px; margin: 0 auto 12px; width: 50px;"></div><div style="padding-top: 8px;"><div style="color: #3897f0; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: 550; line-height: 18px;">View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #f4f4f4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style="width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg);"></div></div><div style="margin-left: auto;"><div style="width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style="background-color: #f4f4f4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style="width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;"><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;"></div><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;"></div></div><p>&nbsp;</p><p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;"><a style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px; text-decoration: none;" href="https://www.instagram.com/p/Cad_PoQuErI/?utm_source=ig_embed&amp;utm_campaign=loading" target="_blank" rel="noopener">A post shared by Isaac Okoro (@isaacokoro)</a></p></div></blockquote><p><script async src="//www.instagram.com/embed.js"></script><br /> Bickerstaff reportedly began the process of making the custom-made gold chain months ago. All of its details apparently hold significant meanings.</p><blockquote><p>&#8220;Bickerstaff started the chain-making process months ago,&#8221; Fedor wrote. &#8220;The finished product was disclosed Saturday night &#8212; a gigantic Cavs &#8216;C&#8217; logo. It’s gold with numerous jewels and special engravings. The five core values &#8212; details, toughness, together, compete, 1 More &#8212; are featured. &#8216;JYD&#8217; is on the back. There’s a sprinkling of other intricate details &#8212; a combination of meaningful team markings and other connections to traditions.</p><p>&#8220;The award doesn’t necessarily go to the player with the most points, assists or rebounds. It’s reserved for the grittiest, most impactful. In Bickerstaff’s own words, the guy who brings the most scrap.&#8221;</p></blockquote><p>The upstart Cavs have been one of the most pleasant surprises in the league this season. They are currently 36-24, which puts them toward the top of the Eastern Conference. Cleveland is on pace to reach its first playoffs since <a title="LeBron James" href="https://cavaliersnation.com/tag/lebron-james/">LeBron James</a> left several seasons ago.</p><p>The team is slated to face the Minnesota Timberwolves at home on Monday.</p><div id="contentad123909"></div> <script type="text/javascript">(function(d) {
        var params =
        {
            id: "e576b5e3-63b7-43fe-8588-310c094931f8",
            d:  "Y2F2YWxpZXJzbmF0aW9uLmNvbQ==",
            wid: "123909",
            cb: (new Date()).getTime()
        };

        var qs=[];
        for(var key in params) qs.push(key+'='+encodeURIComponent(params[key]));
        var s = d.createElement('script');s.type='text/javascript';s.async=true;
        var p = 'https:' == document.location.protocol ? 'https' : 'http';
        s.src = p + "://api.content-ad.net/Scripts/widget2.aspx?" + qs.join('&');
        d.getElementById("contentad123909").appendChild(s);
    })(document);</script> <div class="post-tags"> <a href="https://cavaliersnation.com/tag/cleveland-cavaliers/" rel="tag">cleveland cavaliers</a><a href="https://cavaliersnation.com/tag/featured/" rel="tag">featured</a><a href="https://cavaliersnation.com/tag/isaac-okoro/" rel="tag">isaac okoro</a><a href="https://cavaliersnation.com/tag/j-b-bickerstaff/" rel="tag">j.b. bickerstaff</a><a href="https://cavaliersnation.com/tag/news-ticker/" rel="tag">news ticker</a></div><div class="prev-next-wrapper"><div class="prev-post"> &larr; Previous Story <a href="https://cavaliersnation.com/2022/02/25/heres-what-j-b-bickerstaff-says-he-needs-from-evan-mobley-going-forward/" rel="prev">Here&#8217;s what J.B. Bickerstaff says he needs from Evan Mobley going forward</a></div><div class="next-post"></div></div></div><div id="related-posts"><h3>Related Posts</h3><ul><li><div class="related-image"> <a href="https://cavaliersnation.com/2022/02/26/report-wizards-star-set-to-miss-clash-vs-cavs/" rel="bookmark" title="Report: Wizards star set to miss clash vs. Cavs"><img width="300" height="195" src="https://cavaliersnation.com/wp-content/uploads/2022/02/USATSI_17672219-300x195.jpg" class="attachment-large-thumb size-large-thumb wp-post-image" alt="Kristaps Porzingis" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2022/02/USATSI_17672219-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/02/USATSI_17672219-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2022/02/USATSI_17672219-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="related-text"> <a href="https://cavaliersnation.com/2022/02/26/report-wizards-star-set-to-miss-clash-vs-cavs/" class="main-headline">Report: Wizards star set to miss clash vs. Cavs</a></div></li><li><div class="related-image"> <a href="https://cavaliersnation.com/2022/02/25/heres-what-j-b-bickerstaff-says-he-needs-from-evan-mobley-going-forward/" rel="bookmark" title="Here&#8217;s what J.B. Bickerstaff says he needs from Evan Mobley going forward"><img width="300" height="195" src="https://cavaliersnation.com/wp-content/uploads/2022/02/USATSI_17650278_168386351_lowres-300x195.jpg" class="attachment-large-thumb size-large-thumb wp-post-image" alt="Evan Mobley Cavs" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2022/02/USATSI_17650278_168386351_lowres-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/02/USATSI_17650278_168386351_lowres-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2022/02/USATSI_17650278_168386351_lowres-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="related-text"> <a href="https://cavaliersnation.com/2022/02/25/heres-what-j-b-bickerstaff-says-he-needs-from-evan-mobley-going-forward/" class="main-headline">Here&#8217;s what J.B. Bickerstaff says he needs from Evan Mobley going forward</a></div></li><li><div class="related-image"> <a href="https://cavaliersnation.com/2022/02/25/report-lebron-james-museum-opening-in-akron-in-2023/" rel="bookmark" title="Report: LeBron James museum opening in Akron in 2023"><img width="300" height="195" src="https://cavaliersnation.com/wp-content/uploads/2022/02/031621_la_lebronsmilingap-2-300x195.jpeg" class="attachment-large-thumb size-large-thumb wp-post-image" alt="LeBron James" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2022/02/031621_la_lebronsmilingap-2-300x195.jpeg 300w, https://cavaliersnation.com/wp-content/uploads/2022/02/031621_la_lebronsmilingap-2-615x400.jpeg 615w, https://cavaliersnation.com/wp-content/uploads/2022/02/031621_la_lebronsmilingap-2-108x70.jpeg 108w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="related-text"> <a href="https://cavaliersnation.com/2022/02/25/report-lebron-james-museum-opening-in-akron-in-2023/" class="main-headline">Report: LeBron James museum opening in Akron in 2023</a></div></li></ul></div><div id="comments"><p> You must be logged in to post a comment <a href="https://cavaliersnation.com/wp-login.php?redirect_to=https%3A%2F%2Fcavaliersnation.com%2F2022%2F02%2F27%2Fisaac-okoro-shows-off-epic-new-award-created-by-cavs-to-honor-teams-gritty-mentality%2F"> Login </a></p></div></div><div id="sidebar-wrapper"><div class="widget-container"><div class="widget-inner"><h4 class="widget-header">About Orel Dizon</h4><div class="author-image"> <img class="avatar avatar-60 photo" width="64" height="64" src="https://cavaliersnation.com/wp-content/uploads/2019/10/13509068_1021374311279727_8222685363074163976_n-7-300x300.jpg"/></div><p class="author-box gd-widgets">Orel is a freelance writer who is passionate about the NBA. He has followed the league since the late '90s and found increased interest in it in 2003 – when an 18-year-old prodigy from Akron, Ohio took the league by storm.</p></div></div><div class="widget-container"> <span class="blog-cat-title">Recent</span><div class="widget-img"> <a href="https://cavaliersnation.com/2022/02/24/report-darius-garlands-injury-will-need-to-be-managed-for-the-remainder-of-the-season/" rel="bookmark" title="Report: Darius Garland&#8217;s injury will need to be managed for the remainder of the season"><img width="300" height="195" src="https://cavaliersnation.com/wp-content/uploads/2022/02/image-66-300x195.jpg" class="attachment-large-thumb size-large-thumb wp-post-image" alt="Darius Garland Cavs" loading="lazy" srcset="https://cavaliersnation.com/wp-content/uploads/2022/02/image-66-300x195.jpg 300w, https://cavaliersnation.com/wp-content/uploads/2022/02/image-66-615x400.jpg 615w, https://cavaliersnation.com/wp-content/uploads/2022/02/image-66-108x70.jpg 108w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="widget-inner"><h3 class="home-title1"><a href="https://cavaliersnation.com/2022/02/24/report-darius-garlands-injury-will-need-to-be-managed-for-the-remainder-of-the-season/" rel="bookmark">Report: Darius Garland&#8217;s injury will need to be managed for the remainder of the season</a></h3><p class="gd-widgets">The Cleveland Cavaliers are getting ready to resume their 2021-22 season after the All-Star break. While the Cavs are...</p><ul class="home-links1"><li><a href="https://cavaliersnation.com/2022/02/24/report-key-update-offered-on-caris-leverts-timetable-for-return/" rel="bookmark">Report: Key update offered on Caris LeVert&#8217;s timetable for return</a></li><li><a href="https://cavaliersnation.com/2022/02/23/report-cavs-were-talking-to-collin-sexton-about-an-extension-worth-around-20-million-per-year-before-his-injury/" rel="bookmark">Report: Cavs were talking to Collin Sexton about extension worth around $20 million per year before his injury</a></li><li><a href="https://cavaliersnation.com/2022/02/21/report-everyone-on-cavs-knew-lebron-james-was-playing-under-form-of-protest-during-part-of-final-season-in-cleveland/" rel="bookmark">Report: Everyone on Cavs knew LeBron was playing under &#8216;form of protest&#8217; in part of final year with team</a></li><li><a href="https://cavaliersnation.com/2022/02/15/report-lebron-james-wouldnt-extend-deal-with-cavs-so-team-traded-kyrie-irving-for-picks-instead-of-trying-for-paul-george/" rel="bookmark">Report: LeBron wouldn&#8217;t extend deal with Cavs, so team dealt Kyrie for picks instead of chasing Paul George</a></li></ul></div></div><div class="widget-container"><div id="yikes_easy_mc_widget-5" class="widget-inner widget_yikes_easy_mc_widget"><h4 class="widget-header">Subscribe to get your daily Cleveland Cavaliers news, rumors, and videos!</h4><section id="yikes-mailchimp-container-1" class="yikes-mailchimp-container yikes-mailchimp-container-1 "><form id="cavaliers-nation-1" class="yikes-easy-mc-form yikes-easy-mc-form-1  " method="POST" data-attr-form-id="1"> <label for="yikes-easy-mc-form-1-EMAIL"  class="EMAIL-label yikes-mailchimp-field-required "> <span class="EMAIL-label"> Email Address </span> <input id="yikes-easy-mc-form-1-EMAIL"  name="EMAIL"  placeholder=""  class="yikes-easy-mc-email "  required="required" type="email"  value=""> </label> <label for="yikes-easy-mc-form-1-FNAME"  class="FNAME-label "> <span class="FNAME-label"> First Name </span> <input id="yikes-easy-mc-form-1-FNAME"  name="FNAME"  placeholder=""  class="yikes-easy-mc-text "   type="text"  value=""> </label> <label for="yikes-easy-mc-form-1-LNAME"  class="LNAME-label "> <span class="LNAME-label"> Last Name </span> <input id="yikes-easy-mc-form-1-LNAME"  name="LNAME"  placeholder=""  class="yikes-easy-mc-text "   type="text"  value=""> </label> <input type="hidden" name="yikes-mailchimp-honeypot" id="yikes-mailchimp-honeypot-1" value=""> <input type="hidden" name="yikes-mailchimp-associated-list-id" id="yikes-mailchimp-associated-list-id-1" value="fd937dddf1"> <input type="hidden" name="yikes-mailchimp-submitted-form" id="yikes-mailchimp-submitted-form-1" value="1"> <button type="submit" class="yikes-easy-mc-submit-button yikes-easy-mc-submit-button-1 btn btn-primary "> <span class="yikes-mailchimp-submit-button-span-text">Submit</span></button> <input type="hidden" id="yikes_easy_mc_new_subscriber_1" name="yikes_easy_mc_new_subscriber" value="72bedbe639"> <input type="hidden" name="_wp_http_referer" value="/2022/02/27/isaac-okoro-shows-off-epic-new-award-created-by-cavs-to-honor-teams-gritty-mentality/" /></form></section></div></div></div></div></div></div></div></div><div id="footer-wrapper"><div id="footer"><div id="footer-nav"><div class="menu-home-container"><ul id="menu-home-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75"><a href="https://cavaliersnation.com/">Home</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-41"><a title="Categories">Categories</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a href="https://cavaliersnation.com/category/game-reports/">Game Reports</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82"><a href="https://cavaliersnation.com/category/editorials/">Editorials</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84"><a href="https://cavaliersnation.com/category/team-news/">Team News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a href="https://cavaliersnation.com/category/rumors/">Rumors</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83"><a href="https://cavaliersnation.com/category/media/">Media</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-86"><a href="https://cavaliersnation.com/category/videos/">Videos</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39"><a href="https://cavaliersnation.com/schedule/">Schedule</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48"><a href="https://cavaliersnation.com/contributors/">Contributors</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a href="https://cavaliersnation.com/about/">About</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9117"><a href="https://cavaliersnation.com/career/">Career</a></li></ul></div></div><div id="copyright"><p>Copyright © 2014 Cavaliers Nation, All Rights Reserved. Property of <a href="https://ahnfiredigital.com">Ahn Fire Digital</a>. Partner with USA Today Sports Digital
Properties. <a href="https://cavaliersnation.com/privacy-policy">Privacy Policy</a></p></div></div></div></div> <script id='cls-insertion-886f5bb'>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</script><script>(function () {var clsElements = document.querySelectorAll("script[id^='cls-']"); window.adthriveCLS && clsElements && clsElements.length === 0 ? window.adthriveCLS.injectedFromPlugin = false : ""; })();</script> <script type='text/javascript'>//

jQuery(document).ready(function($){

  $(window).load(function(){

    $('.flexslider').flexslider({

	animation: 'fade',

	slideshowSpeed: 8000

    	});

  	});



$('.carousel').elastislide({

	imageW 	: 80,

	minItems	: 2,

	margin		: 3

});

});

//</script> <script type="text/javascript">//

!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.async=true;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");

//</script> <script type="text/javascript">//

(function() {

    window.PinIt = window.PinIt || { loaded:false };

    if (window.PinIt.loaded) return;

    window.PinIt.loaded = true;

    function async_load(){

        var s = document.createElement("script");

        s.type = "text/javascript";

        s.async = true;

        s.src = "https://assets.pinterest.com/js/pinit.js";

        var x = document.getElementsByTagName("script")[0];

        x.parentNode.insertBefore(s, x);

    }

    if (window.attachEvent)

        window.attachEvent("onload", async_load);

    else

        window.addEventListener("load", async_load, false);

})();

//</script> <script type="text/javascript">//

  (function() {

    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;

    po.src = 'https://apis.google.com/js/plusone.js';

    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);

  })();

//</script> <div id="fb-root"></div> <script type="text/javascript">//

(function(d, s, id) {

  var js, fjs = d.getElementsByTagName(s)[0];

  if (d.getElementById(id)) return;

  js = d.createElement(s); js.id = id;

  js.async = true;

  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";

  fjs.parentNode.insertBefore(js, fjs);

}(document, 'script', 'facebook-jssdk'));

//</script> <script type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/comment-reply.min.js?ver=5.9.1' id='comment-reply-js'></script> <script type='text/javascript' id='stickThis-js-extra'>var sticky_anything_engage = {"element":".ad-728","topspace":"0","minscreenwidth":"0","maxscreenwidth":"999999","zindex":"1","legacymode":"","dynamicmode":"","debugmode":"","pushup":"","adminbar":"1"};</script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/sticky-menu-or-anything-on-scroll/assets/js/stickThis.js?ver=2.1.1' id='stickThis-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/jquery.flexslider.js?ver=5.9.1' id='flexslider-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/jquery.elastislide.js?ver=5.9.1' id='elastislide-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/scripts.js?ver=5.9.1' id='gameday-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/ticker.js?ver=5.9.1' id='ticker-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/respond.min.js?ver=5.9.1' id='respond-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/css3-mediaqueries.js?ver=5.9.1' id='queries-js'></script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/themes/gameday/js/retina.js?ver=5.9.1' id='retina-js'></script> <script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.9.1' async='async' id='remote_sdk-js'></script> <script type='text/javascript' id='yikes-easy-mc-ajax-js-extra'>var yikes_mailchimp_ajax = {"ajax_url":"https:\/\/cavaliersnation.com\/wp-admin\/admin-ajax.php","page_data":"54747","interest_group_checkbox_error":"This field is required.","preloader_url":"https:\/\/cavaliersnation.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/ripple.svg","loading_dots":"https:\/\/cavaliersnation.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/bars.svg","ajax_security_nonce":"22b257e76d","feedback_message_placement":"before"};</script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/yikes-mc-ajax-forms.min.js?ver=6.8.6' id='yikes-easy-mc-ajax-js'></script> <script type='text/javascript' id='form-submission-helpers-js-extra'>var form_submission_helpers = {"ajax_url":"https:\/\/cavaliersnation.com\/wp-admin\/admin-ajax.php","preloader_url":"https:\/\/cavaliersnation.com\/wp-admin\/images\/wpspin_light.gif","countries_with_zip":{"US":"US","GB":"GB","CA":"CA","IE":"IE","CN":"CN","IN":"IN","AU":"AU","BR":"BR","MX":"MX","IT":"IT","NZ":"NZ","JP":"JP","FR":"FR","GR":"GR","DE":"DE","NL":"NL","PT":"PT","ES":"ES"},"page_data":"54747"};</script> <script type='text/javascript' src='https://cavaliersnation.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/form-submission-helpers.min.js?ver=6.8.6' id='form-submission-helpers-js'></script> <script>!function(){"use strict";!function(e){if(-1===e.cookie.indexOf("__adblocker")){e.cookie="__adblocker=; expires=Thu, 01 Jan 1970 00:00:00 GMT; path=/";var t=new XMLHttpRequest;t.open("GET","https://www.npttech.com/advertising.js",!0),t.onreadystatechange=function(){if(XMLHttpRequest.DONE===t.readyState)if(200===t.status){var n=e.createElement("script");n.innerHTML=t.responseText,e.getElementsByTagName("head")[0].appendChild(n)}else{var a=new Date;a.setTime(a.getTime()+3e5),e.cookie="__adblocker=true; expires="+a.toUTCString()+"; path=/"}},t.send()}}(document)}();</script><script>!function(){"use strict";var e;e=document,function(){var t,n;function r(){var t=e.createElement("script");t.src="https://cafemedia-com.videoplayerhub.com/galleryplayer.js",e.head.appendChild(t)}function a(){var t=e.cookie.match("(^|[^;]+)\\s*__adblocker\\s*=\\s*([^;]+)");return t&&t.pop()}function c(){clearInterval(n)}return{init:function(){var e;"true"===(t=a())?r():(e=0,n=setInterval((function(){100!==e&&"false"!==t||c(),"true"===t&&(r(),c()),t=a(),e++}),50))}}}().init()}();</script> </body></html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Object Caching 125/194 objects using disk
Page Caching using disk: enhanced 

Served from: cavaliersnation.com @ 2022-02-27 10:11:25 by W3 Total Cache
-->